Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Keyboard (drivers?) slow to load on startup

12 Jun 2015   #1
charkzilla20

Windows 7 Professional
 
 
Keyboard (drivers?) slow to load on startup

A few times over the last couple years, seemingly randomly, windows will get into a consistent state where it won't receive input from the keyboard after it starts up and is at the login screen. This will last around 30 seconds.
I have a CM Storm Quickfire TK brown keyboard, which works fine.
The mouse works. A Roccat Kone XTD.
I've tried other ports, i've tried some settings in the bios such as fastboot, usb legacy support, usb initialization, etc, but they don't help at all.

So this leads me to believe that windows just doesn't know that there's a keyboard giving it input for a while after startup. Unfortunately, I don't have another keyboard to test this.
It used to be that the keyboard's backlight would come on before the monitor would automatically display the hdmi input after the windows startup, and i could type in my password and log in within seconds after boot. When the monitor displays a few seconds later, I would already be on the desktop...

Any idea why this is occurring?


My System SpecsSystem Spec
.
12 Jun 2015   #2
GokAy

Windows 7 Ultimate x64 SP1
 
 

You can check if there is a service for your keyboard with delayed automatic.
Also try uninstall and re-install keyboard software.
Perhaps a clean startup to see if some other program/service is interfering. Troubleshoot Application Conflicts by Performing a Clean Startup
My System SpecsSystem Spec
28 Jun 2015   #3
charkzilla20

Windows 7 Professional
 
 

Quote   Quote: Originally Posted by GokAy View Post
You can check if there is a service for your keyboard with delayed automatic.
Also try uninstall and re-install keyboard software.
Perhaps a clean startup to see if some other program/service is interfering. Troubleshoot Application Conflicts by Performing a Clean Startup
It seems random.
Like the thing will load up fine and quick and the keyboard works right out of the gate as long as the keyboard was in the same port as it was when it was shut down the last few times :/...

It seems to be working alright now. I'll keep the "clean startup" in mind, but for now, I'm gonna assume it fixed itself.

There is no keyboard software for this thing. I know it sounds weird, but Coolermaster doesn't have any sort of drivers or software on their site for this keyboard. From the start it was just plug-and-play. It works alright for the most part.

Thanks
My System SpecsSystem Spec
.

28 Jun 2015   #4
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

I have 2 plug/play Das keyboards.

I plug them into USB 2.0 not 3.0.
Boot Windows 7 and it installs driver 6.1.7601.17514 and they work.

I do not use Fast Boot/Quick Boot because at time it's to quick and sometimes things don't get loaded.
My System SpecsSystem Spec
09 Jul 2015   #5
charkzilla20

Windows 7 Professional
 
 

I found the culprit. Asus Fan Controller Service.
Set it to delayed start, and it'll adjust the fans normally after boot, and the login page keyboard is quick as normal.

Thanks fellas
My System SpecsSystem Spec
Reply

 Keyboard (drivers?) slow to load on startup




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Deleted bad USB drivers, now on startup, USB keyboard and mouse inop
I recently have been experiencing BSOD with BUGCODE USB error. Machine freezes on startup, then sometimes automatically reboots. Sometimes freezes on startup at different points and has to be unplgged for about an hour before it restarts properly. I read on several threads to uninstall the USB...
Drivers
Slow boot, followed by crash and reset. Very slow repair center load
Running Win7x86, and it started getting extremely slow, within 2 days of this it started refusing to load at all. The system is brand new (ready built from ebuyer), and the only alterations have been a sysfan, spare hdd, spare dvdrw. When trying to load the boot screens take AGES, often...
General Discussion
Slow start-up; crawls into BIOS setup; then slow to load windows
Hi there, please can you help? I realize this BSOD might be a commonly reported problem but the issues here seem not to have been addressed specifically by other threads so I hope I haven't opened a new thread unnecessarily. Anyhow, here goes...:) Various pc problems have arisen since coming...
BSOD Help and Support
USB Sticks slow transfer speeds, system takes forever to load drivers
Hi-have been struggling with my system taking 2-3 minutes to find drivers for any memory stick I plug in to any of 3 USB ports on my Acer 1810T. When the process finally completes, the transfer speeds are about 1MB/s or less. Another (possibly related?) problem is when I insert any SD card in...
Hardware & Devices
Dual booting Kubuntu/Windows7 fail to load drivers or crash at startup
HI, Got a really annoying problem. I am having a dual boot machine with Win7 and Kubuntu 10.04 x64. For some reason every time I have been in Kubuntu and try to reboot into Windows, either a lot drivers fail to load at startup and I have to reboot (which normally leads to everything being okay)...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:45.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App