Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 Home Premium x64 Suddenly Lagging

07 Jul 2015   #1
PrinceAKR

Windows 7 Home Premium 64bit
 
 
Windows 7 Home Premium x64 Suddenly Lagging

Good day.

I've been struggling with this problem for a few days and I've searched high and low trying out different methods, but so far no dice.

This problem started last week when I booted up Spider-Man: Web of Shadows. I noticed my FPS dropped massively; I couldn't even turn the camera without huge amounts of lag and subsequent stutter. I rebooted, and then the same thing happened. Then I pulled out my power cord (using a laptop) and removed the battery, and then I let the unit sit for a few minutes. I put everything back and tried it again and viola—it was fixed.

I thought that would be it, but then a day later the same thing happened. This has been happening constantly and the battery-removal method kept fixing it. But now yesterday, it wouldn't fix itself.

Now ALL my games/programs are lagging, despite the fact that they were running swell.

I'm not sure what the problem is, and I've tried several different things:

- Malware cleaners (adwCleaner, Malwarebytes)
- CCleaner
- Windows Disk Check
- Advanced Systemcare 8 optimization (have been using this for quite some time now)
- SFC Scan (said there are corrupt files but couldn't fix them)

The only thing I haven't done is a Defrag, so that's my next move.


My System SpecsSystem Spec
.
07 Jul 2015   #2
PrinceAKR

Windows 7 Home Premium 64bit
 
 

UPDATE:

It looks like it has something to do with my AC power supply. I just got a message on the screen after a restart that my adapter is no longer recognized...
My System SpecsSystem Spec
Reply

 Windows 7 Home Premium x64 Suddenly Lagging




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Windows 7 Home Premium Suddenly Running Very Slowly
I have had this new laptop for about a month. It's a gaming laptop and I've had no problems until today. Startup which usually takes about 20 seconds from power on to all startup programs functional, now takes 3 minutes with desktop items taking a long time to display. Upon completion of...
Performance & Maintenance
Windows Movie Maker on Windows 7 Home Premium Suddenly Not Working
Hello friends! I make a bunch of videos for YT, and ever so often, I want to make a quick video on WMM. Yesterday, I was working on a project (with a bunch of large files) when I split a clip. The first part of the clip turned black in the thumbnail section and wouldn't play in the preview. ...
Software
Suddenly lagging in every game I try to play?
Hi everyone! I was just playing counter strike when suddenly out of nowhere my fps dropped down to like 20. I thought "whatever, it might be a random lagspike, happens sometimes". It has always been at 100 and only sometimes drops to 90-95 but now since this "whatever lagspike" it just hasn't...
Performance & Maintenance
Windows 7 Home Premium 64 bit Suddenly extremely slow, wont shut down
I came home to and found my mother upset because her Windows 7 Home Premium 64 bit laptop had suddenly become extremely slow. She had tried shutting it down, but it isn't shutting down right. THe task bar and icons disappear, but the background stays and it just stays there, like it was in a coma....
Performance & Maintenance
Games suddenly lagging
I've been playing NBA 2K12 and Assassin's Creed Revelations for a while now and have until recently been able to play both games on high settings with no lag. The games ran flawlessly until about two or so days ago. I tried installing the latest graphics driver for my GTX 560 and it made the...
Gaming
Windows 7 Home Premium - suddenly boots longer
Hi everyone, A couple of days ago my laptop started to boot longer than it used to for the last six months. I have spent the last days searching for a solution and followed advices I have found. The boot time before the problem appeared was about 57 seconds, now it takes 120 seconds to boot up. I...
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:37.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App