Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: drive label stuck as "OS Install" when no label is assigned

12 Jul 2015   #1
bangdosa

Win 7 Ultimate x64 bit SP1
 
 
drive label stuck as "OS Install" when no label is assigned

Hello, not sure if this is the correct area to ask, but I've noticed that my E drive's label is stuck as "OS Install" when there is no label assigned. I thought at first there was a label assigned to it and followed renaming labels option 3 on the forums (as a DVD drive was assigned to the letter). But when I assigned a USB drive to the E drive after switching out the dvd drive's letter, I noticed that it keeps the "OS Install" as default label instead of the normal "removable disk" when no label is assigned. This held true with the internal hard drive's partition as well. However when I assigned a drive label such as "CRUZER", it would change to the assigned label. As I like to have my E drive be the dvd drive, I don't want to see this weird label on it when I didn't assign it. If anyone knows a solution or can help me to try to find one, it would be great! I've attached pictures to explain better

drive label stuck as "OS Install" when no label is assigned-1-.png
drive label stuck as "OS Install" when no label is assigned-2.png
drive label stuck as "OS Install" when no label is assigned-3.png




My System SpecsSystem Spec
.
12 Jul 2015   #2
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

Please use this tutorial by Golden to post a screen shot of Disk Management.

Leave all the clutter off of the pick. Just post exactly as the tutorial instructs.
This will allow other members to see the need basic information.

Disk Management - Post a Screen Capture Image
My System SpecsSystem Spec
12 Jul 2015   #3
bangdosa

Win 7 Ultimate x64 bit SP1
 
 

like this?
drive label stuck as "OS Install" when no label is assigned-1.png
I don't see the point. That doesn't show the disk drive label since its a nonlabeled dvd drive.


My System SpecsSystem Spec
.

12 Jul 2015   #4
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

Your D/M looks normal.

Just exactly what are you trying to see that you don't see?

I'm really not sure what you are trying to do or trying to see when you do something. I'm now sure what that something is.
My System SpecsSystem Spec
12 Jul 2015   #5
bangdosa

Win 7 Ultimate x64 bit SP1
 
 

if you look at the first picture I uploaded looking at the dvd drive on the explorer, it says "DVD RW drive (E:) OS Install". As I have never put in a label for the dvd drive, it should just say "DVD RW drive (E:)." when I used disk management to change the E drive with a USB disk, when the usb is not labeled, it still says "OS Install" when it should be "Removable Disk." Only when I give the drive in the E disk position a label, will "OS Install" disappear. It seems to me that the E drive position has changed its default non label to "OS Install" and I want to reset it back to normal.
My System SpecsSystem Spec
12 Jul 2015   #6
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

Okay I think I understand what you want.
You want something like this. Is that correct?

I don't have a Rename option for my DVD drive. Maybe making the DVD drive letter (D) would bring it back to normal. If you change the DVD drive letter make sure you reboot.



drive label stuck as "OS Install" when no label is assigned-hard-disk-drive.jpg


My System SpecsSystem Spec
13 Jul 2015   #7
bangdosa

Win 7 Ultimate x64 bit SP1
 
 

yeah that's what I want, but the problem isn't with the dvd drive, but rather with the drive letter (E). DVD drives normally do not have the option to rename. also when I changed the drive letter of my second partition to E, the same problem occurred when no label was placed for the partition. same being true when I placed a USB stick as E drive as shown in the picture. It probably means that the E drive's default labeling scheme has a problem, and I'd like to fix that.
My System SpecsSystem Spec
13 Jul 2015   #8
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

Did you try using a different partition letter for you data drive and use the (D) for your DVD player?

If you want to change the Drive Name not the Drive letter you do that from here with a right tick on the drive.

drive label stuck as "OS Install" when no label is assigned-drive-name-change.png


My System SpecsSystem Spec
13 Jul 2015   #9
DavidE

Multi-Boot W7_Pro_x64 W8.1_Pro_x64 W10_Pro_x64
 
 

Did you use this tutorial by Brink, and look for autorun.inf files and look in the registry ?
Drive - Rename
My System SpecsSystem Spec
13 Jul 2015   #10
Layback Bear

Windows 7 Pro. 64/SP-1
 
 

Good find David.
Great little tutorial.
My System SpecsSystem Spec
Reply

 drive label stuck as "OS Install" when no label is assigned




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Partition table issue - "unparititoned space" label stuck.
Hi guys i was using one of the paritioning softwares and i ended up with the parition table as given in the attached pic. is there an easy way to fix the partition table by removing the "unpartitioned space" fictitious labels in the table between e and f drives? Imgur ...
General Discussion
Changing second drive label.
So I added a drive label and now cant figure out how to remove it, seen in the image provided I want to remove the words "HotSwap". UPDTE: It seems that the "HotSwap" is attached to the drive letter, not the drive as any drive on G gets the label.
Hardware & Devices
incorrect "system" partion label
I set windows up over 6 months back now, for some unknown reason win 7 has labeled my very old PATA device as a system partition despite being a storage device. i have no clue why its labeled system. is there a simple way to un label it as system? when i disconnect the device and attempt a...
Installation & Setup
"Safely remove hardware" not showing drive letter/label
From my "Safely remove hardware and eject media" I get a dialog that says: Open Devices and Printers ------------------------- Ian's pc - Eject ST320005 42A2 SCSI Disk Device - Eject ST320005 42A2 SCSI Disk Device
Hardware & Devices
"My Computer" has lost it's label?
I'm having an issue with "My Computer" no longer having any label (text) for it . Screens: http://img402.imageshack.us/img402/9379/screenshot1fz.jpg http://img36.imageshack.us/img36/6821/screenshot2yy.jpg http://img15.imageshack.us/img15/8683/screenshot4bn.jpg Any ideas?
General Discussion
Custom HDD Volume Label Not Displayed in "My Computer"
Hi Everyone, I need help with this issue that I'm having... Please look at the attachment and you'll notice that my Hard disks' volume labels are all set to "Local Disk" in my Computer, even if I rename them, the label doesn't change in "my computer", as you can see in the Disk management window...
Hardware & Devices


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:56.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App