Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Svchost.exe constantly taking up about 50% CPU and lots of memory.

14 Jul 2015   #1
DarkGhost

Windows 7 home premium x64
 
 
Svchost.exe constantly taking up about 50% CPU and lots of memory.

The problem is svchost.exe (localservice). I have posted an image which contains all services under that process.

Please help me SevenForums, you're my only hope.




Attached Images
Svchost.exe constantly taking up about 50% CPU and lots of memory.-svchost-problem.jpg 
My System SpecsSystem Spec
.
14 Jul 2015   #2
GokAy

Windows 7 Ultimate x64 SP1
 
 

Is this happening every boot? Open a resource monitor and switch to CPU tab, sort by CPU. See if you can get additional info, take a screenshot if you can and post here.
My System SpecsSystem Spec
14 Jul 2015   #3
DarkGhost

Windows 7 home premium x64
 
 

It does not start at boot, it seems to be random as to when it starts but once it begins it does not go away. As for what you want can you be more specific? I opened the resource monitor but am not sure what you want me to show you.

Here is two images from the resource monitor.


Attached Thumbnails
Svchost.exe constantly taking up about 50% CPU and lots of memory.-svchost-resmon1.jpg   Svchost.exe constantly taking up about 50% CPU and lots of memory.-svchost-resmon2.jpg  
My System SpecsSystem Spec
.

14 Jul 2015   #4
GokAy

Windows 7 Ultimate x64 SP1
 
 

In CPU tab of Resource Monitor sort by CPU (like you did), now tick the "svchost.exe (LocalService)" at left most column (Services part will now show only LocalService ones). Lets see which one actually consumes CPU time.
My System SpecsSystem Spec
14 Jul 2015   #5
DarkGhost

Windows 7 home premium x64
 
 

OK found it. I think. It was the tab just below processes in the cpu tab. Tell me if you need anything else.

EDIT: the nsi shows up as "network store interface service"


Attached Thumbnails
Svchost.exe constantly taking up about 50% CPU and lots of memory.-svchost-resmon3.jpg  
My System SpecsSystem Spec
14 Jul 2015   #6
Callender

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

For your AMD machine try a different graphics driver.

See Posts #81 & #82 in the thread here and read earlier posts about services running under that particular svchost instance. Ignore the stuff about windows updates. That's a different problem relating to a different svchost instance.

svchost.exe (netsvcs) draining all my memory
My System SpecsSystem Spec
14 Jul 2015   #7
GokAy

Windows 7 Ultimate x64 SP1
 
 

The few links I found for NIS suggest:
- a clean startup - Troubleshoot Application Conflicts by Performing a Clean Startup
- a scan with Malwarebytes Anti-Malware (enable root kit scanning in settings - detections too).
My System SpecsSystem Spec
14 Jul 2015   #8
DarkGhost

Windows 7 home premium x64
 
 

The problem with this is that I have never updated the graphics driver. Any suggestions on this?

As for Malwarebytes Anti-Malware, wouldn't this conflict with Eset Smart Security?

I will look into the clean start up but honestly I am not sure how far I will be able to get with that due to this issue not popping up at a predictable time.

Could this have anything to do with an issue that the Eset firewall had recently?

7/12/2015 6:02:55 PM Duplicate IP addresses detected in network ***.***.1.5 ***.***.1.2 ARP
7/12/2015 6:02:02 PM Detected ARP cache poisoning attack ***.***.1.5 ***.***.1.2 ARP

I did a check and everything seemed to say that it is just something that Eset picks up sometimes. After checking to make sure it was not someone trying to get into my network I should add the 1.5 (which is another system in the network) to the zone as being exempt from active protection.
My System SpecsSystem Spec
14 Jul 2015   #9
GokAy

Windows 7 Ultimate x64 SP1
 
 

MBAM is not an AV itself. It supplements and works nicely (and advised to run) along with a proper AV.

You will have to wait for the issue to happen and decide if it has been fixed with a clean startup (after waiting for enough time). Then you can start enabling services and startup programs a few at a time and wait again. It is tedious especially when issue doesn't happen every boot.
My System SpecsSystem Spec
14 Jul 2015   #10
DarkGhost

Windows 7 home premium x64
 
 

I will get it.

Could clean startup cause system instability or cause issues somewhere like in the browser? Would that also turn of Eset?

Would turning down the priority help or hurt?
My System SpecsSystem Spec
Reply

 Svchost.exe constantly taking up about 50% CPU and lots of memory.




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
SVCHOST.EXE(netsvc) taking up all memory on a freshly formatted system
Hello everyone. Long time lurker, first time poster. I have ran into a problem and would like to ask for some help. I help around my office when computers go bad, and diagnose and fix. But this one has me stumped. A lady needed some help yesterday with a very slow and laggy computer (it...
General Discussion
svchost.exe taking up too much CPU
It's an ASUS U50Vg Laptop Windows 7 Ultimate x64 Intel Core2Duo T6600 @ 2.2GHz 4GB RAM NVIDIA GeForce G105M Here are the screenshots...
Performance & Maintenance
svchost.exe taking up too much CPU?
I've been having an odd problem as of late and am not entirely sure on what to do about it. you see, I've been having some slow down issues with my p/c and the process that I've discovered to cause the slow down is svchost.exe. I know that svchost.exe is an important process for the computer, but...
Performance & Maintenance
Svchost taking too much memory
my svhost process is taking too much Memory... making my computer lag..it havent happened any time before... http://www.pikipimp.com/pp/pimped_photo/s/image/52/806/368/Capture.PNG?ts=1264555978397:shock::shock::shock: please suggest a solution..
Performance & Maintenance
svchost.exe using lots of memory
Hello, I noticed my memory usage was at 42%, when it is usually 25-30%. I opened task manager and found 12 different processes of svchost.exe running. One of then was using 149,156 k of memory, from which I understand is a whole lot. Is this normal? And if it isn't how do I fix it? Thanks in...
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 22:53.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App