Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Need to verify my "path" System Environment Variable

25 Jul 2015   #1
Windows Curious

Windows 7 Home Premium x64
 
 
Need to verify my "path" System Environment Variable

I have recently added Java 8 JDK and have had problems getting the javac to run in cmd prompt. I have many tutorials trying to correct this issue and it seems nothing is correcting it. I am using a 64bit Win7Home Premium Asus laptop, and would appreciate some help verifying that my pre-existing path is not causing an issue. For what it is my startup has always taken roughly two minutes, even before anything additional was installed.

There was not a semi-colon at the end of it, and a few places looked suspicious. I am not very familiar with what this path should be so I created a new variable "PATH" to insert the bin location for javac to work. Javac is now recognized when I type javac or javac -version... but not when I try to run my .java file to be turned into byte code.

After reconsideration I removed the path and will supply it to a recognized member who is willing to assist. I did not want to leave it exposed as views were climbing without any replies.


My System SpecsSystem Spec
.
26 Jul 2015   #2
GokAy

Windows 7 Ultimate x64 SP1
 
 

We gonna steal your paths!

Mine would look like this:
Code:
PATH=C:\Program Files (x86)\Common Files\Microsoft Shared\Windows Live;C:\Progra
mData\Oracle\Java\javapath;C:\Windows\system32;C:\Windows;C:\Windows\System32\Wb
em;C:\Windows\System32\WindowsPowerShell\v1.0\;C:\Program Files (x86)\Common Fil
es\Acronis\SnapAPI\;C:\Program Files (x86)\NVIDIA Corporation\PhysX\Common;C:\Pr
ogram Files\Windows Imaging\;C:\Program Files (x86)\Windows Kits\8.1\Windows Per
formance Toolkit\;C:\Program Files (x86)\QuickTime\QTSystem\;C:\Program Files\Co
mmon Files\Microsoft Shared\Windows Live
Sometimes you need a JAVA_HOME path set in Environment variables. Installing the JDK Software and Setting JAVA_HOME (Using the GlassFish ESB Installation CLI)
My System SpecsSystem Spec
26 Jul 2015   #3
Ztruker

Windows 10 Pro X64
 
 

If you want help, provide the path again.
My System SpecsSystem Spec
.

27 Jul 2015   #4
Windows Curious

Windows 7 Home Premium x64
 
 
Path

Hey guys here it is again and honestly I was not sure if I should have been paranoid or not, I was just thinking too much.

C:\ProgramData\Oracle\Java\javapath;C:\Program Files (x86)\Intel\iCLS Client\;C:\Program Files\Intel\iCLS Client\;C:\Program Files\Common Files\Microsoft Shared\Windows Live;C:\Program Files (x86)\Common Files\Microsoft Shared\Windows Live;%SystemRoot%\system32;%SystemRoot%;%SystemRoot%\System32\Wbem;%SYSTEMROOT%\System32\WindowsPowe rShell\v1.0\;C:\Program Files (x86)\Windows Live\Shared;C:\Program Files (x86)\Intel\OpenCL SDK\2.0\bin\x86;C:\Program Files (x86)\Intel\OpenCL SDK\2.0\bin\x64;C:\Program Files\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\DAL;C:\Program Files (x86)\Intel\Intel(R) Management Engine Components\IPT;C:\Program Files\Intel\WiFi\bin\;C:\Program Files\Common Files\Intel\WirelessCommon\;C:\Program Files (x86)\Microsoft SQL Server\100\Tools\Binn\;C:\Program Files (x86)\Microsoft SQL Server\100\DTS\Binn\

I was just concerned.
My System SpecsSystem Spec
27 Jul 2015   #5
GokAy

Windows 7 Ultimate x64 SP1
 
 

Did you try adding the JAVA_HOME variable as described in the link I gave?
My System SpecsSystem Spec
27 Jul 2015   #6
Ztruker

Windows 10 Pro X64
 
 

One entry looks hookey to me but may be a cut andf paste problem:

%SYSTEMROOT%\System32\WindowsPowe rShell\v1.0\

There should not be a blank between WindowsPowe and rShell, s/b WindowsPowerShell.
My System SpecsSystem Spec
01 Aug 2015   #7
Windows Curious

Windows 7 Home Premium x64
 
 
Thank you, everyone who tried!

Ok, update... I suffered a catastrophic HDD failure, (mechanical, it seems as nothing runs or is recoverable by any means of a tech shop) since the last post, I have been trying to reinstall everything and try to catch up with some class work, but its not going well. I appreciate the advice but for now I just need to get everything working and it seems like I cannot open zip files of my old submitted assignments that were zipped up with the stock Windows zip, and now I have 7-zip. I am not sure but thank you all for trying to help out. I am certain that my environment path has changed with a clean install on a new or refurbished HDD.
My System SpecsSystem Spec
Reply

 Need to verify my "path" System Environment Variable




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Open a new window with "full path" instead of Search Results\"Path"
How can I make it such that in Search Results, when I open a folder in a new window (by right-clicking a file), I will be directed to a window with the "full path" displayed in the address bar, instead of Search Results\"Path" or Search Results>"Path"? Edit: "Right-click -> open file location"...
General Discussion
Path Environment Variable Deleted
I accidentally removed all the stuff in the Path variable in Environment Variables. Is there any way on how I could get it back?
General Discussion
sfc: "Cannot verify component files for" ... "manifest is damaged"
Thanks to other helpful threads on these forums, I have worked through some maintenance that seems to have resolved the constant BSODs I was having, in large part via sfc /scannow. I believe I only have one issue remaining as far as sfc is concerned: Cannot verify component files for...
Performance & Maintenance
Teracopy: "Open error: The system cannot find the path specified"
I'd like to use Teracopy for all copying etc. but after moving to 7 from xp it's giving me these errors. I have Win 7 Pro 64-bit. I copy from network drive for which I have read and write permissions as windows' own copy works fine. But with teracopy I immediately get error "Open error: The...
Software
"System Can't Find Path Specified" Error During Backup
I automatically back up my hard-drive weekly to an external drive. For several weeks I didn't notice that the capacity of my external drive had been exceeded. At that point I deleted several of the older data file backups, thus giving me ample space on the external drive to once again perform my...
Backup and Restore


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:47.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App