Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: PC running kinda slow

17 Nov 2015   #1
dndwanted

Windows 7 Ultimate x64
 
 
PC running kinda slow

So I have a PC, with Windows 7 Ultimate x64 installed just yesterday. It is running sluggerish if I can say so.
I will try to explain now. When I'm on YouTube, it sometimes freezes to the point that I can see the mouse pointer moving, but I can't click on anything for about 5 seconds. This occurs after I enter and exit fullscreen mode as well. Next thing is that Twitch videos lag. I know for sure that it is not a problem with my ISP.
Sometimes, even when I'm not in browser, it lags. I don't know how to explain, it just feels like it's not fluid. It's like I'm using a pc from 2005.
An Intel i5 4460 with 8GB RAM and R9 280x video card shouldn't have any problem doing this basic things. What I'm trying to ask here is how to fix all those problems and optimize my PC to run at it's potential. I need full details on why it does the things it does and how to fix them, to fully optimize my PC. If you guys need more info, please ask.

Thank you!


My System SpecsSystem Spec
.
17 Nov 2015   #2
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 
my guess

As you said you only installed it yesterday, its more than likely that its downloading the 200+ updates, that uses a lot of bandwidth, give it a good day for those and check back in 3/4 if its still a problem.

Roy
My System SpecsSystem Spec
17 Nov 2015   #3
dndwanted

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by torchwood View Post
As you said you only installed it yesterday, its more than likely that its downloading the 200+ updates, that uses a lot of bandwidth, give it a good day for those and check back in 3/4 if its still a problem.

Roy
Well the thing is, I reinstalled windows because I had the same problems before. It's not from the bandwidth.

And I was talking about the PC in general as well. It sometimes lag or not run fluidly even when I browse through folders.
My System SpecsSystem Spec
.

17 Nov 2015   #4
AddRAM

Windows 7 Pro x64 Windows 10 Pro x64
 
 

I sure hope you don`t have windows update set to automatic

How do you know it`s not your service provider ?

Could you run a speedtest and post a snip of the results for us.

Speedtest.net by Ookla - The Global Broadband Speed Test

Where did you get this Ultimate install dvd from ? Is it retail, did you create it ?
My System SpecsSystem Spec
17 Nov 2015   #5
dndwanted

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by AddRAM View Post
I sure hope you don`t have windows update set to automatic

How do you know it`s not your service provider ?

Could you run a speedtest and post a snip of the results for us.

Speedtest.net by Ookla - The Global Broadband Speed Test

Where did you get this Ultimate install dvd from ? Is it retail, did you create it ?
http://www.speedtest.net/result/4840234624.png

And this is a bad day. :P I have days when down speed is 90+ and up speed 60+

A friend gave me a USB with windows on it. I don't know if it is genuine or not. :/
My System SpecsSystem Spec
17 Nov 2015   #6
AddRAM

Windows 7 Pro x64 Windows 10 Pro x64
 
 

I would download your own iso file and burn to dvd at no faster then x4 speed or reinstall the iso file on the usb stick again.

Do you have a genuine windows 7 Ultimate activation key ?

Did you build the PC ?

Or is it store bought, does it have a COA on it ?

The faster you answer the faster I can help you


Attached Images
PC running kinda slow-hardwarecoa.gif 
My System SpecsSystem Spec
17 Nov 2015   #7
dndwanted

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by AddRAM View Post
I would download your own iso file and burn to dvd at no faster then x4 speed or reinstall the iso file on the usb stick again.

Do you have a genuine windows 7 Ultimate activation key ?

Did you build the PC ?

Or is it store bought, does it have a COA on it ?
It came preactivated. I built my PC.
My System SpecsSystem Spec
17 Nov 2015   #8
AddRAM

Windows 7 Pro x64 Windows 10 Pro x64
 
 

There`s no such thing as pre activated, you will need a genuine key, in order for us to help you.

I would just buy W7 Professional, there`s no need for Ultimate.

Example

Microsoft Windows 7 Professional SP1 64-bit - Operating Systems - Newegg.com
My System SpecsSystem Spec
17 Nov 2015   #9
dndwanted

Windows 7 Ultimate x64
 
 

Quote   Quote: Originally Posted by AddRAM View Post
There`s no such thing as pre activated, you will need a genuine key, in order for us to help you.
Well I need help to optimize my drivers I guess, and maybe clean my PC from unwanted files that may slow it down. How does having a key help you?
My System SpecsSystem Spec
17 Nov 2015   #10
AddRAM

Windows 7 Pro x64 Windows 10 Pro x64
 
 

Well, you want to reinstall windows, correct ?

That will clean up your pc and make it lightning fast.

In order to activate that new install you need an activation key.

In order to get help from this forum your windows must be genuine.

We will be glad to help you after that

You do not optimize drivers, you just install the latest one.

And even that is not always the best idea, if you don`t have any issues with your hardware, it`s not always wise to upgrade a driver.

If you just installed windows yesterday and it`s slow then I would think your installer is shoddy.

Did you check windows update ?

It should be set to this setting.


Attached Images
PC running kinda slow-wus.jpg 
My System SpecsSystem Spec
Reply

 PC running kinda slow




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
My PC running slow
I have a PC with windows 7 installed, Intel Core 2 Quad Q9400 cpu, nvidia 9800 gt graphic card and 4gb ram. I had an issue with the hard disk (bad sectors) and changed it so it's like I did a format. I installed the windows and microsoft security essentials. I use Google Chrome. The matter is...
Performance & Maintenance
Running real slow / shut down slow
Hi i have a Eee Pc Asus laptop that is running real slow could someone help me please thank you i ran a farbar scan if that might help Scan result of Farbar Recovery Scan Tool (FRST) (x86) Version: 19-07-2013 Ran by Ma (administrator) on 21-07-2013 16:25:23 Running from E:\ Microsoft...
Performance & Maintenance
New PC, but running Slow?
Hey, I just got a new PC, my OLD specs are uploaded to my profile so you can see the comparison, and my rough current specs are: Intel i5 760 2.8ghz 4GB DDR3 Corsair 1600mhz RAM CORSAIR CMPSU-400CXUK Silent PSU Nvidia GTS250 Asrock P55 M Pro SKT-1156 motherboard 500GB SATA II Hard Drive ...
Performance & Maintenance
Running very slow. . .
Not 2 days ago, this computer I am currently on was blazing fast as usual, now since the past 2 days it has been on a horrid roller-coaster spiraling downward to very poor performance. The mouse jumps around and I must type slowly due to the system continuously missing my keystrokes due to the...
General Discussion
Kinda-slow?
I have allocated 2Gb RAM to my VM (Virtual PC and XP as D/L from microsoft), but it still limps along when I start up an app. :cry: This isn't too terrible really, just annoying. If I start a virtual XP mode application (without starting the full XP client), it says "Preparing to launch...
Virtualization


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:26.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App