Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Very high CPU usage when playing videos

08 May 2016   #1
johnny20

Windows 7 Home Premium 64
 
 
Very high CPU usage when playing videos

Like title says, when I watch a 720p or 1080p video online (youtube for example), cpu fan starts, usage goes high, video lags.

I don't understand why this is happening.

I had Vista on this laptop and this never happened.

Now I upgraded to 7 and it's happening.

Do I need to install some software? It's the same in all browsers, not just Chrome.

I have nothing taking CPU load, just the browser.

AV and other small processes only take few percent usage.

This is only when watching videos online.


My System SpecsSystem Spec
.
08 May 2016   #2
johnny20

Windows 7 Home Premium 64
 
 

I have watched some videos that were on my hdd, and those only take 10-15 percent CPU load.

Online videos, however, take up to 100 percent.
My System SpecsSystem Spec
08 May 2016   #3
ThrashZone

Win-7-Pro64bit 7-H-Prem-64bit
 
 

Hi,
Post a link to a youtube video,
Dual cores but yea all browsers seem to be getting more resource hogs than anything
About the least hog I've ever used is internet explorer without Adobe shockwave element or flash player installed and it's pretty reasonable.

Chrome Firefox Pale Moon all use way too much for the piddly things they do.
Chrome is uncontrollable
But in all browsers it does matter how many browser add-ons/ accelerators/ extensions you have installed.
So in which ever you have use safe mode or In-Private browsing to test them.
My System SpecsSystem Spec
.

Reply

 Very high CPU usage when playing videos




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Svchost.exe Crazy High CPU Usage and Crazy High Memory Usage
There is a serious issue with svchost.exe on my windows 7 computer. My HP Touchsmart 300-1025 has windows 7 64bit installed and svchost is slowing down the computer and using very high cpu and memory usage. It is not a virus or malware. I know the computer is not infected because one the computer...
Performance & Maintenance
High CPU Usage by image name "System" (PID 4) when playing audio
Whenever I play any audio, I get a sharp spike in CPU usage - one core jumps to > 75% and the other remains around 20%, and the image that's causing the spike in usage is "System". I checked for viruses and malware using SUPERAntiSpyware and Malwarebytes, a few things found but none that were...
Performance & Maintenance
Very high physical memory usage, no high usage programs running
Hello everyone, I've been having a very weird problem recently, in which I BELIEVE is involving high physical memory usage. Sometimes I will be doing things such as playing a game, or watching a stream, and my computer will run fine for a little while. But at random times, my computer will majorly...
Performance & Maintenance
BSOD Playing high demand Games or Watching/streaming videos online
Hi, so for the last few months Ive gotten a worse and worse BSOD. I noticed it first in the flight simulator when I would zoom when looking out the canopy and I would see distant enemy fighters and then I would get BSOD just as i saw them. Then Flying my RC simulator I get BCOD very quick. Now it...
BSOD Help and Support
20% - 5% CPU Usage while playing 1080P Videos, Is this normal?
This worries me because I can get 5 percent less when GeForce 210 does a playback of a 1080P video
Performance & Maintenance
Very high CPU usage, causing very high laptop CPU temps (90c idle)
This problem began yesterday. I noticed my CPU was at 90C constantly with very high CPU usage (>50%). I had no major programs running. I rebooted several times and the program persisted. 1. I went into safe mode and everything was normal. So this rules out hardware issues. 2. I reformatted and...
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 19:54.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App