Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: "Safely Remove Hardware" horrendously slow

17 Jan 2010   #11

Windows 7 Professional
 
 
Please help!!!

Quote   Quote: Originally Posted by zlorf View Post
I have this problem when my network printer is switched off. Trying to open "Devices and Printers" gives the delay too.
Also the same problem with "Devices and Printers"...and about the type of devices I have the problem with when safely remove > all kind of USB devices unfortunately

My System SpecsSystem Spec
.

09 Feb 2010   #12

Windows 7 x86 & x64
 
 

I'm having this same problem with 3 out of 4 of the Windows 7 PC's at home.
It happens on 1 of the x64 pc's and 2 of the 32bit pc's. The other 64 bit machine has no delay. All the pc's are different brands, HP Dell Sony Acer.

It happens with any brand USB thumb drives and USB External Drives, from various manufacturers.
I've tried plugging the drives into external USB hubs as well as directly into the pc's and get the same result.

Ejecting the drive from Explorer works instantly.

I've tried USB drives with no data on.. also Fat and NTFS formats.

There is no spinning ring to indicate the system is thinking.

I've turned off AutoPlay and checked the Event Viewer.

I'm at a loss...
My System SpecsSystem Spec
10 Feb 2010   #13

Windows 7 Professional
 
 

Quote   Quote: Originally Posted by Codify View Post
What device is it that you are trying to safely remove?
Any device, be it printer, USB modem, flash drive,..etc

It's worth to mention though that ejecting a flash memory from "Computer" window only takes two sec.

Having that said it looks pretty clear it's a problem with tray icon functionality :S
My System SpecsSystem Spec
.


02 Mar 2010   #14

Windows 7
 
 

Same problem here... The safely remove hardware takes something like half a minute to pop up with any device plugged in (printer, usb drive, sd memory card, etc.). I usually just *don't* safely remove my stuff anymore... but it would be nice to get it fixed. Any ideas there?
My System SpecsSystem Spec
02 Mar 2010   #15
NoN

Windows 7 Professional SP1 - x64
 
 

Very strange indeed...it should be around the 5 seconds for the pop up message to appear

Is this could be latency in Explorer? Check your latency...
My System SpecsSystem Spec
02 Mar 2010   #16

Windows 7 Professional 64-bit
 
 

Have you tried the hardware and device troubleshooter? Open the Hardware and Devices troubleshooter

Cheers,
Cassandra
Microsoft Windows Outreach
My System SpecsSystem Spec
07 Mar 2010   #17

Ubuntu 8.10 Intrepid Ibex
 
 

Hi, I had the same problem and it seems I finally sorted it out.

As other users mentioned above, all of a sudden my OS (windows 7) begun to slow down the "safely remove hardware" menu popup.

After several (unsolving) searches on google, I experienced another similar problem with Adobe Illustrator: saving images took like forever, eventually freezing the app.

I found an article explaining that on Illustrator CS4 there's a bug: if the default printer is turned off it will hang on save / print.
In fact, my default printer (samsung ml-2010) was off (in other occurences, I wasn't at home so the printer was totally disconnected),

So I set windows builtin "xps writer" as default printer, and now Illustrator works fine... And GUESS WHAT?

The systemtray icon "safely remove hardware" now pops up the menu instantly

Solving 2 problems with 1 solution is really cool (and also extremely rare...).

I hope this solution will work for you too.

(sorry for msipells and typos; I'm from Italy)
My System SpecsSystem Spec
08 Mar 2010   #18

Windows 7
 
 

OMG! You are a genious! Solved my problem by doing that and deleteing a Network printer which wasn't showing grayed out as the others network printers that where not available.

Thank you!
(Windows developers, take note!)
My System SpecsSystem Spec
30 Mar 2010   #19

Windows 7
 
 

For me this solution doesn't work
I removed all printers (only setting Microsoft XPS as a default printer didn't help me), I left only XPS printer and no change... It takes about 15 seconds from clicking on icon until I have pop-up. I need the same time until I can see "Devices and printers"

When I try to remove USB flash using My computer, it works perfectly, I have pop-up instantly.

So any other idea, how to fix this?
My System SpecsSystem Spec
02 Nov 2010   #20

Windows 7 Enterprise 32bit
 
 

Quote   Quote: Originally Posted by omg108 View Post
Hi, I had the same problem and it seems I finally sorted it out.

I set windows builtin "xps writer" as default printer, and now Illustrator works fine... And GUESS WHAT?

The systemtray icon "safely remove hardware" now pops up the menu instantly
I cannot believe that this is what worked to fix the issue! Ridiculous, but very happy that it is fixed. Grazie mille omg!
My System SpecsSystem Spec
Reply

 "Safely Remove Hardware" horrendously slow





Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:09 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33