Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Windows 7 & USB 3.0

17 Jan 2012   #11

Windows 7 x64

I hope this is the right place to raise this question about USB 3.0. My laptop has 2 3.0 and 2 2.0 USB drives. When I hook up the drives to the 2.0, I get a message saying the drives would perform better using the 3.0. So I safely remove the drive and insert it into the 3.0. The system does not see the drives, at all. Yet, I can insert some things like my remote mouse receiver and it works fine. What is wrong?

My System SpecsSystem Spec
17 Jan 2012   #12

Windows 7 Home Premium 64bit 6.1 Build 7601 (SP1)

If you're getting "would perform better" when plugged-in to 2.0 ports, presumably they are 3.0 drives and the system is telling you to plug-in to 3.0 ports for best results. That doing so they are not recognized suggests the laptop has not been loaded with the proper drivers for the 3.0 ports. This is odd as at least most laptops come preloaded with all software & drivers.

I'd guess you need to find drivers for your 3.0 ports (start by looking in Device Manager for yellow flags).
My System SpecsSystem Spec
17 Jan 2012   #13

Windows 10 Pro. EFI boot partition, full EFI boot

No, I do not believe windows 7 supports it natively. Windows 8 is supposed to.
My System SpecsSystem Spec

17 Jan 2012   #14

Windows 10 Pro x64

Windows 7 will work with USB3, but no USB3 drivers ship with the Win7 disc (although some are available on WU, and will install automatically if you allow device manager to check WU for drivers). In general, though, you'll be installing chipset drivers for the USB3 port controller on your motherboard or expansion card before they'll work properly.
My System SpecsSystem Spec
26 Jan 2012   #15

Windows 7 x64

To Cluberti,
When you say WU, does this mean Windows Update? Allow Device Mgr to check WU for is this done? And lastly, by doing what you suggest will this automatically be installing chipset drivers for the USB3 port controller on my motherboard? Thankyou.
My System SpecsSystem Spec
27 Jan 2012   #16

Windows 10 Pro x64

Yes, Windows Update - you can configure Windows 7 to search WU for driver updates:
Configure Windows to Search Windows Update for Device Drivers

As to the second portion, if there *is* a driver there, it'd be found. If not, you'd still have to copy down from the vendor's site and install.
My System SpecsSystem Spec
09 May 2012   #17

win 7 X64 Ultimate SP1
USB 3.0 Addon

In reply to the first post. I am using an Asus card (see link). - ASUS Model U3S6 USB 3.0 & SATA 6Gb/s Add-on card

With Renesas drivers. Two different Rigs. No problems. Not available to boot with. Drivers load with Win 7. Check my system specs for more info.

Attachment 211072

Also I have just fired up an Asus P8Z77-V Deluxe with Intel 3770K (native USB 3.0) and it has no problems. It should be bootable. Although I haven't tried it yet.
My System SpecsSystem Spec
08 Jun 2012   #18

Windows 7 Home Premium (Retail) Full version - With SP1

Quote   Quote: Originally Posted by MilesAhead View Post
I'm using SIIG USB 3.0 PCIexpress card. I have 2 USB 3.0 docking stations. My WD drives run at full speed. It kicks ass basically.
I don't mean to hi-jack this thread but I am interested in your experience with the SIIG card. I installed a Silverstone EC03-P in my desktop and am having an irksome problem with it. The performance with my WD Passport is about 3 times faster than running the disk through an USB2 port. However, if I eject the disk, use it on my laptop and then return it to the desktop the problem appears. If I try to eject from the desktop again, I get a message saying something like the disk is busy please close any program that may be using it. Are you having that sort of problem?

My System SpecsSystem Spec
26 Sep 2012   #19

Windows 7 Ultimate 32bit

I installed Renesas electronics usb 3.0 controller,and I plugged into usb 3.0 port my WD Elements 1TB drive,but it still transfer speed is like 40-50 MB/s copy.Why?
My System SpecsSystem Spec

 Windows 7 & USB 3.0

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:35.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App