Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Blank Screen for 30 Seconds before boot starts?

15 Jan 2010   #1

OSX and Windows 7
 
 
Blank Screen for 30 Seconds before boot starts?

On my old Sony laptop this problem never occurs, but after duel bootng OSX and Windows 7 on my MacBook I get this possible problem on every boot.

My MacBook starts as nromal, I select Windows 7 (OSX boots fine) and it just hangs on a blank screen for around 20 seconds with an underscore flashing the whole time before anything starts to happen (that bit where the Windows logo forms etc).

This makes the boot times around 1 minute or so, whereas on my old laptop they're only around 30 seconds.

This is Windows 7 Ultimate (64-bit). Everything is updated, using Bootcamp 3.0 drivers etc, working perfectly just like XP did.

I'm sure this question has been asked before, but I have tried searching, and can't seem to find anyone with this problem. Is this just apart of booting? Why doesn't this happen on my other PC?

Thanks.

Edit: Mis-typed title, meant to say 20 seconds.

My System SpecsSystem Spec
.

15 Jan 2010   #2

Windows 7 x64 Ultimate
 
 

You can try looking in the system log files (from the log viewer under admin tools). Ususally if a driver or piece of hardware takes longer than expected to become active a warning it put in the log.

On the other end of the spectrum is the Windows Performance Toolkit which you can DL from here:
Windows Performance Analysis Developer Center

It is much more involved but it can possibly pinpoint a specific driver that is hanging for 30 seconds. That is assuming that the black screen is during the windows boot and is not bootcamp itself waiting for something bfore actually starting the windows boot...
My System SpecsSystem Spec
15 Jan 2010   #3

OSX and Windows 7
 
 

I am 99% sure it's not bootcamp, because the screen is white with a Windows logo on whilst it does all that, then it changes to the black screen with the flashing underscore for 20-30 seconds (which it never did with XP), the underscore disappears, then the "Starting Windows" begins to appear.

Edit: I just timed it, it's actually 45 seconds! And that Windows Performance tool comes with a SDK, making it over 4GB. Is there a download just of the performance tool with no SDK?
My System SpecsSystem Spec
.


16 Jan 2010   #4

OSX and Windows 7
 
 

My System SpecsSystem Spec
Reply

 Blank Screen for 30 Seconds before boot starts?




Thread Tools



Similar help and support threads for2: Blank Screen for 30 Seconds before boot starts?
Thread Forum
64-bit - Blank screen on boot up, before login screen; slow startup Performance & Maintenance
Computer starts up with Windows Vista boot screen General Discussion
Sound starts after a few seconds Sound & Audio
Blank screen on boot up, before login screen; slow startup General Discussion
Computer screen goes blank with only curser for 5-10 seconds at log on General Discussion
Blank screen comes when starts for sometime Performance & Maintenance
Laptop starts to a blank screen with white cursor blink BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:49 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33