Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: High RAM and CPU usage


24 Jan 2010   #1

XP, Win7, Ubuntu, Mac
 
 
High RAM and CPU usage

Hi, When I start my pc, and select Windows7 from the dual boot menu, I get the usual logo, then my screen goes blank for about a minute. Once that has gone, and I login, my CPU and RAM are, on average, CPU: 30%, RAM: 60-70%, although the CPU and RAM have peaked at 100%.

I have disables SuperFetch, scanned my system for viruses/worms/etc... Using Avast.
I have Spybot S&D , as well as teatimer.exe (Prevents registry access without giving permission).

Does anyone know what could be causing this? Any help would be greatly appreciated.
Thanks in advance, Dan.

( 4GB RAM - 32bit Windows 7 [So it can only use 3.5Gb] - 9.6 GHz Quad Core CPU )

My System SpecsSystem Spec
.

24 Jan 2010   #2

Windows 7 Home Premium 64bit
 
 

You mean a 2.4Ghz Quad? as in your spec ?


First thing, how many processes/programs are starting with Windows?

Does it drop down after its running a few minutes or only happening at first boot?

You can try something like autoruns or even CCleaner (startup tab) to see what all is booting with windows
My System SpecsSystem Spec
24 Jan 2010   #3

Windows 7 Ult, Windows 8.1 Pro,
 
 

Quote   Quote: Originally Posted by fuzzy29 View Post
Hi, When I start my pc, and select Windows7 from the dual boot menu, I get the usual logo, then my screen goes blank for about a minute. Once that has gone, and I login, my CPU and RAM are, on average, CPU: 30%, RAM: 60-70%, although the CPU and RAM have peaked at 100%.

I have disables SuperFetch, scanned my system for viruses/worms/etc... Using Avast.
I have Spybot S&D , as well as teatimer.exe (Prevents registry access without giving permission).

Does anyone know what could be causing this? Any help would be greatly appreciated.
Thanks in advance, Dan.

( 4GB RAM - 32bit Windows 7 [So it can only use 3.5Gb] - 9.6 GHz Quad Core CPU )
I would bet that is caused by what ever A/V you have installed. It's a very common problem in fact.
My System SpecsSystem Spec
.


25 Jan 2010   #4

XP, Win7, Ubuntu, Mac
 
 

@Wishmaster:
yes, does it matter (other than it'd be amazing if they had a single core that fast)
Only about 40 processes, and it stays at the same high levels all the time I'm using it.

@chev65:
I have the same Avast running on my XP machine at the moment (With firefox, A/V, Spybot, MSN, Steam), and the RAM usage is 14%, the CPU usage 1%.

Thanks for the quick replies.
My System SpecsSystem Spec
Reply

 High RAM and CPU usage




Thread Tools



Similar help and support threads for2: High RAM and CPU usage
Thread Forum
Very high CPU usage, causing very high laptop CPU temps (90c idle) Performance & Maintenance
Win 7 intermediate user, low cpu usage high ram usage Performance & Maintenance
High CPU usage, low fps, high latency. Performance & Maintenance
Windows 7 random CPU usage and high physical memory usage!!! Performance & Maintenance
High CPU Usage Using LAN Network & Sharing
High RAM usage? Performance & Maintenance
CPU high usage Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:37 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33