Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: RAM issue

26 Feb 2010   #1

Windows 7
RAM issue

Hi guys, my problem is kinda weird

recently, (I guess after moving to 7) many times my computer slows down and tends to be heavy on the RAM percentage .....almost always 35-50%

I can somewhat understand this since I am a Power user, a mass multitasker with media and heavy gaming, and also user of programs like CAD and Photoshop .

IT is SUPPOSED TO BE ok tho even with tht though....Since my specs are supposedly great

Windows 7 Professional, AMD Phenom 9600 Quadcore (2.3), 3.0 GB RAM,
and ATI Radeon HD 4650

I already checked for SPYWARE, VIRUSES, Fragmentations, Disk errors, drivers ,registry issues. nothing. Im pretty thorough and good with those.

BUT ITHINK I found the problem atlast......I HAVE 3 Gigs of RAM (and the computer knows it, but almost always when I am using the pc and when stuff slows down......the percentage of ram usage is around 35-50% even in light conditions....However when I calculated all the tasks and services , how much memory they use in total it was...... barely 20%...barely..even when im Gaming...

SO where's the rest, what is using it? If its being used by something else, why isnt it on the task mgr.
PLZ HELP! SOrRY FOR THE LONG RANT....JUST not good at explaining and simplifying

My System SpecsSystem Spec
26 Feb 2010   #2

Windows 7 Professional

Your memory maybe faulty, try this: Memtest86+ - Advanced Memory Diagnostic Tool

My System SpecsSystem Spec
26 Feb 2010   #3

Windows 7 Professional

Download and execute Process Explorer here: Process Explorer

All you need to do is copy the exe to a folder and run it. Right click in the row at the top labeled 'Processes' and add a column. Go tothe 'Process Memory' tab and make sure 'Working set size' is checked. That will show you the amount of RAM used by each process.

This is very similar to Windows task manger, but will show you all the processes running on your machine.
Let us know what you find.
My System SpecsSystem Spec

26 Feb 2010   #4

Windows 7 Home Premium 64bit

Its quite normal for Win7 to use 1.0 - 1.5GB of RAM, even at idle.

Slow down in what way?
System freeze/hang or just seems to take longer to load something?

32 or 64bit?

Some could be hard drive activity, especially if using just 1 mechanical HD.
My System SpecsSystem Spec
26 Feb 2010   #5

Windows 7 Ultimate x64 Service Pack 1 (Build 6.1.7601)

Having 3GB of RAM and using 35-50% sounds normal for windows 7 or Vista, if it was faulty your would be getting BSOD and other problems.
My System SpecsSystem Spec
26 Feb 2010   #6

MS Windows 7 Ultimate SP1 64-bit

Increase your ram from 3GB to 4GB. Yes, I know that you won't get the full advantage of 4G but you will get an improvement.

Run MSCONFIG and look at the startup tab. There will be things listed there that don't really need to start until they are needed.

Be sure and run one and only one AV program. My personal recommendation is Microsoft Security Essentials which is FREE! and from Microsoft. A large number of us use Microsoft Security Essentials. There are, of course, loyal users and advocates of other AV programs.

If you really wan an enlightenment, download Autoruns from the SysInternals site (the same people that wrote and maintain ProcessExplorer)
My System SpecsSystem Spec
26 Feb 2010   #7

Windows 7

Hey guys, i just got my memory diagnosed's perfectly fine

@mvnsnd....Thnx for the process explorer....i DID find i have alotta shit using wasnt this bad when i was using XP OR VISTA even

@Wishmaster.... Its 32bit...and I am using 3 HD's.....and wht i meant by slow was literally slow loading....even when im only browsing (no my internet is fine...ichecked tht out already) or when sometimes accessing or responding to clicks, the start button and stuff

but even so...i shouldnt slow down on loading or responding....cuz imean i should have atleast a gig and a half of memory why is it mentioned b4 I HAVE BEEN THOROUGH WITH SECURITY THREATS, inconsistencies, and errors ....this shouldnt be happening right?

ON another note
Looks like I might have to get more RAM...but how far can i go functionally...since i heard a rumor that windows 7 or vista only take and will only use 4GB.....BUT MY MAIN question still remains

shouldnt be slowing down right?
My System SpecsSystem Spec
26 Feb 2010   #8

MS Windows 7 Ultimate SP1 64-bit

4 GB or win 7 32bit
Your computer/motherboard documentation will be helpful to you.
My System SpecsSystem Spec
28 Feb 2010   #9

Windows 7

hey guys i have 1 gb ram DDR1, gigabyte 81915ME-GL, P-4 processor, m getting bsod often . So can someone help me regarding this issue??? plz m looking forward for answers....
My System SpecsSystem Spec
28 Feb 2010   #10

Windows 7 Ultimate Vista Ultimate x64

Out of interest do you have a My Book WD External drive or something like that?
My System SpecsSystem Spec

 RAM issue

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Boot issue, 0xc0000098 ci.DLL file issue
OK so I hope this can be a quick fix and thanks for your help. * Randomly computer didn't start, get something telling me that the ci.dll file is missing or corrupt and error 0xc0000098 * safe mode and last know good configuration both result in bsod * Tried a few things, disconnect all...
BSOD Help and Support
net start command line issue - 64bit issue?
I am trying (in vain) to issue a net start command "net start - "C:\Program Files (x86)\uTorrent\utorrent.exe", on the command line. The error message is "the filename, directory name or volume label syntax is incorrect". I believe the 3 details are correct, as i am looking at the utorrent.exe file...
General Discussion
HP Multi Print/Scan Issue Re Install Issue?
I have an HP M1522 NF multi function peripheral attached to a PC running Windows 7. I needed to re install the drivers and software the other day but now it will only install the printer drivers and not the scanner drivers or any of the accompaying software?
Hardware & Devices
jpeg permission issue / possible encryption issue
Hello, I am new to the forums and have looked around just about everywhere I can think of for a similar topic and thus far have been unable to locate any help. If this has been previously covered, please point me in the direction and I will read up. So as for my issue.... I was running...
General Discussion
Interesting connectivity issue, just a browser issue
Opps, maybe not so unique since I just noticed an ENTIRE forum for browsers...perhaps moving this is appropriate...if so, please do. I will be reading up in there. Its interesting because I can't find any mention of it anywhere on this site. Specifically browser connectivity is lost after a...
Network & Sharing
8800GT Driver issue? Or maybe its a bios issue.
Hi all. I'm not sure where to start with this issue, it's bit spread out but it all started while I was gaming and the game froze and then the computer crashed. The freezing happened every once in a while, but the crashing had never happened. During the restart I see...

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 00:45.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App