Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Messed Up External Hard Drive Icon


15 Apr 2009   #1

Windows 7 Professional x64 / Ubuntu 9.10
 
 
Messed Up External Hard Drive Icon

The icon for my USB External Hard Drive (labeled as USBEXT) is messed up. In the Send To context menu, as well as in the Computer folder, and the sidebar of Windows Explorer, it shows up as if the proper icon is missing?

Anyone know of a possible solution? Just the default drive icon next to the label would be nice but I'm also wondering how I could customize all of the icons in Windows 7 for hard drives, folders, music files, etc. I remember there were programs that did such things in previous versions of Windows and didn't know which of them, if any, would work with Windows 7 (Build 7077). Thank you in advance for your help!

PS: I apologize for my overwhelming amount of noobness...

My System SpecsSystem Spec
.

15 Apr 2009   #2
Microsoft MVP

64-bit Windows 8.1 Enterprise
 
 

Hello Gemini Man, and welcome to Seven Forums.

You might see if unplugging it and reconnecting it may allow it to display properly after Windows 7 redetects it. If not, then temporarily do step 4 in this tutorial to unhide and look for a desktop.ini file when you first open the USB drive. If one is there, then delete it. You may need to restart afterwards for the icon to display.



These tutorials below can be helpful in customizing the other icons in Windows 7:Hope this helps,
Shawn
My System SpecsSystem Spec
15 Apr 2009   #3

Windows 7 Professional x64 / Ubuntu 9.10
 
 

Wow, thank you! There was a desktop.ini file, and I wasn't sure what it did, but deleting it did the trick.

I've never experienced a forum that was truly helpful to the degree that this one is. This is the first question I had to ask myself that wasn't already thoroughly answered here already. So thanks again for helping me out, and for all that you do on this site.
My System SpecsSystem Spec
.


15 Apr 2009   #4
Microsoft MVP

64-bit Windows 8.1 Enterprise
 
 

You're welcome Gemini Man. I'm happy to hear that the icon is back for you now.

Have fun customizing the others.
My System SpecsSystem Spec
13 Aug 2010   #5

Windows 7 32-bit
 
 

I had the same problem as Gemini Man, went through the steps, and the regedit fix still did not work.

Through some investigative work, I did another quick fix, then restarted my system, and then the icon was finally changed.

I temporarily showed hidden files and folders (through control panel options), searched for an autorun.inf file on the main page of the USB hard drive, deleted it, and voila, the icon changed (after the restart.)

Hope this clears any more problems up like it did for me!
My System SpecsSystem Spec
22 Jun 2011   #6

Win 7
 
 

I registered to post that the trick chiefxc used worked for me aswell.

First i deleted the ini file, rebooted and it still wasnt fixed then i did what
chiefxc did and rebooted and it was fixed.

I used Total commander to see the hidden files.

My System SpecsSystem Spec
15 Dec 2011   #7

windows 7 Professional 64 bit
 
 

Quote   Quote: Originally Posted by chiefxc View Post
I had the same problem as Gemini Man, went through the steps, and the regedit fix still did not work.

Through some investigative work, I did another quick fix, then restarted my system, and then the icon was finally changed.

I temporarily showed hidden files and folders (through control panel options), searched for an autorun.inf file on the main page of the USB hard drive, deleted it, and voila, the icon changed (after the restart.)

Hope this clears any more problems up like it did for me!
Thx chiefxc I deleted the autorun file shown at top of all files on ext HD and did a restart and viola, all good. ty very much. gr8 forums here. peace 2 all.
My System SpecsSystem Spec
13 Jul 2012   #8

Windows 7
 
 

Hello friends.

Today I had a same problem. I've six drive partitions & five of them had missing icons. Only system drive (Windows7) icon was healthy. I also tried searching for autorun.inf or desktop.ini files but couldn't find them.

Finally the other approach suggested by Brink above solved the problem. I did exactly what's mentioned over here & all drive icons are restored now!
Icon Cache - Rebuild

Thanks
My System SpecsSystem Spec
Reply

 Messed Up External Hard Drive Icon




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:45 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33