Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Search Index Broken, Rebuilding won't help

03 Apr 2010   #1

Windows 7 Professional
Search Index Broken, Rebuilding won't help

Hi SevenForums,

I've been having this problem since I installed Windows 7, but I haven't gotten to it before today... When I installed Windows 7, I set up everything, including the search index. I wanted it to search my music library, most of my documents, and my videos, which amounts to ~16,000 files. I set up the checkmarks good, i.e. checking My Documents, and unchecking individual unwanted folders within.

For whatever reason, I search for a music file, which the index finds, then I search for another music file from the same artist, which is in the same folder, and the index can't find it... I rebuilt my index a few times over the last few months to try and fix the issue, but it never works, it just always gives the same mistakes over and over again.

Now I try to remove all the folders from the index and start over again, and Windows remembers all the choices I made, so if I uncheck My Documents, but had manually selected a sub-folder within a folder I unchecked, said sub-folder stays checked. I understand this last sentence was not as clear as it could be, but I can't find the words to say it better...

I'd like to completely reset the windows search index settings and parameters, so that it erases the index, forgets any presets it currently knows, and just lets me try all over again, so maybe it would finally work.

Can anyone help me?

Raphaël Tremblay Lessard / Chlikaflok

My System SpecsSystem Spec
03 Apr 2010   #2

Windows 7 Professional x64

Welcome to SF!

Try disabling search, rebooting, and enabling it again.

Search Index Broken, Rebuilding won't help-capture.png

Search Index Broken, Rebuilding won't help-capture1.png

My System SpecsSystem Spec
03 Apr 2010   #3

Windows 7 Professional

Thanks for welcoming me!

I've just tried what you suggested, it's still rebuilding the index, but from what I'm seeing it's doing the same as before. I'll wait until the index is done rebuilding itself before jumping to conclusions though.
My System SpecsSystem Spec

04 Apr 2010   #4

Windows 7 Professional

No cigar.. I'm having the same problems as before.

This pretty weird... guess I'll live with it until my next reinstall...

Thanks for the help,
My System SpecsSystem Spec
04 Apr 2010   #5

Windows 7 Professional x64

You could try a repair install.
My System SpecsSystem Spec
25 Jul 2010   #6

Win 7

Similar problem here. Rebuilt the index and now Win Explorer search will not find folders sitting in plain view.

I've been computing since 1997 and have tried every basic setting anyone has thought of and nothing has mattered. To make it worse, one day last week it started working. The next day it wouldn't find anything again and I didn't change anything in-between.
My System SpecsSystem Spec
25 Jul 2010   #7

Win 7
This finally worked for me.

OK this worked for me. Credit for the Regedit part goes to Samhrutha G S at Microsoft Support.

Important: The instructions below contain steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information view the article in the Microsoft Knowledge Base: How to back up and restore the registry in Windows

1. Click Windows + R (Opens run window)

2. Type regedit and press Enter.

3. In registry editor, windows locate: HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows Search
In the right pane, right click on SetupCompletedSuccessfully and click on Modify.

NOTE: If SetupCompletedSuccessfully is not there, then in the right pane, right click on a empty area and click on ‘New’ select ‘DWORD (32 bit)’ Value and type SetupCompletedSuccessfully and press Enter.

4. Type 0 and click on OK.
NOTE: This is the number zero.

5. Close Regedit.

6. Restart the computer.
Resetting the registry to 0 will also remove the drivesfrom the list of “Included Locations” you may have set previously in Indexing Options.
So you will want to add those back in through the “Modify” button. > Show All Locations > Check the drives you want indexed.
Next in Indexing Options you can click through > Modify> rebuild new index.

I did one more step just to make sure before rebuilding the index. I went into Control Panel> Indexing Options and created a new location and new folder for the index.

I then deleted the old index through explorer.

Then I hit the rebuild index button.

I had a suspicion that simply rebuilding the index was not creating a whole new data set; for one thing, the index was being rebuilt too fast, like in under a half hour on a machine with 700 Gigs of files. Second, it wasn’t changing anything for the better.
So out went the old index.

My theory was that Win 7 may be “borrowing” the possibly corrupt data from the first file to build the new index as quickly as possible. But I have not tried this procedure without making a new index folder to see whether deleting the old one is necessary after resetting the SetupCompletedSuccessfully value.

About 3 hours later, the index was rebuilt and indexed search for files and folder contents is working.

It’s good to be aware that there is another place where Windows has search settings. In Control Panel > Folder Options > Search Tab. Make sure the box is clear for “Don’t Use The Index While Searching The File System”. Also choose other options you want there. I selected “Include Subfolders” and “Find Partial Matches”.
My System SpecsSystem Spec
25 Sep 2015   #8

Windows 7 Premium 64bit
Was helpful for restoring index default folders on Windows 10

Excellent instructions on how to rebuild the index and restore the default folders. It actually was useful for my Windows 10 build as I had seemingly had a corrupt database of locations with the different versions of MS Office I had on my computer. Thanks!
My System SpecsSystem Spec

 Search Index Broken, Rebuilding won't help

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Windows 7 Index Search
Why does Windows 7 automatically reindex my index search file when I reboot the computer. I have 300,000 files on my computer and it takes two days to rebuild the index. I leave my computer on all the time because I am afraid that by turning it off and on again will cause the indexing function...
General Discussion
windows 7 search index
please, tell me what is search index in windows and what influence does it have during search?
Performance & Maintenance
Start Search broken, doesn't return search.
I'm not really sure how to explain this and this is my first post so I think I will just show you, yeah, that's probably the best way. The best way I see to explain it is instead of a list of the files and programs found in the start search showing up it just shows a few files like Documents.file,...
General Discussion
Index files but keep them out of search?
This may be impossible, but I was wondering if files/folders could remain in the index (to retain the ability to sort them) but not show up in the windows search. If not, I don't mind as this was just a random thought.
General Discussion
Search box broken
Hi, I recently installed a program that was able to change folder backgrounds but uninstalled it, and I think this is what has caused this problem: Those same files show up no matter what I type in and they are all 0 bytes. If I right click...
General Discussion
Can't add locations to search index
Hello, I am new to this forum, so I hope this is the right place to post this question. I have the following problem: I can't add locations to the search index. The modifie button is always disabled (see screenshot). Is there a way to solve this ? Grtz
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 04:32.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App