Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Programs hanging on startup...

04 Apr 2010   #1
Ghostafec

Window 7 Professional 32-Bit
 
 
Programs hanging on startup...

Wonder if anyone can shed any light on a problem I am having. Just bought Windows 7 Professional 32-Bit and got everything installed, cleaned up, optimised etc only to notice that after the initial boot if I try to load anything from the Start Menu the program I select hangs and doesn't open yet my PC doesn't crash. The Start Menu becomes unuseable until about 30 seconds after clicking a program when it starts to kick in and work again, until then you can move your mouse cursor over the menu options but can't select anything. After this initial problem it all runs smooth as you like but on startup even though it boots in quick and all the trays load within 5-10 seconds this happens every single time.

Is this standard with Windows 7 at the moment or is this a bug that I should be more concerned about?

Any advice appreciated, cheers!


My System SpecsSystem Spec
04 Apr 2010   #2
Ghostafec

Window 7 Professional 32-Bit
 
 

Just an update, narrowed the locking of the start menu down to the Windows 7 notifcation process, I disabled the program notification and the programs do start to load and the start menu is accessible however program such as 3DMark06 and Everest Ultimate still stick on the initial loading screen for 30 seconds or so and don't boot in. It seems as though there is something loading in the background that wasn't before as I have only just noticed this however no new installations have been performed.

Hmmmmm......
My System SpecsSystem Spec
04 Apr 2010   #3
manhunter2826

Windows XP - Now Windows 7 Home Premium (64-bit).
 
 

Could u possibly start msconfig and disable anything u see as problematic associated with a known program - under the Startup tab - just uncheck the program, do not delete however.

Click on Orb and type msconfig
My System SpecsSystem Spec
04 Apr 2010   #4
manhunter2826

Windows XP - Now Windows 7 Home Premium (64-bit).
 
 

It could possibly be your anti-virus (scan) kicking in on boot-up - are u able to check this?
My System SpecsSystem Spec
04 Apr 2010   #5
Ghostafec

Window 7 Professional 32-Bit
 
 

Thanks for the replies

The startup shows:

Adobe Acrobat
Adobe Reader and Acrobat Manager
Adobe Software Gmbh NeroCheck
Bitdefender 2010
Bitdefender 2010
Catalyst Control Center
CTXfiHlp Application (Soundcard)
Delivery Manager (Sky Player)
Delivery Manager (Sky Player)
iTunes
Nvidia NVRAID
QuickTime
razerhid Application (Mouse)
razerhid Application (Keyboard)

Nothing there stands out to me as a problem apart from the delivery manager where the two entries run the same command only one has " " around the command. Is this a normal procedure or does that seem strange?

With regard to the anti-virus, I have on scan boot-up disabled and the tray icon loads instantly, I will try disabling it in msconfig and reboot and see what happens.
My System SpecsSystem Spec
04 Apr 2010   #6
Ghostafec

Window 7 Professional 32-Bit
 
 

Just tried disabling both Bitdefender startup items, rebooted, still the same issue.

Tried seperately disabling the Sky Player Delivery startup items, still the same issue (it did resolve the duplicate entry however, there is just one now).

Tried disabling all the Adobe entries and still the same issue.

A better example of a program that loads but doesn't function is Windows Live Mail. I can start it up and it loads the program however the circular loading icon goes around for about 30-40 seconds before it loads my my mail in the main viewing pane.

This is a strange one as that definitley wasn't happening yesterday...
My System SpecsSystem Spec
04 Apr 2010   #7
Ghostafec

Window 7 Professional 32-Bit
 
 

Problem solved!

Opened up task manager and checked the services and a service called KService.exe was starting up for 40 or so seconds, turns out it's associated with Sky Player software, disabled it in services.msc and everything booted up straight away. Thanks for the help, hopefully this will come in handy for someone else further down the line at some point!
My System SpecsSystem Spec
05 Apr 2010   #8
manhunter2826

Windows XP - Now Windows 7 Home Premium (64-bit).
 
 

Glad u got it sorted, and thanks for letting us know.
My System SpecsSystem Spec
Reply

 Programs hanging on startup...




Thread Tools



Similar help and support threads for2: Programs hanging on startup...
Thread Forum
Hanging at startup, Safemode OK BSOD Help and Support
Programs slow to launch and close and hanging Performance & Maintenance
Windows Hanging on startup Performance & Maintenance
Lagging, hanging programs General Discussion
Hanging programs BSOD Help and Support
Windows 7 Keeps Hanging At Startup General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:10 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App