Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Very Slow Performance!

04 May 2010   #1
inw1987

Windows 7 premium 64x
 
 
Very Slow Performance!

Hi all,

I am looking for a bit of help please, when I have iTunes running and playing music it often starts jumping and the laptop is very unresponsive. When it does this I usually have Word and Google Chrome open. I think I have figured out it is mainly when chrome and iTunes are open together, but I do not understand why this is a problem, surely the laptop is capable of this. I have attached screen shots of the performance screen to show what is happening. If I shut down iTunes I have no problems but it is not using excessive RAM I don't think.

Thanks




Attached Thumbnails
-capture.jpg   -capture1.jpg   -capture2.jpg  
My System SpecsSystem Spec
.

04 May 2010   #2
Snakeyeskm

Win 7 64 bit professional
 
 

from what I can see on your resource monitor screens, there is excessive CPU usage for just those two programs. Try running each separately and check out your CPU usage for each. I have attached my resource monitor when I had both iTunes playing and chrome open, in addition to other software. As you can see I have minimal activity in all my cores. Furthermore something about your total memory does not make sense to me, if you have 3 MB of physical memory, you seem to be showing a slightly lower amount of the total physical memory. I doubt if that is a significant issue.


Attached Thumbnails
-untitled.jpg  
My System SpecsSystem Spec
10 May 2010   #3
inw1987

Windows 7 premium 64x
 
 
Found the problem!!

Hi

Thanks for the reply, I found thread on the Google forums High CPU Usage - Windows - Google Chrome Help and people were complaining about chrome producing high CPU values, one of the reasons are pages using Shockwave player. I have had a look at the task manager and any page using shock wave player especially my homepage which is sky.com causes the CPU to spike. iTunes uses hardly any apart from opening. By clicking my homepage CPU usage can shoot up to over 65%. There doesn't seem to be any know reason or fix for this so far but loads of people are complaining about it.
My System SpecsSystem Spec
.


Reply

 Very Slow Performance!




Thread Tools





Similar help and support threads
Thread Forum
Slow bootup, slow performance
I have a Dell Latitude E6520 i5-2520 (2.5GHz), 8GB RAM, 7200RPM HDD, Windows 7 Pro x64. After installation everything seems super ok . Bootup time, working in windows, etc. Then i decided to start the update (about few hundred megabytes). After the upgrade it seems that everything is...
Performance & Maintenance
very slow startup and slow performance over all
its about 6 months i m using the same window, but now it starts really slow and over all performance of my system is also down. i have dell n5110 i5 with 4gb ram, and please i dnt want to reinstall window :( also i am using selective startup Any suggestions?
General Discussion
Slow performance lately?
Greetings guys, My computer yesterday was working normally as it is supposed to. But today when I switched on my PC it acted very weird. The problem is that whenever I play a song (via Youtube/WMP/VLC media player Etc..) and scroll down on Facebook or browse through the folders, the songs...
Performance & Maintenance
slow performance
my laptop is compaq presario cq62. CORE i5 M430 2.27 Ghz 320 GB HDD 2 GB RAM but when i copy file to any file to pen drive it gives speed of 5-7 mbps. when i copy from pen drive to laptop it gives speed of 10-11mbps. when i copy file from one drive to another it gives speed of 20.4mbps.
Performance & Maintenance
Slow Performance, Slow Boot-up - Cause Undetermined!
Hello everyone, I have done a lot of research on Google as well as on this forum to find a solution to my problem. Unfortunately, people who have posted on the forums have SIMILAR but not the exact problem as I have. I would like to take this opportunity and explain exactly whats been going...
Performance & Maintenance
W7 Slow Boot Time and Overall Slow performance
Hi new to these forums and I'm hoping someone can help me out here. I formated my HDD and did a clean install (W7 7100 build) but I'm noticing slow boot times and slow performance compared to Vista x64. W7 boots at least 10secs slower and programs tend to lag (aren't as snappy compared to...
Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:54.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App