Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Sony Vaio display brightness problem


30 Jun 2010   #1

windows 7
 
 
Sony Vaio display brightness problem

in advance, sorry if this issue has been solved on this forum, but i didn't find it.

i have sony vaio VPCS11X9E which came preinstalled with Windows 7 64bit, and everything worked fine. i was forced to reinstall Windows 7 32bit because of some old software (don't ask). as far as i can see, everything is fine except for one thing, display brightness. display is dimmed, constantly, since the login screen. i have managed to make the brightness keys to work in the sense that the brightness bar is visible and changing. however, the brightness of the screen doesn't change. i have also gone through all power and display settings, in windows and vaio control center, and have set everything on maximum, regardless of power plan etc, and tried tampering with adaptive brightness, but to no avail. right now i am a little desperate, and have no other ideas.. i'm in a bit of a hurry so i need any help or suggestion.. i hope i have provided enough information. (drivers are all updated of course).. thank you in advance.

My System SpecsSystem Spec
.

30 Jun 2010   #2

Windows 7 Ultimate x64 x2 + x86 + Windows 8.1 x64 x2
 
 

Couple of things to try ....

Check for any Sony supplied software that may duplicate and override the windows 7 settings you have made

Create a new account (same level as your current user), to eliminate profile issues.

If possible run a Live Linux CD to eliminate the slight possibility that you have a problem with the screen hardware
My System SpecsSystem Spec
30 Jun 2010   #3

windows 7
 
 

i have just tried with another account (administrator, just as the previous), but unfortunately, nothing changes. screen gets dimmed as soon as the login screen appears, but the windows startup logo and progress bar etc are as bright as can be, so i am certain that it is not hardware issue.

to further clarify, screen was bright until i updated intel graphics drivers from intel website, automatically. it was one of the first things i did after installing Windows 7, even before installing sony specific software from vaio website.. i just don't know where to look for the solution.

thanks for trying barman58!
My System SpecsSystem Spec
.


30 Jun 2010   #4

Windows 7 Ultimate x64 x2 + x86 + Windows 8.1 x64 x2
 
 

Quote   Quote: Originally Posted by coldwater View Post
i have just tried with another account (administrator, just as the previous), but unfortunately, nothing changes. screen gets dimmed as soon as the login screen appears, but the windows startup logo and progress bar etc are as bright as can be, so i am certain that it is not hardware issue.

to further clarify, screen was bright until i updated intel graphics drivers from intel website, automatically. it was one of the first things i did after installing Windows 7, even before installing sony specific software from vaio website.. i just don't know where to look for the solution.

thanks for trying barman58!
Have you tried rolling back the drivers? It would not be the first time that a "New" driver version from Windows Update is a retrograde step. Another thing to look at is if even newer drivers are available from either Sony or the graphics system manufacturer, Intel
My System SpecsSystem Spec
30 Jun 2010   #5

windows 7
 
 

Have you tried rolling back the drivers? It would not be the first time that a "New" driver version from Windows Update is a retrograde step. Another thing to look at is if even newer drivers are available from either Sony or the graphics system manufacturer, Intel [/QUOTE]

that is just what i was doing just now. there was a newer graphics driver on intel's site that wasn't being installed automatically, so i did it manually. however, nothing changed. screen is still dimmed and brightness controls don't change it, whether i use keyboard fn+F5/F6 or windows' power options, or sony vaio control center.

i am trying to find an older graphics driver, maybe i'll get lucky.

thanks nigel.
My System SpecsSystem Spec
30 Jun 2010   #6

windows 7
 
 

ok, so far, i only get ahead when i deinstall graphics driver completelly (from programs and features). but, as soon as i install any driver, problem reappears. i have tried 4 versions of drivers, oldest being from 30.12.2009, but i just can't get a break.

any help would be greatly appreciated..
My System SpecsSystem Spec
30 Jun 2010   #7

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by coldwater View Post
ok, so far, i only get ahead when i deinstall graphics driver completelly (from programs and features). but, as soon as i install any driver, problem reappears. i have tried 4 versions of drivers, oldest being from 30.12.2009, but i just can't get a break.

any help would be greatly appreciated..
what GFX chipset Intel what?

Bios newest?

does it do the same thing in safe mode(F8)?


Ken
My System SpecsSystem Spec
30 Jun 2010   #8

Windows 8.1 Pro RTM x64
 
 

Hi coldwater,

Have a look at these links: VAIO : Sony Europe

You could also check their Forum: http://club.vaio.sony.co.uk/clubvaio...hreads?forum=6 (sorry, there doesn't appear to be a search facility, at least for unregistered viewers).
My System SpecsSystem Spec
30 Jun 2010   #9

Windows 7 Ultimate x64 x2 + x86 + Windows 8.1 x64 x2
 
 

The latest drivers for the Viaio range are here

ftp://ftp.vaio-link.com/PUB/VAIO/WIN7UPGRADE/

I can't see what is causing this so have put a call out for some assistance from some of the Sony / Intel People here to take a look - hopefully someone will recognise this issue

Also some laptops have screen /power settings in the Bios (Dell Etc), you may want to check the BIOS for such settings (kudos to Pebbly for the suggestion )
My System SpecsSystem Spec
30 Jun 2010   #10

Windows 7 Ultimate x64 x2 + x86 + Windows 8.1 x64 x2
 
 

More suggestions ....

Quote   Quote: Originally Posted by pebbly View Post
Barman, done a little searching , does the op have the original sony cd here is a quote off a site by someone with the same prob


Try the SonyTR forum: http://www.siliconpopculture.com/forum/

Quote:
You need the Sony Utilities Library, Sony PowerPanel, two utilities for
the function keys which names I don't remember. I have your email
address. I have a complete set of the TR3A installation CDs but they are
with the TR3A which is on vacation and will not return until mid-week.
As I recall, the install CDs can be used to selectively install the
proprietary Sony files. I'll let you know.

ignore the TR3A bit it seems it happens to a few types , also get the op to try the lid catch [ appears to be faulty wiring in the flexcable]
My System SpecsSystem Spec
Reply

 Sony Vaio display brightness problem




Thread Tools



Similar help and support threads for2: Sony Vaio display brightness problem
Thread Forum
Solved sony vaio brightness issue Drivers
sony vaio vpcs131fd brightness problem Hardware & Devices
Sony Vaio VPCEB17FA BRIGHTNESS ISSUE General Discussion
Brightness Issue with Sony Vaio VGN-CS36GJ Drivers
Sony Vaio and Display Resolution Graphic Cards
Sony Vaio VGN-FZ290 Brightness Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:36 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33