Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows 7 random CPU usage and high physical memory usage!!!


30 Jun 2010   #1

Windows 7 - 64 Bit
 
 
Windows 7 random CPU usage and high physical memory usage!!!

Ok, I am literally KILLING myself over this!

I installed Windows 7 64Bit over XP around a month ago and it was so good that I recommended it to my brother who was previously on XP too. We got him a copy of the 32bit version as he has only 2gb of memory, and he installed it on his machine. However, he constantly had high CPU and RAM usage (Even though no programs were obviously taking it all up in his task manager) and it was making his computer sluggish and slow. Everything was freezing and hanging and it was a nightmare.

I spent a day looking all over the net to find out the problem, but could not fix it at all, no matter what the hell I tried. So he reverted back to Windows XP. (A nice waste of money on Windows 7.) His Windows XP now runs smoothly and is all as it was.

Suddenly today, after my brother connected to my Windows 7 homegroup (or workgroup rather) through his Windows XP machine, my computer got the EXACT same problem as he had ages ago! I have been browsing Google all day downloading s**t, changing things in my computer, trying EVERY possible fix that people have suggested and that sound legit. Nothing works!

So now all of a sudden, my computer is sluggish, games are jumpy and jittery, video rendering times are slooooooow.

Here is a picture of my resource monitor:
You can see the physical memory usage being at 45%. I've ordered the memory usage of each service in highest to lowest.
I just CANT see where the problem is!
(I've tried leaving my homegroup to see if that changes anything, but it just says "Windows couldn't remove you from your homegroup." So I searched online, tried all possible fixes, with no avail.)

I've scanned my computer for malware and viruses and nothing shows.

If you can help me, you are by sure a god, and I may have you kiss you repeatedly. I have never been so frustrated as I do alot of memory dependant work on my computer and this is just pure horrible.



Here are some extra images that may help:





My System SpecsSystem Spec
.

30 Jun 2010   #2

Windows 8.1 Pro (x64)
 
 

I can tell you what is probably causing your problems. AVG.
When you are looking at memory, do not sort by Working set, sort by Hard faults.
Hard faults is what causes things to slow down. Plus you have plenty of memory not to worry about usage.
My System SpecsSystem Spec
30 Jun 2010   #3

Windows 7 - 64 Bit
 
 

Quote   Quote: Originally Posted by logicearth View Post
I can tell you what is probably causing your problems. AVG.
When you are looking at memory, do not sort by Working set, sort by Hard faults.
Hard faults is what causes things to slow down. Plus you have plenty of memory not to worry about usage.
But I tried uninstalling AVG earlier and it did nothing.
When I look at my memory now,

Svchost.exe (DcomLaunch)

had 22 hard faults but it slowly dropped to 0.
All services are at 0 hard faults and memory usage is at 1.68GB(42%).
This is with just firefox open.
My System SpecsSystem Spec
.


01 Jul 2010   #4

Windows 7 - 64 Bit
 
 

It looks like the memory usage slowly climbs for as long as my computer is on, but it starts at 1.16GB.

I've also now uninstalled AVG again, and it has made no change.
My System SpecsSystem Spec
01 Jul 2010   #5

Windows 7 - 64 Bit
 
 

Picture from today. Memory usage is currently at 1.93GB(48%) after 2 hours of my computer running.



mbam.exe is Malwarebytes' Anti-Malware performing a full system scan.
But what about the svchost.exe? could that be a problem?
My System SpecsSystem Spec
01 Jul 2010   #6

Windows 8.1 Pro (x64)
 
 

I think you are looking for the problem is the wrong area. Your memory usage is perfectly fine according to the above screenshot. You have plenty of free memory. The slow down must be something else...hard drive is one possible, hard faults are directly effected by the performance of the hard drive for example.
My System SpecsSystem Spec
01 Jul 2010   #7

Windows 7 - 64 Bit
 
 

Quote   Quote: Originally Posted by logicearth View Post
I think you are looking for the problem is the wrong area. Your memory usage is perfectly fine according to the above screenshot. You have plenty of free memory. The slow down must be something else...hard drive is one possible, hard faults are directly effected by the performance of the hard drive for example.
Could it possibly be due to somebody connecting to my harddrive via homegroup?

EDIT:
Scratch that. I found a way to leave my homegroup, so I did and the problem still hasn't gone away.

I disconnected my 2 other seperate harddrives to leave my single IDE one with Windows 7 installed on it. When I booted it up, the problem was still there. If it's a problem with the harddrive, then its the one with Windows 7 on it. I'm thinking of just doing a clean format and going Vista instead...
My System SpecsSystem Spec
01 Jul 2010   #8

Windows 7 Ult, Windows 8.1 Pro,
 
 

Upgrade installations cam sometimes be problematic, I see it all the time over in the networking section. If you want your machine to work right just perform a clean install of Win 7.
Clean Install with a Upgrade Windows 7 Version
My System SpecsSystem Spec
01 Jul 2010   #9

Windows 7 - 64 Bit
 
 

Quote   Quote: Originally Posted by chev65 View Post
Upgrade installations cam sometimes be problematic, I see it all the time over in the networking section. If you want your machine to work right just perform a clean install of Win 7.
Clean Install with a Upgrade Windows 7 Version
I originally did do a clean install of Windows 7. Thanks anyway.
My System SpecsSystem Spec
Reply

 Windows 7 random CPU usage and high physical memory usage!!!




Thread Tools



Similar help and support threads for2: Windows 7 random CPU usage and high physical memory usage!!!
Thread Forum
Physical Memory/CPU Usage showing high Performance & Maintenance
High Physical memory usage Performance & Maintenance
Computer Lag - High Physical Memory Usage Performance & Maintenance
Solved Extremely high physical memory usage Performance & Maintenance
High Physical Memory Usage Performance & Maintenance
High Physical Memory Usage Performance & Maintenance
constant high physical memory usage Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:09 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33