Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Weird RAM usage

18 Jul 2010   #1
astanar

windows 7 64
 
 
Weird RAM usage

For the past week or so i'll be on the computer surfing the net when suddently it becomes super slow. Windows takes forever to move, to close or just to open new ones. I went into the tast manager to find this(see screenshot). My ram usage shows 95% but on the application list nothing uses that much ram to put it to that level! I've got 4gigs of DDR3 and have no clue what is going on.






Attached Thumbnails
-wtfram.jpg  
My System SpecsSystem Spec
.
18 Jul 2010   #2
Anak

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1
 
 

One thing I'm wondering is ......Do you really need all those services running at the same time? Especially scvhost.

See post #17, and 20 here:
Windows 7 slowly becoming slow!
My System SpecsSystem Spec
18 Jul 2010   #3
logicearth

Windows 10 Pro (x64)
 
 

Quote   Quote: Originally Posted by Anak View Post
Especially scvhost.
There is suppose to be multiple scvhost! scvhost host multiple services in groups.
My System SpecsSystem Spec
.

18 Jul 2010   #4
astanar

windows 7 64
 
 

Hey, Well I use most of them yes but I have no idea about the SCVHOST services and why there are so many. Thing is even with all those services my ram usage is only 20-30% which is fine. Whats bugging me is why is it going to 95% when it does not show any increase in the list at all! If I look at the list at 95% and wait couple minutes, it will drop back to whatever it was(20-30%) but show no change in the list.
My System SpecsSystem Spec
18 Jul 2010   #5
zigzag3143

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by astanar View Post
Hey, Well I use most of them yes but I have no idea about the SCVHOST services and why there are so many. Thing is even with all those services my ram usage is only 20-30% which is fine. Whats bugging me is why is it going to 95% when it does not show any increase in the list at all! If I look at the list at 95% and wait couple minutes, it will drop back to whatever it was(20-30%) but show no change in the list.
You absolutely need the scvhosts. m mthere are used by the system to communicate with the outside world. Even if you werent connected to the internet you would still need them.

do you hsve show all process checked in taskmanager? where are you viewing the 95 cpu use?

Ken
My System SpecsSystem Spec
18 Jul 2010   #6
astanar

windows 7 64
 
 

yes i do have show all process clicked and it is not 95% cpu but physical memory.
My System SpecsSystem Spec
18 Jul 2010   #7
mickey megabyte

ultimate 64 sp1
 
 

Quote   Quote: Originally Posted by zigzag3143 View Post
... where are you viewing the 95 cpu use?

Ken
at the centre bottom of his screenshot.

+ you do need those svchosts!
My System SpecsSystem Spec
18 Jul 2010   #8
Anak

Microsoft Community Contributor Award Recipient

Win 7 Home Premium 64bit Ver 6.1.7600 Build 7601 - SP1
 
 

Yes everyone I understand about svchost, and its necessity, but I can count ten of them in just what I can see in the OP's screenshot

Then something's really weird, I don't have any listed in my win 7 processes' tab.

My XP runs with eight, and are not any where near as loaded up as the OP's.


astanar, can you post a screenshot of your start-ups?

You can go; Start> Run> Type in _ msconfig _> Start up tab
My System SpecsSystem Spec
18 Jul 2010   #9
astanar

windows 7 64
 
 

will do as soon as I get home, at work currently. It is really weird, when it happens the RAM goes up to 95-96% then I can hear the HD being used for whatever reason.
My System SpecsSystem Spec
18 Jul 2010   #10
mickey megabyte

ultimate 64 sp1
 
 

Quote   Quote: Originally Posted by Anak View Post
Yes everyone I understand about svchost, and its necessity, but I can count ten of them in just what I can see in the OP's screenshot

Then something's really weird, I don't have any listed in my win 7 processes' tab.

My XP runs with eight, and are not any where near as loaded up as the OP's.


astanar, can you post a screenshot of your start-ups?

You can go; Start> Run> Type in _ msconfig _> Start up tab
are you sure??? you have the 'show processes from all users' box ticked?

here's mine:


Attached Images
 
My System SpecsSystem Spec
Reply

 Weird RAM usage




Thread Tools




Similar help and support threads
Thread Forum
Frequent unresponsiveness, 100% hardware disk usage, 0% software usage
Every 10-40 minutes, the application I'm currently working in becomes unresponsive, and after a minute or two, the window turns white, notifying me that it's not responding. This unresponsiveness quickly spreads to other open processes, rendering them frozen as well. I can still use the mouse, and...
Performance & Maintenance
Really weird 100% CPU usage issue by no particular process
Hi there! As you will see, English is not my first language (by far :p) Some days ago I noticed after a couple of minutes I start mi PC, my CPU usage goes to a constant 100% , so I checked for viruses and such but MSE gave me nothing and neither Malwarebytes. Here's the weird thing, I checked...
Performance & Maintenance
System Restore - Current usage exceeds Max Usage
In system protection, the current usage is at 405GB while max usage is defined at 279GB (30%). 1) How this can happen ? ,and 2) How can I set the Max Usage to be kept?
Backup and Restore
Weird system error after weird BSOD
Hello, Currently I have a big problem with my Computer, i can't run Windows in normal mode, and currently using Safe Mode I will describe the problem and Windows_NT6_BSOD_jcgriff2.zip DESCRIPTION My computer have some BSOD a few days before, but it's rare and after it restarts, Windows...
BSOD Help and Support
Weird RAM Usage
Hey guys, First of all, I have 2 Gbytes of RAM. In the past days, RAM usage on my PC was normal like 600-700mb at idle, 800-1500mb when used. Since yesterday, RAM usage became weird, like MSE v2 consuming like 70mb (see attached screenshot), Emsisoft Anti-Malware at around 30mb (before it was...
General Discussion
Windows 7 random CPU usage and high physical memory usage!!!
Ok, I am literally KILLING myself over this! I installed Windows 7 64Bit over XP around a month ago and it was so good that I recommended it to my brother who was previously on XP too. We got him a copy of the 32bit version as he has only 2gb of memory, and he installed it on his machine....
Performance & Maintenance


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:15.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App