Windows 7 Forums

Showing results 1 to 3 of 3
Search took 0.00 seconds.
Search: Posts Made By: rizzen93
Forum: Hardware & Devices 31 Aug 2010
Replies: 6
Views: 1,316
Posted By rizzen93
Just wrapped it back up in the box it came in,...

Just wrapped it back up in the box it came in, going to send it off back to Newegg tomorrow morning.

Thanks for the help anyways, folks. Hopefully I won't have to ask about the next one I get.
Forum: Hardware & Devices 31 Aug 2010
Replies: 6
Views: 1,316
Posted By rizzen93
I was in the process of doing that just as you...

I was in the process of doing that just as you posted. :)

Contrary to the smiley, I have the same problem on my laptop, which runs XP 32/Linux Mint. In XP I get the USB device not recognized...
Forum: Hardware & Devices 31 Aug 2010
Replies: 6
Views: 1,316
Posted By rizzen93
External HD not recognized

Just bought myself a WD Elements 640GB external drive (http://www.newegg.ca/Product/Product.aspx?Item=N82E16822136473).

Just took it out of the box it came in, plugged it in, and Win 7 doesn't...
Showing results 1 to 3 of 3

 
Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:17 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33