Windows 7 Forums

Showing results 1 to 3 of 3
Search took 0.00 seconds.
Search: Posts Made By: jmck95
Forum: Hardware & Devices 24 Nov 2012
Replies: 9
Views: 2,195
Posted By jmck95
All i did was put the parts together, tested it...

All i did was put the parts together, tested it once without the hard drive. it worked like it should, then i plugged the hard drive in, and it started up like normal. detected and replaced drivers...
Forum: Hardware & Devices 21 Nov 2012
Replies: 9
Views: 2,195
Posted By jmck95
it worked!!! Windows 7 took to the new hardware...

it worked!!! Windows 7 took to the new hardware like it was a child in a candystore
Forum: Hardware & Devices 14 Nov 2012
Replies: 9
Views: 2,195
Posted By jmck95
Moving hard drive from one computer to another, will it work?

Hello, I am planning on building a new computer. I was wondering if my current hard drive that is running Windows 7 64bit upgraded from windows vista would work in the new computer? It is a 750Gb...
Showing results 1 to 3 of 3

 
Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:15 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33