Windows 7 Forums

Showing results 1 to 4 of 4
Search took 0.00 seconds.
Search: Posts Made By: Dragon7
Forum: Hardware & Devices 13 Sep 2010
Replies: 8
Views: 4,353
Posted By Dragon7
Thanks, I tried different cables (3 of them)...

Thanks,
I tried different cables (3 of them) and no luck.
The Hard drive is an external USB (not internal) will changing the AHCI settings in bios still help?



I have no problems with...
Forum: Hardware & Devices 09 Sep 2010
Replies: 8
Views: 4,353
Posted By Dragon7
My Hard drive case is windows 7 compatible at...

My Hard drive case is windows 7 compatible at least that what the site says.
Unfortunately I cannot find windows 7 64 bit drivers, the ones I found were 32 bit.

Vantec €“ Vantec NexStar CX -...
Forum: Hardware & Devices 08 Sep 2010
Replies: 8
Views: 4,353
Posted By Dragon7
Thanks for the reply, yes I have plugged it...

Thanks for the reply,

yes I have plugged it into every usb port on my computer all 10 including back and side panel. It has 2 usb plugs on the cables, I plug them both in when using the drive...
Forum: Hardware & Devices 07 Sep 2010
Replies: 8
Views: 4,353
Posted By Dragon7
Hard drive lose connection on widows 7 but works under XP

Hi,

I have a 2.5 inch SATA external hard drive (100GB) in a "NexStar CX" case it works fine under XP machines but lose connection on widows 7 computers!

If I try to use it on a computer that...
Showing results 1 to 4 of 4

 
Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:08 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33