Windows 7 Forums

Showing results 1 to 3 of 3
Search took 0.00 seconds.
Search: Posts Made By: thatdavieguy
Forum: Hardware & Devices 27 Feb 2011
Replies: 5
Views: 5,759
Posted By thatdavieguy
I updated the bios yesterday with no success so...

I updated the bios yesterday with no success so its looking like 1 of 2 options, try the IRQ conflicts or reinstall windows :confused:
Forum: Hardware & Devices 26 Feb 2011
Replies: 5
Views: 5,759
Posted By thatdavieguy
It has its own power supply, i've checked on the...

It has its own power supply, i've checked on the iomega site and they say that all of their drivers are covered by windows 7.

I went through some of their steps that they detail for support on...
Forum: Hardware & Devices 26 Feb 2011
Replies: 5
Views: 5,759
Posted By thatdavieguy
External Hard Drive Not Being Recognised

Hi,

I've been using a 1TB iOmega external hard drive with my laptop for about a month and a few days ago it stopped working and isn't being recognised, the power light comes on when i connect the...
Showing results 1 to 3 of 3

 
Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:40 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33