Windows 7 Forums

Showing results 1 to 3 of 3
Search took 0.00 seconds.
Search: Posts Made By: Klosterman95
Forum: Gaming 28 Apr 2011
Replies: 7
Views: 2,679
Posted By Klosterman95
Uhm...My PSU shouldn't have anything to do with...

Uhm...My PSU shouldn't have anything to do with it. But it's a 750W powersupply, I don't know the specific brand. I just don't know what else i could do. I will updated the drivers for my card.
Forum: Gaming 20 Mar 2011
Replies: 7
Views: 2,679
Posted By Klosterman95
Entire computer is lagging while playing games

hello everyone, im still trying to figure out why my computer is lagging on the easiest-to-run games out there like World of Warcraft. But anyways, I really need to know what exactly is lagging my...
Forum: Gaming 25 Feb 2011
Replies: 3
Views: 1,228
Posted By Klosterman95
Entire system is lagging while playing games

Hello everyone, Well today I launched Battlefield: Bad Company 2 and maybe 30 seconds into playing, my entire system begins to lag for 5 second intervals, it will stop and return to normal, but keep...
Showing results 1 to 3 of 3

 
Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:50 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33