Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Software permissions causing headache


15 Sep 2010   #1

windows 7
 
 
Software permissions causing headache

I installed filezilla ftp server to test a ftp software application i have built for use on an external server. When my application tries to copy a file to my server, the server reports a 550 error which means it cannot write to the folder eventhough it has full permission in the application settings. I had a similar problem with apache with this matter but i fixed it by running the server as the administrator. I tried this with filezilla but with no luck. I don't see the shield on the programs icon but instead i see a lock in the left corner. If i change the location to my documents, the copy works but i need the server to work on the htdocs folder like my apache does without having to change all my settings. Can anyone provide a suggestion into allowing my server to write to a program files folder?

My System SpecsSystem Spec
.

15 Sep 2010   #2

Windows 7 32 bit
 
 

You could try this:
Built-in Administrator Account - Enable or Disable

If it doesn't work from there I don't know how you'd do it.

edit: the other possibility may be to set up 'zilla ftp server in a different folder. Instead of installing to Program Files make a folder directly under C: like MyServer or something. I'm not into server programming but if you use relative paths you may be able to transplant the thing as is after testing.
My System SpecsSystem Spec
16 Sep 2010   #3

windows 7
 
 
Problem solved

I tried changing the run as administrator that worked for apache but i though that perhaps the permission is not used until the software restarts. I tried restarting the pc but still no luck. I then uninstalled the software out of frustration and then re-installed it and it turns out that even if i uninstall the application, the settings are saved and when you install the application again, it uses the run as administrator and this fixes the problem. I think i'm getting to grips with the whole concept but it aint no xp.
My System SpecsSystem Spec
.


Reply

 Software permissions causing headache




Thread Tools



Similar help and support threads for2: Software permissions causing headache
Thread Forum
Expert Advice Needed: W7 x64 Software Causing Random BSODs! BSOD Help and Support
Second OS causing permissions problems General Discussion
BSOD error. possible driver software causing blue screen BSOD Help and Support
Desktop toolbar on the Taskbar causing headache General Discussion
Solved Homegroup Headache (or Network Headache -- I don't know which). Network & Sharing
permissions (maybe) causing audio issues Sound & Audio
BSOD: Software (Isys) Causing Issue? BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:00 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33