Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Autoplay is 'mixed up' and not working.


15 Nov 2010   #1

Win 7 Home Premium 64 bit
 
 
Autoplay is 'mixed up' and not working.

Running Win 7 Home Prem 64 bit and autoplay will not run a software instal CD/DVD.

I have reset all autoplay defaults to "Take No Action" except Software and Games which is set to "Instal or run prog". I have restarted Win to ensure these stick. When I try to install a prog from the CD the Mixed Media options come up and then disappear. After that nothing. I can't even run the Win install CD to refresh Windows.

If I try to run Setup.exe or similar I get an error that this is not a Win installer.

Any help appreciated. A fresh instal of Win is a worry - I'm a software junkie with over 200 apps installed.


My System SpecsSystem Spec
.

15 Nov 2010   #2

Windows 7 Ultimate x86
 
 

Is there any chance that really isn't a win installer/ the cd copy is bad ?
If you open the cd/DVD in Explorer, double click the setup.exe and it still dosn't take it, this is not an autoplay issue anymore.
It could be as simple as a dirty lense or a corrupted CD/DVD driver up to a faulty drive.
I (personally) would not automatically assume, a fresh install would be the way to go here.

-DG
My System SpecsSystem Spec
19 Nov 2010   #3

Win 7 Home Premium 64 bit
 
 

OK an update. Have done a fresh install of Win and everything was working normally. Then for some reason the old behaviour has returned. Some software CDs will install by manually running setup.exe and others won't.

Is there any way of resetting autoplay from within regedit as the Control Panel approach is not removing this "odd" behaviour.

It does seem that autoplay is assessing the software as "mixed content" rather than programs. These are well known progs like MS Office, Sony Vegas Studio, Serif WebPlus and they are original discs.

I thought Adobe Lightroom 3 might be the culprit as it inserted itself as default in just about every category but uninstalling it did not fix my problem.
My System SpecsSystem Spec
.


19 Nov 2010   #4

Windows 7 Ultimate x86
 
 

Granted, whatever you set in Control Panel ends up in the registry anyways.
Here is the registry setting to check, or to turn off Autorun:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\cdrom
A value of 1 means enable autorun (on), while zero means disable autorun.

Another way to disable autoplay would be to block a drive from the Media Change Notification.
If that is the case you would find a dword "NoDriveTypeAutoRun " either in

HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer
or in
HKEY_LOCALE_MACHINE\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer

For the correct values look here

-DG
My System SpecsSystem Spec
19 Nov 2010   #5

Win 7 Home Premium 64 bit
 
 

Thanks for the answer. It seems I have autoplay enabled but my Pioneer drive set to AutorunAlwaysDisabled. Screenshot added. How do I undo this setting for the Pioneer drive (I have 2 drives). It also seems I do not have a default drive set (screenshot 2). Should I have this set?


Attached Thumbnails
Autoplay is 'mixed up' and not working.-cdrom.jpg   Autoplay is 'mixed up' and not working.-cdrom2.jpg  
My System SpecsSystem Spec
19 Nov 2010   #6

Windows 7 Ultimate x86
 
 

Are you sure that it refers to YOUR Pioneer Drive ???
Because that AutoRunAlwaysDisable holds drives that don't support AutoRun (like CD changers etc.)
And nope...Default is normally not set on that Enum key.

It must be some of your installed software, taking over control (for example Roxio is known to do that.)
Do you recall what you installed after it worked and when it stopped?

If you can't recall, I would disable all non-Microsoft services for a test. If that solves the problem you will have to go through it to identify the culprit
Here is a nice Microsoft Howto for that:

How to troubleshoot a problem by performing a clean boot in Windows Vista or in Windows 7

-DG
My System SpecsSystem Spec
Reply

 Autoplay is 'mixed up' and not working.




Thread Tools



Similar help and support threads for2: Autoplay is 'mixed up' and not working.
Thread Forum
Solved Autoplay not working General Discussion
Solved Autoplay/autorun not working General Discussion
Autoplay not working General Discussion
Network of computers with mixed operating systems was working now not Network & Sharing
Autoplay not working General Discussion
AutoPlay stopped working, help. Customization
Conficker Working Group: Efforts To Fight Botnet A Mixed Bag Security News

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:52 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33