Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: O&O Defrag

05 Dec 2010   #1

W7x64 Pro, SuSe 12.1/** W7 x64 Pro, XP MCE
 
 
O&O Defrag

When I just tried to open O&O Defrag, it produced the error shown below. Services does show that the defrag agent is started, but I also selected to restart it, just in case.

I reinstalled the program, and it still produces the same error when starting. When the OK button is selected, Windows pops another error saying that it has stopped working, and of course, that closes the program.

I'm not certain if the 10038 error is part of the first error message or is separate, but I didn't find it Googling. This problem needs help.



Attached Images
 
My System SpecsSystem Spec
.

07 Dec 2010   #2

W7x64 Pro, SuSe 12.1/** W7 x64 Pro, XP MCE
 
 

I received a response yesterday from O&O support, which was not of much use, because it simply suggested what I had already considered...that my firewall was interfering in some fashion with the defragger, but neither giving the defragger full control of it's activity, nor shutting down the firewall and it's service had any effect on the problem.

If there is anything interfering with it, it is reminants of F-Secure, with I have uninstalled, yet I found two items in the Device Manager (fs_rec and F-Secure Firewall Driver), which I have been unable to uninstall via the Device Manager. I even did a search of the Registry, in which I found numerous keys left behind, which I deleted, but afterward the OS began to exhibit so many problems, that I had to restore the system via a backup image. I do not know that these are the cause of the defragger problem, but it is the only thing that I have been able to find so far.

I would restore the system by using an older image, but I don't think that I have one old enough to do so. Is there a tool available so where that would rid my system of these program scraps cleanly?
My System SpecsSystem Spec
07 Dec 2010   #3

Windows 8 Professional
 
 

Just curious why you feel the need to use another defrag program when there is a built in scheduling defrag in Windows 7?


Also, I would recommend the very good and FREE Defraggler (you can download it from filehippo.com).
My System SpecsSystem Spec
.


07 Dec 2010   #4

W7x64 Pro, SuSe 12.1/** W7 x64 Pro, XP MCE
 
 

I did not post this thread to debate the merits of one defragger vs another, it should be sufficient to say that I, like everyone else, uses a program that they have confidence in and feels comfortable with. I do not believe that my current problem is the result of a defect in the program.
My System SpecsSystem Spec
07 Dec 2010   #5

Windows 8 Professional
 
 

Quote   Quote: Originally Posted by seekermeister View Post
I did not post this thread to debate the merits of one defragger vs another, it should be sufficient to say that I, like everyone else, uses a program that they have confidence in and feels comfortable with. I do not believe that my current problem is the result of a defect in the program.

hence why my response was "Just curious why you feel the need to use another defrag program when there is a built in scheduling defrag in Windows 7?"

I am curious as to WHY you feel O&O is better.



On a side note I feel its important to state that O&O claim their defrag program will make SSD's run faster. On that statement alone I am passing O&O off as another program that makes you pay money ($50 hah) for something that can be done just as well if not better by built in or FREE options.
My System SpecsSystem Spec
07 Dec 2010   #6

Windows 8 Professional
 
 

Also in the error it states that it cannot connect to the "defrag agent" or service. Have you checked to see if the O&O service is running or not? Make sure it is set to run on startup.
My System SpecsSystem Spec
07 Dec 2010   #7

Systems 1 and 2: Windows 7 Enterprise x64, Win 8 Developer
 
 

Hi Seekermeister,

Your firewall is blocking it.

Open port 50300 and you should be good to go.

Lemur
My System SpecsSystem Spec
07 Dec 2010   #8

W7x64 Pro, SuSe 12.1/** W7 x64 Pro, XP MCE
 
 

Lunarpancake,

Second sentence from the OP:

Quote:
Services does show that the defrag agent is started, but I also selected to restart it, just in case.
My System SpecsSystem Spec
07 Dec 2010   #9

W7x64 Pro, SuSe 12.1/** W7 x64 Pro, XP MCE
 
 

Quote   Quote: Originally Posted by Lemur View Post
Hi Seekermeister,

Your firewall is blocking it.

Open port 50300 and you should be good to go.

Lemur
It appears to me that this port is open:


Attached Images
   
My System SpecsSystem Spec
07 Dec 2010   #10

Systems 1 and 2: Windows 7 Enterprise x64, Win 8 Developer
 
 

So you're using Outpost for your firewall? Are you using a second firewall? Just had to ask....
My System SpecsSystem Spec
Reply

 O&O Defrag




Thread Tools



Similar help and support threads for2: O&O Defrag
Thread Forum
Auslogics Disk Defrag vs IObit Smart Defrag Software
Solved Disk Defrag, Registry Defrag and Registry Cleaners Performance & Maintenance
How do you defrag? Performance & Maintenance
Auslogics Defrag vs Win7 built-in Defrag? Performance & Maintenance
Does Puran Defrag 7.3 Free work with Windows 7 Defrag disabled ? Software
Windows Disk Defrag Doesn't Defrag Performance & Maintenance
Does Windows Defrag defrag system files? Performance & Maintenance

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:36 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33