Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: How about running .jar files on win 7 beta

27 Jun 2009   #1
extomas

WIndows 7
 
 
How about running .jar files on win 7 beta

quick question:

anybody have problems running .jar files on windows 7 ? Already downloaded newest version 14 from sun.


My System SpecsSystem Spec
.
27 Jun 2009   #2
extomas

WIndows 7
 
 

Hey please somebody
My System SpecsSystem Spec
27 Jun 2009   #3
Generator

XP Pro SP3 x86/Vista SP2 x64/Win7 x64 Triple-boot
 
 

do you mean your version is '6 update 14' by any chance?

Thats the version I have running and jar files work here but please note, not all java files are designed for the PC.

Also, some java files require other dependecies like .net framework etc so check the authors site to see if it needs anything else installed first.

What is it your trying to install exactly? If you can give me an address to download the file, I could try it here on my machine if you wish to ensure it's not your java.
My System SpecsSystem Spec
.

28 Jun 2009   #4
extomas

WIndows 7
 
 

I have a little .jar program which was running on XP correctly...
I going to send you PM with download url to check that file..

This program don't have producer website, because it is coded for privately use. Please tell me what you find out
My System SpecsSystem Spec
28 Jun 2009   #5
Generator

XP Pro SP3 x86/Vista SP2 x64/Win7 x64 Triple-boot
 
 

Quote   Quote: Originally Posted by extomas View Post
I have a little .jar program which was running on XP correctly...
I going to send you PM with download url to check that file..

This program don't have producer website, because it is coded for privately use. Please tell me what you find out

Hi extomas, I got your pm..

I've tried running the file in each of my Windows (XP Pro, Vista Ultimate and Win 7).

In Win 7 and Vista I get the same error which is:
Quote:
Could not find the main class:
draudimoskaiciuokle.DraudimoSkaiciuokleApp. Program will exit
In XP though, I don't get an error but nothing happens at all.

Could it be possible that you are either missing some other files or that it's supposed to be run from a web server/site?
I strongly think that it's not meant to be ran by itself, it seems it's missing some dependencies to me for it to fail on three OS's.

I don't have enough knowledge personally to debug .jar files, my knowledge is mainly Ajax/java script.

If you do still think it could be Java itself playing up, you can test the install here: How do I test whether Java is working on my computer?
My System SpecsSystem Spec
21 Feb 2010   #6
fergofm

Windows 7
 
 

Hi,

It seems to me that I am having the same problem. Apparently this thread didn't come to any conclusion, am I right?

The scenario is as follows:
I used to run a little jar file coded by me in XP, but now that I am using Windows 7 it doesn't work any more.
My java version is Version 6 Update 18

I get the following message:

Exception in thread "main" java.lang.NoClassDefFoundError:
Caused by: java.lang.ClassNotFoundException:
at java.net.URLClassLoader$1.run(Unknown Source)
...
Could not find the main class: C:\SMFilesGenerator.jar. Program will exit



I would appreciate it so much if you could help me.
[COLOR=#000000 ! important][COLOR=#000000 ! important][COLOR=#000000 ! important]Lang[/COLOR][COLOR=#000000 ! important]Detect[/COLOR][COLOR=#000000 ! important]de>es [/COLOR][COLOR=#000000 ! important]Google[/COLOR][COLOR=#000000 ! important]C[/COLOR][COLOR=#000000 ! important][/COLOR][/COLOR]
[COLOR=#000000 ! important]Hi, It seems to me that I am having the same problem. Apparently this thread didn't come to any conclusion, am I right? The scenario is as follows: I used to run a little jar file coded by me in XP, but now that I am using Windows 7 it doesn't work any more. My java version is Version 6 Update 18 I get the following message: Exception in thread main java.lang.NoClassDefFoundError: Caused by: java.lang.ClassNotFoundException: at java.net.URLClassLoader$1.run(Unknown Source) ... Could not find the main class: C:\SMFilesGenerator.jar. Program will exit I would appreciate it so much if you could help me.[/COLOR]
[/COLOR]
My System SpecsSystem Spec
Reply

 How about running .jar files on win 7 beta




Thread Tools




Similar help and support threads
Thread Forum
How do I share files with a PC running XP?
I wanted to share files between a PC running XP Pro and my Win Laptop through a router with ethernet cables. I tried a lot and lot (have done system restore for 8-10 times in this process) to do this by following the tutorials and guides all over the internet but in vain. I don't wanna mess it up...
Network & Sharing
.exe files running problem
all my .exe files are getting opened with utorrent. tried to fix it with .reg file but that didn't help at all. now i cant download, cant install anything .unable to run any .exe programs.:cry: how can i fix this?
General Discussion
Issues running .bat files
I am having a lot of difficulty running batch files. I simply want to create a runonce logon script that will install my .reg file I have created for every user who creates an account on this computer. My file is called c:\tweaks.reg. The file works fine when I double click it or run from command...
General Discussion
BSOD running SW:The Old Republic Beta, error 1000007e
Not very tech-literate but here is what I got (+ uploaded required files): System Specs: OS: Win 7 x64 Professional CPU: Intel(R) Core(TM) i5 CPU 750 @ 2.67GHz Motherboard: Intel DP55WB RAM: 4 GB Graphics Card: NVIDIA GeForce GTS 250
BSOD Help and Support
Help. I'm a moron, so I deleted the SP1 Beta uninstall files.
Uh, so, yeah. Windows helpfully gives me a message, every-so-often, stating that it will expire in 0 hours, as I have a beta version of SP 1. Obviously, the solution is to use the non-beta version of SP 1, however, I can't do that, because I accidentally deleted the un-install files, using...
Installation & Setup
problem: running srt,sub with mkv files
hi i have hp laptop with windowd 7 in the beginning my MC wasn't able to play mkv files until i installed win7codecs pack and x64components pack. the problem is my subtitles don't show up with the video in MC. I can run my Subtitles with WMP and Real player but i can't run it with MC
Media Center


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:14.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App