Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: can't get VisualStudio 2008 to work (Win 7 32 bit)

23 Feb 2011   #1

Windows 7 Ultimate 32bit
 
 
can't get VisualStudio 2008 to work (Win 7 32 bit)

Hi,

I'm desperately trying to run a microsoft program on a microsoft machine - shouldn't bee too hard eh? well we'll see...

I want to install the XNA Game Studio 3.1 and Microsoft Visual C# 2008 Express Edition SP 1 on my Windows 7 Ultimate 32 bit computer...
like many many other users, i encountered the error "Requested registry access is not allowed" when starting up any new project in VS 2008, and after going through hell with my registry ( http://www.sevenforums.com/crashes-d...ml#post1255243 ), i only got a security warning ( http://img171.imageshack.us/img171/3682/screen100.jpg ), and then for either option i chose "object reference not set to an instance" ( http://img203.imageshack.us/img203/3299/screen101vi.jpg )

i was just after all that crap that my computer was working again and didn't feel like trying 2008 some more, so i downloaded and installed Visual Studio C# 2010 Express and XNA Game Studio 4.0 and that worked perfectly

but the whole reason i wanted to install the 2008 version is that a friend of mine is working on a project in XNA GS 3.1 and xna 3 won't run on anything else than 2008, and i want to work with him on that project...
he heared they made some changes in functions of XNA from version 3* to version 4.0, so naturally we're concerned about compatibility problems, and it WOULD be so easy if i could just use VS 2008 as well - but i can't seem to succeed in that now...


anyways, back to my problem history:

so i have Visual Studio 2010 installed, after uninstalling everything about VS 2008 and XNA, and cleaning the registry.

now i tried installing VS 2008 again, and now i got yet a different message when trying to open a new project:
http://img263.imageshack.us/img263/3839/screen101.jpg
followed by
http://img39.imageshack.us/img39/3999/screen102t.jpg

sigh...

i made sure i have access to all the related keys in the registry (my user name, Admin and System)

what should i do?

thank you in advance, and everybody who reads this, for caring : )

My System SpecsSystem Spec
27 Feb 2011   #2

Windows 7 Ultimate 32bit
 
 

Jesus... -.-

After brutally ripping out most of the .NET framework (i wanted to simply uninstall it, and then re-install it from the beginning - but HELL it revolted : D it was a bloody mess, unfortunately there was a point of no return and the theory applied: "you have to break someone in order to reshape them"... i wish it hadn't come to it, as really NOTHING seemed to be working inbetween again -.-.... but at some point i reigned again :clap:
at one point i could use this wonderful package again:
All-In-One Runtimes (Collection of runtime support like .NET packages),
which was really nice and convenient) and several struggling battles between uninstalling everything, system restores and failed updates and repairs, AND even making enough space on a different harddisk and installing a seperate instance of Windows, where everything worked - my internet broke down >.<
"Error 651: The modem (or other connecting device) has reported an error."
after almost 2 days of fighting THAT (astonishingly, setting my adapter's IPv4 settings on
"IP address: 192.168.1.210
Subnet Mask: 255.255.255.0
Default Gateway: 192.168.1.1
Primary DNS server: 192.168.1.1
Secondary DNS server: 4.2.2.3"
(got the tip from here)
worked), i renewed every installation that had to do with Visual Studio (the .NET frameworks just had been renewed), this time making sure everything had the same language by default (i'm german and my Windows is too - i HAVE installed english language files too but it's just not the same^^) - and somehow it worked this time... i almost wish it DIDN'T, so i could go on and search for the CAUSE why it didn't... because now i still don't know what was preventing it from working and i can't give you a better solution than to half kill your system and re-install everything again -.-

well... i don't know if i should mark this as SOLVED, because... it IS solved, but this thread doesn't really contain any real solution... i always hate it if i'm looking for answers and all i read is "re-install this, re-install that" :roll:
but... i don'T have anything else here :shrug:
My System SpecsSystem Spec
Reply

 can't get VisualStudio 2008 to work (Win 7 32 bit)





Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 05:37 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33