Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows Service Fails to 'Access' System Interop


02 Mar 2011   #1

Window 7 Embedded
 
 
Windows Service Fails to 'Access' System Interop

Web Service Hosted by Windows Service Fails to 'Access' System Interop DLL

Hi
I have some hardware controlling software running on Windows 7 Embedded. Running a Windows Forms test harness will successfully control the hardware via the 3rd party dll which is invoked via interop.

Trying to run the same driver using a web service hosted in a windows service fails either on the first call or, for instance, if I try a LoadLibrary() even with a fully qualified path (note File.Exists says true...).

Tried quite a few tricks but to no avail....

AndyF.

My System SpecsSystem Spec
.

Reply

 Windows Service Fails to 'Access' System Interop




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:50 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33