Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: cannot run setup.exe (everything else works)

19 Mar 2011   #1
tvestergren

Windows 7 Professional x64
 
 
cannot run setup.exe (everything else works)

Hi.

I am new here on Seven Forums but i have used it several times before to solve various problems, so thanks for a great forum. But now I have i tricky one that doesn’t want to be solved.

It is a setup.exe file that doesn’t launch, nothing happens when I press it, (double click, right click then open or run as administrator). I did a search and found that you could restore default Windows 7 file extension type associations, so I tried that on .exe, but it still won’t start.

The setup.exe file is for a program I want to install and it is in a folder with a bunch of other stuff and not in a .iso file or something like that. I believe it isn’t broken because many of my classmates have used it recently.

Two or three times the following window has appeared but despite what i chose nothing happens (the program hasn't been installed on this disk/windows before)
(roughly translated it says:

Assistant for program compatibility

This program may not have installed correctly

If not installed properly, try reinstalling with
settings that are compatible with this version of Windows

Reinstall with recommended settings

This program is installed correctly
)

So i tried with different capability settings, especially XP (sp3) (because the setup.exe file worked on a Windows XP (sp3) computer this morning), but still nothing.


I am grateful for any replies.

/Tommy




Attached Images
 
My System SpecsSystem Spec
.
20 Mar 2011   #2
r3plicat3

Windows 7 Ultimate x64
 
 

This may seem like a stupid question, but with some computers I've had to fix, Im going to ask it anyway...

When you double click the setup.exe there isn't an admin prompting permission in the task bar, is there? If so, click that.

otherwise I would advise installing the software as an administrator if you haven't already. If THAT doesn't work, then check your antivirus software and see if its blocking certain files from running.

let me know if none of those work, I have some other ideas.
My System SpecsSystem Spec
20 Mar 2011   #3
Maguscreed

Microsoft Community Contributor Award Recipient

Windows 7 x64
 
 

I've had luck using this to install stubborn apps.
Download Windows XP Mode
My System SpecsSystem Spec
.

20 Mar 2011   #4
tvestergren

Windows 7 Professional x64
 
 

Thanks for the replies. It's not a stupid question, I have a habit to screw everything up and not realy knowing what I do so a simple solution might do it, but I tried what you said and it didn't work. No prompts, tried right-click and launch as administrator and deactivated antivirus and firewalls.

I've even reinstalled Windows 7 so everything is in default but the .exe will not launch.

"Windows XP Mode" is that like when you launch "windows" on a mac?
How does that effect performance?
My System SpecsSystem Spec
20 Mar 2011   #5
Maguscreed

Microsoft Community Contributor Award Recipient

Windows 7 x64
 
 

Well I don't know your system specs, or the software your trying to install, you only need to activate it when you want to, it doesn't have to be on all the time.
My System SpecsSystem Spec
20 Mar 2011   #6
tvestergren

Windows 7 Professional x64
 
 

It was a very good computer a few years back and the software is Pro Engineer (CAD).

I will try and see if it works.
My System SpecsSystem Spec
21 Mar 2011   #7
tvestergren

Windows 7 Professional x64
 
 

I tried it and I was able to install the program but it doesn't work well, there is to much lag.
My System SpecsSystem Spec
21 Mar 2011   #8
Maguscreed

Microsoft Community Contributor Award Recipient

Windows 7 x64
 
 

well now that it's installed you can try creating a shortcut to your normal desktop and running in windows 7 in compatibility mode.
It may run just fine.
My System SpecsSystem Spec
21 Mar 2011   #9
tvestergren

Windows 7 Professional x64
 
 

I'm not sure I understand you correct, but it still launch XP mode and then the program

what did you mean with "running in windows 7 in compatibility mode"?
My System SpecsSystem Spec
21 Mar 2011   #10
Maguscreed

Microsoft Community Contributor Award Recipient

Windows 7 x64
 
 

Now that it's installed you should be able to use normal windows 7 mode just to run the application. If it gives you trouble, you can navigate to the program's main executable file , right click it, choose properties and set it for windows xp compatible mode, in the compatibility tab.
My System SpecsSystem Spec
Reply

 cannot run setup.exe (everything else works)




Thread Tools




Similar help and support threads
Thread Forum
Nothing Works
Helo everybody! I have a problem with my laptop, I starts but it gets only as far as the blue screen and thats it, nothing more, it gets stuck there. I have tried with start repair, safe mode, commend prompt, nothing happens, it only stops or loads and ends up with the blue screen. I did boot...
General Discussion
RAID Setup - Alienware - A few setup questions?
I have just finished moving my OS from a 3TB hard drive to an SSD. I now have 2 matching drives that I would like to set up as a RAID array. A couple of questions: 1. Do I need to backup the data that will be on the RAID before setting it up and then move it back once it has been setup? 2. Do...
Hardware & Devices
Tuner Setup - setup loops at accepting Channel Changer
have installed new Haupaugge HVR 2250 turner card and have to set up TV Tuner and confirm remote functions after some driver conflicts i got the card and remote working to control Shaw Digital Box via IR blaster and can see live TV when i'm on the "Test Channel Changing" page - I can see and...
Media Center
Win7 Starter getting error on initial setup; locked in setup loop
I have several Asus Eee netbooks that I'm getting set up to use at my school. I had some parent volunteers helping me get them ready to deploy, and one of the netbooks was plugged in to initially power it up, but then hard-shut-down before Windows could run through its initial setup. Now when I...
Installation & Setup
Audio works, then stops then works again
Hi all Quick question if i may, this is really baffling me. I have onboard sound on my xfx 750i mobo. ( realtek, i believe) i have installed the latest drivers and for some reason i have this strange problem. If i have my speakers plugged in the back of the PC. the sound is really good. Good...
Sound & Audio


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 06:25.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App