Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Broken windows installer :( Help needed.


03 Apr 2011   #1

Main OS: Windows 7 64 bit, Secondary: Vista 32 bit
 
 
Broken windows installer :( Help needed.

Hi everyone,

It's been a while since i posted in these forums but i've recently found this issue and can't find any answers or ways to solve it.

What happens is, when i try to install certain applications, or remove certain ones i get an error saying "The feature you are trying to use is on a network resource that is unavailable."

When i try to install Virtualbox or uninstall SmartSVN.. i get this message so it aborts. It started ever since i reverted the Windows Service pack 1 install.

This is what it looks like:



I get this when i try to install the new Virtualbox, or uninstall the current one. In the location it specifies there is a .msi file there too. And when i press OK i get this:



I get this for another application SmartSVN and im thinking it might also happen for others. Something's clearly broken since i uninstalled Service Pack 1. Any ideas? I was thinking of running a windows repair off the install disc but will that remove anything on my pc like files?

thanks

My System SpecsSystem Spec
.

05 Apr 2011   #2

Main OS: Windows 7 64 bit, Secondary: Vista 32 bit
 
 

Nobody has any idea?
My System SpecsSystem Spec
05 Apr 2011   #3

Several, including Windows 7 x64 Ultimate
 
 

The error is usually because Windows is not allowing you as the user to access something. Check the permissions on the folders and files you are trying to use.

Otherwise, enable the special administrator account, log in with that, and try the install/uninstall then.

Regards....Mike Connor
My System SpecsSystem Spec
.


05 Apr 2011   #4

Main OS: Windows 7 64 bit, Secondary: Vista 32 bit
 
 

thanks for the reply.

I checked the permissions for each folder, Appdata, local, temp, virtualbox and they all have full permissions.
My System SpecsSystem Spec
05 Apr 2011   #5

Several, including Windows 7 x64 Ultimate
 
 

Sometimes msi mucks up. There used to be a fix for it here;

How do I uninstall Office 2003, Office 2007 or Office 2010 suites if I cannot uninstall it from Control Panel?

But Microsoft has now abdicated any responsibility for this, saying that the problems are caused by "bad" software.

On a number of occasions I have re-installed Windows because I was unable to solve the problem you are having within a reasonable time-frame.

On a few occasions running as admin has solved the problem.

I don't know of any other "fixes". Maybe somebody else can help?

Regards....Mike Connor
My System SpecsSystem Spec
05 Apr 2011   #6

Main OS: Windows 7 64 bit, Secondary: Vista 32 bit
 
 

Thanks for the info mate.

I'll look into that fix from Microsoft. If that doesn't work i might have to consider a format.

Hopefully someone else might have an idea.
My System SpecsSystem Spec
05 Apr 2011   #7

Several, including Windows 7 x64 Ultimate
 
 

Quote   Quote: Originally Posted by DaRonRon View Post
Thanks for the info mate.

I'll look into that fix from Microsoft. If that doesn't work i might have to consider a format.

Hopefully someone else might have an idea.
My pleasure.

You can still get the msi clean-up utility at various places, but I have not used it recently, ( not since before SP1), and I don't know whether it still works.

Regards....Mike Connor
My System SpecsSystem Spec
05 Apr 2011   #8

Main OS: Windows 7 64 bit, Secondary: Vista 32 bit
 
 

Wow i installed the tool and it solved the problem with installing VirtualBox!

I'll try SmartSVN and see if that works too.

Thanks again Mike!

edit: worked for the other app too
My System SpecsSystem Spec
05 Apr 2011   #9

Several, including Windows 7 x64 Ultimate
 
 

My pleasure. Glad to hear it worked.

Regards....Mike Connor
My System SpecsSystem Spec
05 Apr 2011   #10

Several, including Windows 7 x64 Ultimate
 
 

For anybody else having such problems with .msi installers/uninstallers,
you can still get the utility here;

Windows Installer CleanUp Utility Download - Softpedia

Instructions,( such as they are, not really very informative);

Windows - Installing Windows installer CleanUp utility

It works (or has worked), on quite a lot of .msi problems, so if you get a "strange" error when installing/uninstalling .msi software it is worth a try, but it is not a universal panacea.

On occasion it can also result in you having to re-install other programs which were installed using msi.

Regards....Mike Connor
My System SpecsSystem Spec
Reply

 Broken windows installer :( Help needed.




Thread Tools



Similar help and support threads for2: Broken windows installer :( Help needed.
Thread Forum
Solved Windows Installer broken... how to fix it? General Discussion
Windows 7 broken Performance & Maintenance
Deleting of Windows Installer Cache (C:\Windows\Installer\) Files News
My Windows 7 OS is broken, NEED SERIOUS HELP!! BSOD Help and Support
Broken Windows DVD? Installation & Setup
Windows Installer Broken Software
Magic Folder Gadget Broken - Help Needed Gadgets

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 12:21 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33