Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: problem with Itunes


17 Apr 2011   #1

Windows 7 Home Premium x64 Service Pack1
 
 
problem with Itunes

When I try to open Itunes, I get the following error:
"The Itunes Library.itl file is locked, on a locked disk or you do not have written permission for this file"

I then went to the file, took ownership of it and tried to pen it but the same error. I looked in Properties for the.itl file and discovered that in the security permissions there is a permission there for one of my accounts that says read and writ only which is probably the cause of the problem. I tried to create a new permission for my account and give it full control, but it only added a new one and didn't change the old permission.For the old permission when you click on it, the remove permission is grayed out so that I can't change it in any way. I was wondering if anybody could help me with this problem so that I could get Itunes working again, Thanks.

MusicalRabbi2k3




Attached Images
 
My System SpecsSystem Spec
.

17 Apr 2011   #2

Windows 8.1 ; Windows 7 x86 (Dec2008-Jan2013)
 
 

Hi MusicalRabbi2k3,

Welcome to Sevenforums

have you tried replacing the owner as described here?
My System SpecsSystem Spec
17 Apr 2011   #3

Windows 7 Home Premium x64 Service Pack1
 
 

I tried that. I was the owner of the file before. It seems like, for some reason the first 4 permissions were inherited from the hard drive and for all of them the remove button is grayed out even for my user even though my user is also the owner. I can click on them and edit them. When I change the permissions, It just adds a new permission entry that does not override the previous ones and for the new ones, under "inherited from" it says not inherited instead of E: where the program was installed
My System SpecsSystem Spec
.


18 Apr 2011   #4

Windows 8.1 ; Windows 7 x86 (Dec2008-Jan2013)
 
 

I was talking about Replacing the Owner, but not just "Taking ownership". Please provide screenshot of the same windows you did in the fist post, but with Owner tab.
My System SpecsSystem Spec
18 Apr 2011   #5

Windows 7 Professional x64 SP1 ; Windows Server 2012 R2 Standard
 
 

Which user Account are you Recieving this issue for? - The highlighted user account (In the image provided) Only has Read permissions - you will need to click edit and Tick the Full Control Box then apply your settings

Hope This Helps,
Josh
My System SpecsSystem Spec
Reply

 problem with Itunes




Thread Tools



Similar help and support threads for2: problem with Itunes
Thread Forum
iTunes Problem Software
Problem with iTunes Software
Problem with iTunes Software
iTunes compatibility problem Software
Problem with iTunes Installation & Setup
itunes 9 and win 7 pro x64 encountered problem Software

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:05 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33