Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Application locks during "file - save as"


17 May 2011   #1

window 7 professonal 32 bit
 
 
Application locks during "file - save as"

Hi -
I have and older application that I am trying to run in Windows 7 -32 bit.
It has run successfully in all versions of windows from 3.1 – Vista 32 bit.
The program installs and launches without issue, but when I click “file-save as” the program locks up once the “file window” opens. I cannot type a file name or select a location. Once I close the program using task manager I get an error about a “ole2disp.dll” (Any option in the “file” tab that causes the “file window” to open has the same result.)
The program runs if I create a virtual XP machine, so I don’t think the problem is with “ole2disp.dll” itself, but more one of Windows 7 permissions. I have tried various “compatibility modes” and taking ownership and giving full control to everything I can, but still no success. (another clue … when closed through task manager it prompts me to save my work, allows me to type a file name into a slightly different looking file window…. But it always saves a new blank file.)
Any thoughts?

My System SpecsSystem Spec
.

17 May 2011   #2

Windows 7 32 bit
 
 

Since it's an old 16 bit app I'd either try DosBox or look for an application that performs the same function:

Alternative Software And Apps for Windows, Linux, Mac, iPhone, Android, Web Apps/Online And Other Platforms - AlternativeTo.net
My System SpecsSystem Spec
18 May 2011   #3

window 7 professonal 32 bit
 
 

Note - Everything works fine if use Windows 7 to create a virtual XP machine; but there HAS to be a way to allow it to access the "file" menu....or at least I really want there to be solution that allows it to run straight up on Windows 7.

Can anyone at least explain why it would lock at at this particular point?
My System SpecsSystem Spec
.


18 May 2011   #4

Windows 7 32 bit
 
 

Kind of nebulous to try to patch up software with no name that I assume is no longer published. Unless you can find somebody else that got it to work I don't know where to go from here. Best bet may be to install XP on another partition or machine and network them to the Windows 7 machine.
My System SpecsSystem Spec
Reply

 Application locks during "file - save as"




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 05:55 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33