Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Redistributable issues

29 Jul 2011   #1

Windows 7 Ultimate x32
 
 
Redistributable issues

Hello community of sevenforums,

Here's my "story":

It's been a long time since my redistructable packages encountered problems. The period that redistructable wasn't working properly is approximal 2 months (by this i mean that i can't do a restore). General problem that i'm facing is:

Error 1935.An error occurred during the installation of assembly 'Microsoft.VC80.ATL,type="win32",version="8.0.50727.42",publicKeyToken="1fc8b3b9a1e18e3b",processorA rchitecture="x86"'. Please refer to Help and Support for more information. HRESULT: 0x80070003. assembly interface: IAssemblyCache, function: CreateAssemblyCacheItem, component: {97F81AF1-0E47-DC99-A01F-C8B3B9A1E18E}

I get that while trying to install Microsoft Visual C++ 2005 Redistributable, Microsoft Visual C++ 2008 Redistributable. Microsoft Visual C++ 2010 Redistributable installs without a problem, same as NET Framework 4.

That wouldn't be a big deal if I wouldn't get a "The program can't start because MSVCR80.DLL/MSVCR90.DLL is missing from your computer. Try reinstalling the program to fix this problem." error. As it appears, I can't run some programs that I really need.

Tried innumerable amount of solutions that i found on net, nothing worked so far, that's the mainly reason I'm posting this. I really lost hope...

Major things(the ones that might be/are caused because of redist):
  • Numerous programs don't work (the ones which uses runtime librarys)
  • Event viewer don't work (MMC could not create the snap-in. The snap-in might not have been installed correctly.)
  • Repair install does NOT work (gives an error (don't really remember it exactly) something like "installation process can not be started" it appears after first restart of repair install)
  • Did really MANY things to solve this problem out. Not talking of tens of uninstalling/installing redists/frameworks

P.S. Haven't tried clean install, there's many important files that takes large place on my laptop. Even if clean install worked, wipe is not an option. Also excuse me for my English language skills and move the thread if posted it in wrong section.

Professional help is really appreciated!


My System SpecsSystem Spec
.

29 Jul 2011   #2

Microsoft Community Contributor Award Recipient

Win 7 Pro 64-bit
 
 

Hello Mantas and welcome to Seven Forums.

Have you tried running System File Checker? If any damaged/corrupt files are found, run the scan 3-4 times.

SFC /SCANNOW Command - System File Checker
My System SpecsSystem Spec
29 Jul 2011   #3

Windows 7 Ultimate x32
 
 

Getting the same all 3 times:
Beginning system scan. This process will take some time.

Beginning verification phase of system scan.
Verification 80% complete.
Windows Resource Protection found corrupt files but was unable to fix some of th
em.
Details are included in the CBS.Log windir\Logs\CBS\CBS.log. For example
C:\Windows\Logs\CBS\CBS.log

Also have tried this command before. Similar results tho..
My System SpecsSystem Spec
.


Reply

 Redistributable issues




Thread Tools



Similar help and support threads for2: Redistributable issues
Thread Forum
Redistributable Package problem + IE9 9648 Windows Updates & Activation
Latest DirectX Redistributable Installer Software
Microsoft Visual C++ 2008 Redistributable Installation & Setup
WU update 643 error w/C++ 2005 redistributable Windows Updates & Activation
C++ Redistributable General Discussion
Can't install sony vegas, probably because of C++ Redistributable Software
MS Visual C++ 2008 Redistributable Packages Software

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:23 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33