Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Puran Defrag Error

06 Jul 2012   #1

Windows 7 Home Premium 64 Bit
 
 
Puran Defrag Error

This is not a pressing concern, but I am receiving the following error from time to time running Puran Defrag:
Code:
Faulting application name: PuranDefragGUI.exe, version: 7.3.0.0, time stamp: 0x4ef83885
Faulting module name: ntdll.dll, version: 6.1.7601.17725, time stamp: 0x4ec4aa8e
Exception code: 0xc00000fd
Fault offset: 0x0000000000054f4a
Faulting process id: 0x1904
Faulting application start time: 0x01cd5bc21c52e257
Faulting application path: C:\Program Files\Puran Defrag\PuranDefragGUI.exe
Faulting module path: C:\Windows\SYSTEM32\ntdll.dll
Report Id: 31b5245d-c7bf-11e1-bf7d-60d819ef9b8e
Any help would be appreciated.

My System SpecsSystem Spec
.

06 Jul 2012   #2

Microsoft Community Contributor Award Recipient

Windows 7 Ult. x64 Windows 8.1 x64
 
 

Bleh! As far as I know Greg's the power-user of this software, so maybe he has some insight. I'm guessing you have tried reinstalling it and it gives the same error?

Regards,
Golden
My System SpecsSystem Spec
06 Jul 2012   #3

Windows 7 Home Premium 64 Bit
 
 

Tried re-installing it. Still get the same error. I may try restarting my system, uninstall, and re-install it again (with restarts in between) to see if that helps.
My System SpecsSystem Spec
.


06 Jul 2012   #4
Microsoft MVP

 

Oops. I have no idea what's causing it as I've never had a problem with it before myself, or heard of one until now. I'd file a bug report with Puran. Puran Defrag Support.

I switched from Auslogics about two years ago after Cluberti traced a boot hang to system files needing defrag and it provided the only boot-time defrag (with full Disk Check) that cut startup time in half.

I've put it on perhaps a hundred or more installs since then and recommended it here for installs since that time and have heard no complaints until now.
My System SpecsSystem Spec
06 Jul 2012   #5

Windows 7 Home Premium 64 Bit
 
 

No worries Greg. I'm sure I am just doing things that most users do not. I run my system as a standard user, so I installed it with administrative privileges. Probably should have logged into my administrative account and installed it that way. I have since done so and am seeing if the problems persist.

I currently am not sure whether it was installing it with my standard user account through the administrative account or if it was due to running it with my standard account through the administrative account. I'll do some testing and let you know what the case is.
My System SpecsSystem Spec
06 Jul 2012   #6

Microsoft Community Contributor Award Recipient

Windows 7 Pro 64 SP1
 
 

I use it all the time, I've never gotten that. I do run it from my admin account though.
My System SpecsSystem Spec
06 Jul 2012   #7

Windows 7 Home Premium 64 Bit
 
 

Nope, had the same problem again installed from my administrative account and running on the administrative account... Ran SFC /SCANNOW, and no problems. I wonder if it does not do well when running behind another window or when my blue screen tool runs. I'll have to check each of those scenarios next.

Edit:
Appears a reboot and defrag during boot may have resolved the issue. I'll post back if it reoccurs.
My System SpecsSystem Spec
07 Jul 2012   #8
Microsoft MVP

 

I received this email in reply to mine to Puran referencing this thread:

Quote:
Hello Gregrocker,

Thank you for your Email and supporting Puran Software. I highly appreciate it.

It looks like the problem is solved now.

Usually, such errors are fixed by using "Restart - Defrag - Shutdown + Full Disk Check" option. It seems like end users facing such problems have errors on their hard disk/file system which when fixed by disk check solves the problem.

Thank you

Regards,
Vishal Gupta
Puran Software


Did you run the full Disk Check which might have repaired errors, Mike?
My System SpecsSystem Spec
07 Jul 2012   #9

Windows 7 Home Premium 64 Bit
 
 

Seems just the reboot and boot time defrag resolved the problem without needing to do a disk check. I did a disk check a few days ago, and I have not done anything that would be likely to cause corruption since then. My hypothesis is that the GUI was having issues due to me forgetting to reboot after installing the software, although the boot time defrag may also have set things straight.

If it was the boot time defrag, I would further hypothesize that there was an issue moving a file that could not be moved while Windows was running. Once it was moved during boot time, it no longer needs to be moved during subsequent defrags and so it works fine.

The second scenario seems less likely since the logs show a problem with the GUI and not the defrag program itself. I am fairly sure the first hypothesis has a higher probability of being true. Maybe I should write Puran and let them know that it might be a good idea to recommend a reboot when Puran finishes installing.
My System SpecsSystem Spec
07 Jul 2012   #10
Microsoft MVP

 

I was hoping they would interact in this thread, but please keep us posted what they say if you contact them.
My System SpecsSystem Spec
Reply

 Puran Defrag Error




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:47 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33