Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: .msi 'installation directory must be on a local hard drive'


28 Nov 2012   #1

Windows 8.1
 
 
.msi 'installation directory must be on a local hard drive'

Hi, sorry if this is in the wrong thread, but every time i try to run a particular .msi i get this.

'installation directory must be on a local hard drive'

Its not the msi as ive tested it on another computer.

The msi is a plugin tool called t-splines by autodesk. Ive also tried older versions with the same error

Things i've tried so far
sys restore
safe mode
right click - take ownership
I uninstalled 7zip which i already had, then reinstalled with the .msi from the website to test if it was all msi, however it actually worked


I was looking around for other .msi install software just to test it but can't find any

Any help guys is really appreciated, or if you could point me in the direction of some .msi files which i can test on my rig

edit, just tried a few other msi's i had on my computer and i get the error 1723

Thanks!

My System SpecsSystem Spec
.

29 Nov 2012   #2

Windows 7 32 bit
 
 

I would try opening the Services Applet in Control Panel. Scroll down to RPC and see if the service is started. The error you posted is RPC Server Busy. But it might mean the service is not running.

Chances are you'll get more focused help on this Forum
My System SpecsSystem Spec
29 Nov 2012   #3

Windows 8.1
 
 

Hi thanks for reply .

I checked services.msc and the RPC endpoint mapper is running (I assume that is what you are talking about as no other 'RPC' entries are there.

I've realised now that its more than likely a general problem with my win 7 as other msi installation files (non-related to t-splines) will chuck the 1723 error at me.

Maybe its worth posting this in the bsod and debugging section, my best guess is that something is a miss with my registry.

Thanks again for your help though!
My System SpecsSystem Spec
.


29 Nov 2012   #4

Windows 7 32 bit
 
 

One suggestion I found that shouldn't hurt anything is to try Unregistering the exe then Registering again.
Open a command prompt and type
regsvr32

and hit Enter

It should pop up a usage dialog box for Regsvr32.exe

If it does, you know it's in the path. So just click OK to close the dialog.

Find "msiexec.exe" on your system.
Open an administrative command prompt in that folder and type
regsvr32 /u msiexec.exe

It should say Unregister of msiexec.exe succeeded.

If so then type the same command but without the "/u" switch
regsvr32 msiexec.exe

It should say succeeded again.
Now try the install again.

Regsvr32 adds and removes registry entries for COM libraries and programs.
RPC error is a COM error. It can mean that it cannot find the program because when it looks in the Registry the correct info is not there. In any case it's already broken. This won't hurt it.

Here's a post roughly related to your problem:
http://answers.microsoft.com/en-us/w...1d77702?auth=1
My System SpecsSystem Spec
30 Nov 2012   #5

Windows 8.1
 
 

thanks for reply

When i type regsvr32 i get 'to register a module you must provide a binary name'

when i use admin cmd and type in 'regsvr32 /u msiexec.exe' i get

'The module "msiexec.exe was loaded but the entry-point DllUnregisterserver was not found.

Make sure that "msiexe.exe" is a valid DLL or OCX file and then try again.

Am I meant to get this?
My System SpecsSystem Spec
01 Dec 2012   #6

Windows 7 32 bit
 
 

It means that exe doesn't expect to be registered as a COM stub. I'd say try on Microsoft Site. Somebody there ought to know how to fix their own installer. Search knowledge base for installer issues. Search using the error string. There must be others besides you. I just can't seem to find anything more specific.

Do you have the install discs? There's always the fall back
sfc /scannow

before doing that I'd search on Installer Cleanup Tool. See if that does any good.
My System SpecsSystem Spec
04 Dec 2012   #7

Windows 8.1
 
 

Hi thanks for replying again and your help, think I'm gonna have to get to the root of this problem next week after all my hand ins for uni (architecture student, toooo much work lol)

I tried a fix tool from ms site but with no luck, however I've made some progression i think. While trying to install quicktime for my course.....it failed saying there's a problem with windows installer...missing DLL.

I did a sfc /scannow and it fixed some errors, however upon reboot all that was changed was my win 7 theme back to normal (I had third party theme installed before). I tried installing quicktime again and got the same error.

However, quicktime allows you to right click and run as admin, and this bypassed the DLL error some how and i was able to install. Does this mean the problem i have is something to do with user account control maybe, and that DLL isn't actually missing or corrupt? I'm the only user on my computer.

I'll keep scouring the ms site and forums in the mean time.

Thanks
My System SpecsSystem Spec
04 Dec 2012   #8

Windows 7 32 bit
 
 

I'm not sure. The only problem I had with installer was on Vista where you run one of a group of programs and get an offer to install the app instead of running it. Best thing to do is periodically search on the exact error phrase. I found a few hits but nothing that seemed an exact match. Over time you might get a direct hit.

I've never owned a laptop. So there are things that come into play beyond my experience. You might try an Acer specific support forum. If there are many Acer owners with the same issue there may be a fix or work-around posted on their support forum. Most manufacturer's have web support as it's cheaper than phone banks(although they may have those also but they go for the cheap fix via download if they can get it.)
My System SpecsSystem Spec
04 Dec 2012   #9

Windows 8.1
 
 

Ah damn, sorry i forgot to update my specs, i have laptop and desktop and used those specs last time on here for problems with laptop. I've updated them now to my desktop, if it makes any difference.

Yea i think i'll keep trying too narrow it down when i get some free time over xmas lol. Although i'm thinking of just switching to windows 8 as have the upgrade offer from when i got my laptop, so i could use the upgrade disk to clean install on my desktop presuming the upgrade trick still works.
My System SpecsSystem Spec
04 Dec 2012   #10

Windows 7 32 bit
 
 

I wouldn't expect W8 to be glitch free at this point. You might take a look on the sister Windows Eight Forum. A lot of people, including myself, signed up for that forum on the heels of W8 announcement. But many don't participate since it's a change of paradigm that looks unappetizing. It seems like an OS for tablets and phones. Not for desktop.

But it's one alternative.. providing it has the drivers for your system. I don't know enough about W8 to know if it's only different on the outside. Or if the OS innards have been drastically changed.
My System SpecsSystem Spec
Reply

 .msi 'installation directory must be on a local hard drive'




Thread Tools



Similar help and support threads for2: .msi 'installation directory must be on a local hard drive'
Thread Forum
WD USB hard drive showing as local disk Hardware & Devices
Samsung s2 external hard drive not loading showing local disk F drive Hardware & Devices
Solved Can't delete directory on external hard drive General Discussion
Can't delete directory on external hard drive General Discussion
Os hard drive and local disk hard drive how can i make them into one? Hardware & Devices
directory changes for portable hard drive General Discussion
Local USB hard drive apearing as networked iDisk Hardware & Devices

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:41 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33