Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Net framework 4.5 will not install


24 Jun 2013   #1

windows 7 home 64bit
 
 
Net framework 4.5 will not install

window7 service pack1 all updates install
HP P6633w
AMD atholon II x2 225 processor 3.10
64 bit system

With all that said I am unable to install the net framework 4.5 no real error message or no code, it just tell me something blocking the install but no info on what.
Net framework 4.0 is installed all the latest windows updates are installed

The issue came up while talking to canon support because my EOS utility is not working. I did use CCleaner and did a full clean on my computer on Sunday 6/23/13 (malwarebytes and ms security essentials . I also had installed-uninstalled Google drive and most of what was cleaned in the reg had to do with that I always create a backup before I run the cleaner. restoring did not fix the issue with the canon software. Canon is at a loss and I am at a loss on what how to fix the canon software issue they suggested making sure my net framework and windows are up to date, they are. uninstall and reinstall the eos software.
So the main question is why won't net framework 4.5 install and do I need it? I so wish I had nerver installed that google drive as I think getting it all removed is part of the issue?? Canon support is at a loss and I am at a loss on what to do.

My System SpecsSystem Spec
.

24 Jun 2013   #2

windows 7 home 64bit
 
 

talked to Canon again and they said the nasty word - reinstall - I hope there a better way - any help or ideas are welcome and appreciated.
My System SpecsSystem Spec
24 Jun 2013   #3

Windows 7 Home Premium 64bit sp1
 
 

Quote   Quote: Originally Posted by walkingbird View Post
window7 service pack1 all updates install
HP P6633w
AMD atholon II x2 225 processor 3.10
64 bit system

With all that said I am unable to install the net framework 4.5 no real error message or no code, it just tell me something blocking the install but no info on what.
Net framework 4.0 is installed all the latest windows updates are installed

The issue came up while talking to canon support because my EOS utility is not working. I did use CCleaner and did a full clean on my computer on Sunday 6/23/13 (malwarebytes and ms security essentials . I also had installed-uninstalled Google drive and most of what was cleaned in the reg had to do with that I always create a backup before I run the cleaner. restoring did not fix the issue with the canon software. Canon is at a loss and I am at a loss on what how to fix the canon software issue they suggested making sure my net framework and windows are up to date, they are. uninstall and reinstall the eos software.
So the main question is why won't net framework 4.5 install and do I need it? I so wish I had nerver installed that google drive as I think getting it all removed is part of the issue?? Canon support is at a loss and I am at a loss on what to do.
You might need to update your current version before you can upgrade to 4.5 you are probably using the old 2.5
you should be able to scan it to see if you have it through the M$ site
My System SpecsSystem Spec
.


24 Jun 2013   #4

windows 7 home 64bit
 
 

Just checked and 4 is running
My System SpecsSystem Spec
24 Jun 2013   #5

Windows 7 Home Premium 64bit sp1
 
 

So the Cannon you speak of is a printer right ?

or what is the software called ?
My System SpecsSystem Spec
25 Jun 2013   #6

windows 7 home 64bit
 
 

no it is my canon eos rebel t3. I do have a canon printer that is connected via the wired netwook to my router and it is working fine. I also have a canon powershot sx 100 and it works fine. I also tried the t3 on my laptop and it is fine. I used the usb cable from the laptop and it did not fix the issue on the desktop. I have uninstall/reinstalled all software for the cameras and no luck.
I had to install a new hard drive in the desktop - basically rebuilding it from the ground up and the camera had no issue for a good week - on my system cleanup/backup day I had some software that I did not install (may have been install with the google drive install). I removed those while searching google for each and making sure they were not tied to something I did want. (about 4) - then I ran ccleaner for the reg and it remove tons of stuff left over from the google drive install. I ran the reg clean 3 time. did my full malwarebite clean, MSE scan and did a backup. nothing found on any scan other then the reg scan. the camera worked on Friday - did the cleanup/backup Sat. and camera did not work Sunday.
I did a backups when I did the reg clean and restoring those backups did nothing for restoring the camera. I have reran the reg clean to get all the google drive stuff off the system.Something I did Sat took out something for the camera that a uninstall/reinstall is not fixing. I have done that process so many times, with the disk - with the new file off the net. with restarts and without restarts. I have also move the usb from on port to another, I have usb 2 and 3 ports. tried the camera in both types.
the canon software uses the netframework and I know very little to nothing about that program. windows is all updated. when I did the cleanup I did remove all the restore points (wish I had not done that). there are two netframe files for the 4.5 NDP45-kb2805221-x64 and NDP45-KB2750147-x64 both file fail to install. My system is a 64 not a 32 or 86. the 4 installed fine.
If it comes down to reinstalling windows I am going to live with the issue as I can get my images off the sd card. This is a big puzzle. I do have a person that support the schools computers for the county coming by maybe Sunday to check it out. sorry for the long wait in getting back to you - my dad is here and that is taking up most of my time. also thank for your time and thought this is a pain to figure out.
My System SpecsSystem Spec
25 Jun 2013   #7

Windows 7 Home Premium 64bit sp1
 
 

Sounds like your install might need repairing have you tried to do a system restore to a earlier time to see if that will fix the issue ?

Btw don't worry about it He's your Dad he is number one remember that
My System SpecsSystem Spec
25 Jun 2013   #8

windows 7 home 64bit
 
 

the system restore has been great until I did the cleanup/backup. the only issue that I am having is the camera. it is faster and a better running system. because it was caused by a drive issue I backup/cleanup every sat. the first one went fine no issues. dad has two programs he uses and wants me to run those, not sure I want to do that. like I said the computer fix it man is coming over when he has time and he understand networks and such. he does things that are way above me.
My System SpecsSystem Spec
25 Jun 2013   #9

windows 7 home 64bit
 
 

all my system restore points have been deleted. I have been told that there is a way to let window look at its install and repair it without uninstalling, not sure I want to do that as it takes booting with the system disk and hitting f3. Did that and did not find what I was looking for so I aborted and restart with what is on my hard drive.
My System SpecsSystem Spec
Reply

 Net framework 4.5 will not install




Thread Tools



Similar help and support threads for2: Net framework 4.5 will not install
Thread Forum
Install Net framework into Win 7 64 bit Software
Net Framework uninstall/install Software
NET Framework 4.0 crashes on install Software
Solved I can't install net framework 3.5 Software
How do i fix so i can install Net framework 3.5 SP1? General Discussion
Error 643-->.net Framework 4 install Windows Updates & Activation
cant install .net framework 1.1 Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:06 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33