Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: "Something" blocks processes while writing to disk


26 Jun 2013   #1

Windows 7 Home Premium 32bit
 
 
"Something" blocks processes while writing to disk

I think of me as a computer expert and I believe this is a very though one (I'm planning to scratch Windows, in facts), but I have a last hope asking here!

The problem is: there's "something" that blocks processes while they're writing to disk.
The effects showed are, for example:
  • the kaspersky internet security breaks during updates and suspend itself saying the virus base is broken
  • download in chrome stops halfway
  • Adobe Lightroom (which uses a custom sqlite db) breaks during operations, saying the catalog is corrupt and attempts recovery at restart (operation that can break, too)
I tried disabling windows defender that in other occasions showed to lock files, but with no success.
I noticed that in Safe mode operations seems good.
I used ProcExplored to see if there's any process using CPU during this breakups, but didn't find anything; I also looked in the open handles to find other processes using the same file as the breaking ones without luck.


I don't thing it to be a virus as I have AV protection and tend not to expose PC to malware.


I also notice that this behavior mainly happens a few minutes after boot and then seems to disappear after other several minutes.


Does anybody have clues on what's happening or on how to find it out?


Thank you very much!!


My System SpecsSystem Spec
.

26 Jun 2013   #2

Desk1 8 Pro / Desk2 7 Home Prem / Laptop 8.1 Pro all 64bit
 
 

Hello pdario as a long time KISS user mate I would uninstall and reinstall something has probably corrupted the system there.

Just save the trial to downloads use the unistalled from the Start Orb and reinstall from the Downloads and activate with your code but I am guessing I telling my grandmother to suck eggs but that is where I would start.

I know it is a pain but there have been a few bugs in KISS juts lately.

A sfc and chkdsk would not go amiss but again I guesing you ahave already tried these if you are ok at this stuff.
Troubleshooting Steps for Windows 7 (point 15 1st up) and Disk Check
My System SpecsSystem Spec
26 Jun 2013   #3

Windows 7 Home Premium 32bit
 
 

Noo!! I didn't even think of an hardware failure!! No panic, no panic!!!

Ok, I'll go for the sfc and chkdsk checks and still hope it's a sw problem.

About KIS: I also tried suspending and stopping it; I will also try a reinstall, if you think it could be the cause (I thought that it is something below it, as it is itself broken).
My System SpecsSystem Spec
.


26 Jun 2013   #4

Desk1 8 Pro / Desk2 7 Home Prem / Laptop 8.1 Pro all 64bit
 
 


Pdario I personally don't like Chrome but whatever floats the boat. That isa strange symptom for KISS though and no mate a reinstall sounds like it mightbe in order.

Now you know you have the two main options one in the Start list which Ipersonally don't like although it does save your config of the program there isthe uninstall tool from Kaspersky

http://support.kaspersky.com/common/service.aspx?el=1464

I don't know how you config the KISS I use my own which I got from anothersite but it has been removed but if you want a hand through - ask.

But first run these they will find stuff that any AV can miss

http://www.superantispyware.com/

http://www.malwarebytes.org/products/malwarebytes_free/

http://www.bleepingcomputer.com/download/adwcleaner/
download the ADW from bleeping computer



If you are going to reinstall 7 then it looks like the chipset supports 64bit and there are options for you. A factory default (32bit) this USB Windows 7 Installation Key Drive - Create use the ISO and the activation code from your machine sticker or just buy and install a 7 OEM that would get rid of all the bloatware.

The sfc and chkdsk are not really hardware related mate they just check the OS filing sytem and try to correct problems.

Another check you could do is a temp check with Speccy Speccy - Download download from piriform and see what the temps are they can cause problems.

and a memtest if needed though this takes some time to do and needs at least 8 passes.
Memtest86+ - Advanced Memory Diagnostic Tool download and make a bootable stick or disk and set the BIOS to boot from the optical drive and let run.

Then if all this fails start in this Troubleshooting Steps for Windows 7 you will have done some already.
My System SpecsSystem Spec
26 Jun 2013   #5

Windows 7 Home Premium 32bit
 
 

Thanks for suggestion. When I mentioned HW I was thinking of bad sectors, that sounds plausible...

I tried sfc but it said it cannot run after getting to 28%.
I tried windowed check disk selecting bad sectors check, it complained it couldn't run and set a boot scan.
I rebooted but nothing happened, so I set the disk dirty with fsutil and rebooted; it is now scanning for error, but it says is going through 5 steps which will exclude sectors scan.

One thing I noted before rebooting is the Crypto Service taking almost 50% CPU (basically a full core) and a LOT of ESENT errors in the Windows logs (saying it cannot read or write some files), but I don't know if this is a cause or an effect.

If I'm able to find out the disk is good, I think I'll go for 7 reinstall, so to retake my last GB of RAM that now is hidden by the graphic memory.
My System SpecsSystem Spec
26 Jun 2013   #6

Desk1 8 Pro / Desk2 7 Home Prem / Laptop 8.1 Pro all 64bit
 
 

Maybe try those in safe mode pdario - the sfc again and the malware runs cos it sounds like something is gobbling up the machine with that core use.
My System SpecsSystem Spec
27 Jun 2013   #7

Windows 7 Home Premium 32bit
 
 

I left chkdsk run this night; this morning I found Windows rebooted: I looked in the event log, but it seems no errors were found (bad sectors check skipped); anyway something happened, because I lost my Google cookies in Chrome (I found my self logged out of Gmail), I lost my ssh password in MobaXTerm and other oddities.
I tried sfc again and it stopped, I'll try in safe mode.

Anyway, I'm preparing for Windows reinstall, but I first need to be sure the HD is ok: can you suggest a way to check the disk surface?
My System SpecsSystem Spec
27 Jun 2013   #8

Desk1 8 Pro / Desk2 7 Home Prem / Laptop 8.1 Pro all 64bit
 
 

Sorry for late reply mate one yest particularly of the actual surface you cab do with the Partition Wizard http://www.partitionwizard.com/free-partition-manager.html

Just install run and click on surface test see my pic it takes some time too.

This is a very useful tool to use for other jobs.

For testing the drive - I don't know what brand they are so I would suggest the Seatools one

SeaTools | Seagate go to the Downloads finder


Attached Thumbnails
"Something" blocks processes while writing to disk-sw.png  
My System SpecsSystem Spec
27 Jun 2013   #9

Windows 7 Home Premium 32bit
 
 

Yes, thank you! I'll look at them and try these tests
My System SpecsSystem Spec
27 Jun 2013   #10

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x86 Service Pack 1 - Linux Mint Mate 14 x64
 
 

Welcome to the forums pdario,

If it's unable to write files to the disk, then I would think of it either being some kind of malware, or possible disk failure/corruption.
My System SpecsSystem Spec
Reply

 "Something" blocks processes while writing to disk




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:12 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33