Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: removing batch file from registry


13 Sep 2013   #1

Windows 7 ultimate 64bit
 
 
removing batch file from registry

recently I ran Mamu's add icons to system batch file for mame icons. I wasn't satified with the results so I was going to do a system restore. Then I learned system restore was turned off "which I turn off when I defrag then turn back on when completed". Now I can't figuere out how to remove it. I'm not very good with cmd. or batch files so any help would be greatly appreciated




Attached Files
File Type: zip batch file.zip (971 Bytes, 6 views)
My System SpecsSystem Spec
.

13 Sep 2013   #2

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x86 Service Pack 1 - Linux Mint Mate 14 x64
 
 

You just delete the batch file if you want to remove a batch file, there's no need whatsoever to go inside the registry.
My System SpecsSystem Spec
13 Sep 2013   #3

Windows 7 ultimate 64bit
 
 

This batch file changed the registry. I deleted the original one after executing it but the icons are still the same.
My System SpecsSystem Spec
.


13 Sep 2013   #4

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x86 Service Pack 1 - Linux Mint Mate 14 x64
 
 

My System SpecsSystem Spec
13 Sep 2013   #5

Windows 7 Professional x64 SP1 ; Windows Server 2012 R2 Standard
 
 

In addition a system restore will restore the registry to a previous state so it may be worth considering if all else fails

System Restore

Josh
My System SpecsSystem Spec
13 Sep 2013   #6

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64
 
 

Quote:
Then I learned system restore was turned off
I think he means he hasn't got any shadow copies.
My System SpecsSystem Spec
13 Sep 2013   #7

Windows 7 Professional x64 SP1 ; Windows Server 2012 R2 Standard
 
 

Woops ...
My System SpecsSystem Spec
14 Sep 2013   #8

Windows 7 ultimate 64bit
 
 

I've tried everything I can think of cleared and rebuilt icon cache, used Ragnarok Windows 7 orig iconpack, and ran sfc /scannow. Nothing has worked. Filestypeman shows .ico Type Name as Batfile and Description as Windows Batch File. I haven't found any system effects just within MAME itself so I guess I'll just deal with it as it is and chaulk it up as a learning experience. Thank everyone for trying to help and if I find a fix I'll make sure I post so someone else may benefit. Thanks again
My System SpecsSystem Spec
14 Sep 2013   #9

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x86 Service Pack 1 - Linux Mint Mate 14 x64
 
 

What file type are you referring to?
My System SpecsSystem Spec
15 Sep 2013   #10

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1
 
 

Code:
@echo off
if "%1&"=="&" goto end2
if "%1"=="n" goto naomi
if "%1"=="ng" goto naomig
if "%1"=="n2" goto naomi2
if "%1"=="t" goto triforce
if "%1"=="nc" goto namcops2
if "%1"=="mech" goto mechs
if "%1"=="m2" goto model2
if "%1"=="m3" goto model3
if "%1"=="rem" goto M32UIrem
if "%1"=="m4" goto m4
if "%2&"=="&" goto nonwork
goto copy

:M32UIrem
echo ------------- REMOVE MAME32 UI icons -------------
echo This will delete all MAME32UI flashy squared icons
echo and replace a few ones with MAMu_'s icons...
echo (roms.ico, clone.ico and warning.ico)
echo --------------------------------------------------
echo Any key to continue, Ctrl-C to cancel
echo --------------------------------------------------
pause
del clone.ico
copy clone2.ico clone.ico
del cpu.ico
del cust1.ico
del cust2.ico
del custom.ico
del foldavail.ico
del folder.ico
del foldmanu.ico
del foldopen.ico
del foldsrc.ico
del foldunav.ico
del foldyear.ico
del golden.ico
del harddisk.ico
del horz.ico
del lightgun.ico
del manufact.ico
del neo-geo.ico
del nonwork.ico
del noroms.ico
del roms.ico
copy roms2.ico roms.ico
del sound.ico
del snd.ico
del source.ico
del stereo.ico
del unknown.ico
copy unknown2.ico unknown.ico
del vert.ico
del warning.ico
copy warning2.ico warning.ico
del working.ico
del year.ico
echo --------------------------------------------------
echo    default non working, missing parent icon and
echo missing clone icon have been replaced with MAMu_'s
echo --------------------------------------------------
pause
goto end

:mechs
copy zzz_mechanical.ico %2.ico
echo zzz_mechanical.ico copied to %2.ico
goto end

:nonwork
copy zzz_mame.ico %1.ico
echo zzz_mame.ico copied to %1.ico
goto end

:m4
copy m4tst.ico %1.ico
echo m4tst.ico copied to %1.ico
goto end

:naomi
if "%2&"=="&" goto end
copy naomi.ico %2.ico
echo naomi.ico copied to %2.ico
goto end

:naomig
if "%2&"=="&" goto end
copy naomigd.ico %2.ico
echo naomigd.ico copied to %2.ico
goto end

:naomi2
if "%2&"=="&" goto end
copy naomi2.ico %2.ico
echo naomi2.ico copied to %2.ico
goto end

:namcops2
if "%2&"=="&" goto end
copy namcops2.ico %2.ico
echo namcops2.ico copied to %2.ico
goto end

:triforce
if "%2&"=="&" goto end
copy triforce.ico %2.ico
echo triforce.ico copied to %2.ico
goto end

:model2
if "%2&"=="&" goto end
copy model2.ico %2.ico
echo model2.ico copied to %2.ico
goto end

:model3
if "%2&"=="&" goto end
copy model3.ico %2.ico
echo model3.ico copied to %2.ico
goto end

:copy
copy %1.ico %2.ico
goto end

:end2
echo ---------------------------------------
echo     MAMu_'s icons copy tool v 0.02
echo ---------------------------------------
@echo off
echo  ! X     Copy non working icon to X.ico
echo  ! n X   Copy naomi       icon to X.ico
echo  ! ng X  Copy naomi gdrom icon to X.ico
echo  ! n2 X  Copy naomi 2     icon to X.ico
echo  ! nc X  Copy namco PS2   icon to X.ico
echo  ! m2 X  Copy model2.ico       to X.ico
echo  ! m3 X  Copy model3.ico       to X.ico
echo  ! m4 X  Copy m4tst.ico        to X.ico
echo  ! t X   Copy triforce    icon to X.ico
echo  ! X Y   Copy X.ico to Y.ico
echo ---------------------------------------
echo  ! rem   Remove all M32UI default icons
echo ---------------------------------------
@echo off
pause
:end
It looks like it deletes the originals when it replaces them. A reinstall of Mame may well fix this.

A Guy
My System SpecsSystem Spec
Reply

 removing batch file from registry




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 09:55 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33