Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: all DLL's are being loaded for every application on startup


25 Feb 2014   #1

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 
all DLL's are being loaded for every application on startup

this problem started happening after I had run WMI.bat( that was in tutorial to fix system restore not working)
System restore now works, but now every time I restart system the following happens,
Event 11, Wininit
Custom Dynamic Link Libraries are being loaded for every application
see attachment

Thank you for any help on this



Attached Files
File Type: txt all dll's being loaded.txt (1.2 KB, 2 views)
My System SpecsSystem Spec
.

27 Feb 2014   #2

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

The following solved my problem.

In the registry, please change the value of HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows\LoadAppInit_DLLs from 1 to 0, reboot, and check if the event in question is still logged. (Would also want to check if HKLM\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Windows\LoadAppInit_DLLs was set to 1 and if so, change it to 0.) Note the value to check is LoadAppInit_DLLs of type REG_DWORD, rather than LoadAppInit_DLLs of type REG_SZ.
Reply
Reply with quote Report abuseReport inappropriate content
waltbros
Found this helpful
Me Too
0
waltbros replied on May 24, 2010See post history
Close
Reply In reply to No.Compromise's post on May 24, 2010
In the registry, please change the value of HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows\LoadAppInit_DLLs from 1 to 0, reboot, and check if the event in question is still logged. (Would also want to check if HKLM\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Windows\LoadAppInit_DLLs was set to 1 and if so, change it to 0.) Note the value to check is LoadAppInit_DLLs of type REG_DWORD, rather than LoadAppInit_DLLs of type REG_SZ.
Changed HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Windows\LoadAppInit_DLLs value from 1 to 0 and did not get the event. Not too sure what else that affects, so I changed it back to a 1. If you tell me it won't affect anything else, I guess I'll change it back to a 0. Since it is just a warning event I'm not sure it is worth the possibility of something else going wrong.
HKLM\SOFTWARE\Wow6432Node\Microsoft\Windows NT\CurrentVersion\Windows\ did not have a LoadAppInt_DLLs word in it.
My System SpecsSystem Spec
Reply

 all DLL's are being loaded for every application on startup




Thread Tools



Similar help and support threads for2: all DLL's are being loaded for every application on startup
Thread Forum
Solved Avoiding '<application name> is not a valid Win32 application' error. General Discussion
I disabled application info and application update in services.msc BSOD Help and Support
Programs Only Open In Safemode, Less Processes Loaded On Startup General Discussion
Troubleshoot Application Conflicts by Performing a Clean Startup Tutorials
application windows size on startup Customization

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:53 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33