Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Slow DL speeds in uTorrent with new 100mbit connection

24 Nov 2014   #1
Tonsgaard

Windows 7 Ultimate x84
 
 
Slow DL speeds in uTorrent with new 100mbit connection

I recently changed my ISP from a 20/2 to a 100/20 mbit connection.

My problem here is that with my old 20/2 connection I had a stable DL speed
at about 2mb/s with well seeded torrents, but now with my new connection
which is supposed to be 5x faster, my DL speeds are unstably jumping between
300kb/s to 3mb/s, which does not seem right at all. I was expecting to hit about
10mb/s on well seeded torrents.

TL;DR: my DL speeds are slow and unstable with a beast connection.

Speedtest results are perfectly fine:


Any help regarding this matter would be greatly appreciated.

-Tonsgaard


My System SpecsSystem Spec
.
24 Nov 2014   #2
matts6887

Windows 7 ultimate 64-bit
 
 

I would try the simple idea for starters of power cycling your network equipment. Unplug the power cords to both your modem and router(if there is one) and wait about a minute or so. Then plug the modem back in first; and let that boot; then plug the router back in next; and let that boot. What this will do is hopefully reset the the connection to both devices by clearing the memory cache from both devices in turn basically refreshing the connections. Give that a shot and see what happens. Post back if no results.
My System SpecsSystem Spec
25 Nov 2014   #3
OvenMaster

Win7 Pro 32bit; Zorin OS 9 Core (in VM)
 
 

I wish I were able to read Danish. I think you need to search whether Tele Danmark throttles down Torrent users.
My System SpecsSystem Spec
.

Reply

 Slow DL speeds in uTorrent with new 100mbit connection




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Slow download speeds, Fast upload speeds. Other devices are fine.
My computer has extremely slow download speeds, upload speeds are fine. Ping is always at ~10-20ms. (to Google) The problem has nothing to do with, my ISP, my router, my type of connection. I know this for a fact. http://www.speedtest.net/result/3745496488.png I've tried multiple network...
Network & Sharing
Intel centrino wireless N-2230 having slow connection speeds
i have an HP pavilion m6-1045dx laptop with the specs: intel i5-3210M processor 8gb ram windows 7 64bit OS obviously, i have an intel centrino wirless N-2230 as the wireless NIC. a few days ago my hard drive failed and needed repair, i managed to replace the hard drive but came a long this...
Network & Sharing
utorrent on WINDOWS 7-very SLOW download SPEEDS
Hello all , I have a big problem with speed downloading between 15kb/s below after a weeks all things was normal , I was downloading any thing in by 150 to 250 but the problem is now limited downloading 15kbt/s to under. any help will be appreciated sorry for my bad language ... :confused:
Software
Slow speeds when downloading via uTorrent?
Hi all, I have a very strange problem. I am on a 50Mbps Down and 20Mbps Up, line... When downloading 2 things on uTorrent at around 1.5MB/s all my bandwidth just goes? This has not happened to me before. http://grab.by/iFGK Normal speedtest: http://grab.by/iFHO
Network & Sharing
Fast connection to router but slow download speeds?
Don't understand what's going on here. Connection in Windows is fine, speed wise: http://www.sevenforums.com/attachment.php?attachmentid=219657&stc=1&d=1341423890 But on Speedtest I'm getting this: http://www.speedtest.net/result/2045335765.png Usually get around 10mbps like the...
Network & Sharing
Problem With Wired Internet Connection Extremely Slow Speeds
It all started out a week ago with random times where my internet speed would drop drastically but after about 5 minutes it would go back to normal. Then about 5 days ago I couldn't connect to cable with my cable modem the activity light would just pop green over and over again. I used cycling over...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:46.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App