Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: "unhandled exception occurred in your application"

25 Dec 2014   #1
iknowjohnny

windows 7 professional
 
 
"unhandled exception occurred in your application"

I have a canon camera which has wifi. It has a configuration utility that helps you setup the connection to a wifi access point which i do have. However, whgen i try and run this app called "wifi connection setup" I get the error i mentioned. It also says "object reference not set to an instance of an object". I have reinstalled it, tried downloading it rather then using the disc version, tried repairing net framework, (which i suspected from a post in a google search) virus scans, etc. Sill does this. Any ideas on how to determine what is happening?


My System SpecsSystem Spec
.
28 Dec 2014   #2
A Guy

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1
 
 

Try booting to Safe Mode with Networking (in case you want to get on internet while testing. Safe Mode will also work). See if the utility works there

Safe Mode

If it does work in Safe Mode, try a Clean Start to see if something is interfering

Troubleshoot Application Conflicts by Performing a Clean Startup

You can also see if it works in another User Account

User Account - Create

Or the built in hidden Admin account (disable this account again after testing)

Built-in Administrator Account - Enable or Disable

If this is a one time setup thing, then if any of these methods work, you will be set up, even if you don't definitively determine the cause

Those errors are indeed often associated with .NET, but it is not 100% so.

A Guy
My System SpecsSystem Spec
28 Dec 2014   #3
iknowjohnny

windows 7 professional
 
 

Thanks. I tried safe mode and still get that error. I take it this means .NET framework is NOT to blame? And what exactly does it tell me of importance? I realize a lot of things are not loaded in safe mode so those are all no longer suspect, tho i don't know what is or isn't loaded or what to look for now.
My System SpecsSystem Spec
.

28 Dec 2014   #4
A Guy

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1
 
 

I do not believe .NET loads in safe mode? Since the issue is the same in Safe Mode, it's almost sure no 3rd party app is the issue. But Windows still loads the minimum services and drivers. Did you try a different user, or the admin account? It would tell you if it was something about your user. A Guy
My System SpecsSystem Spec
28 Dec 2014   #5
iknowjohnny

windows 7 professional
 
 

I tried but nothing from my account was there including the app i'm having issues with. Plus i have a app that scrambles text so my passwords and user names cannot be hack, and when i turned it off it wouldn't go off so i couldn't even type to get to the app in one of my email accounts. Everything i tried to do got stopped in it's tracks by some issue due to being logged in as that admin account. So i just gave up on that.
My System SpecsSystem Spec
28 Dec 2014   #6
A Guy

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1
 
 

Ahhh, a shame as that would tell us if it was just that one user. Can you post a screenshot of the exact error, and it's detail tab?

Screenshots and Files - Upload and Post in Seven Forums

Also see the instructions for checking the event viewer for a more detailed error message marked as Answer here:

Net framework error unhandled exception has occurred in your - Microsoft Community

You might find if this is a known issue with this application on the Canon Camera forum as well

Camera - Canon Community

A Guy
My System SpecsSystem Spec
28 Dec 2014   #7
iknowjohnny

windows 7 professional
 
 

I saw that post and tried the event viewer a while back with to no avail, tho i can't remember what exactly happned. I've tried so many things i don't recall a lot of what happened but i did try that. Heres the text from the error...

Unhandled exception has occurred in your application. If you click continue, the application will ignore this error and attempt to continue. If you click quit the application will close immediately.

See the end of this message for details on invoking
just-in-time (JIT) debugging instead of this dialog box.

************** Exception Text **************
System.NullReferenceException: Object reference not set to an instance of an object.
at WirelessCameraConnectionSetting.MainForm.v_btnSetting_Click(Object sender, EventArgs e)
at System.Windows.Forms.Control.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnClick(EventArgs e)
at System.Windows.Forms.Button.OnMouseUp(MouseEventArgs mevent)
at System.Windows.Forms.Control.WmMouseUp(Message& m, MouseButtons button, Int32 clicks)
at System.Windows.Forms.Control.WndProc(Message& m)
at System.Windows.Forms.ButtonBase.WndProc(Message& m)
at System.Windows.Forms.Button.WndProc(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.OnMessage(Message& m)
at System.Windows.Forms.Control.ControlNativeWindow.WndProc(Message& m)
at System.Windows.Forms.NativeWindow.Callback(IntPtr hWnd, Int32 msg, IntPtr wparam, IntPtr lparam)


************** Loaded Assemblies **************
mscorlib
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.5485 (Win7SP1GDR.050727-5400)
CodeBase: file:///C:/Windows/Microsoft.NET/Framework/v2.0.50727/mscorlib.dll
----------------------------------------
WirelessCameraConnectionSetting
Assembly Version: 1.0.0.5
Win32 Version: 1.0.0.5
CodeBase: file:///C:/Users/Dale/AppData/Local/Temp/CanonOFI_TEMP/Data/WirelessCameraConnectionSetting.exe
----------------------------------------
System.Windows.Forms
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.5483 (Win7SP1GDR.050727-5400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Windows.Forms/2.0.0.0__b77a5c561934e089/System.Windows.Forms.dll
----------------------------------------
System
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.5485 (Win7SP1GDR.050727-5400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System/2.0.0.0__b77a5c561934e089/System.dll
----------------------------------------
System.Drawing
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.5483 (Win7SP1GDR.050727-5400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Drawing/2.0.0.0__b03f5f7f11d50a3a/System.Drawing.dll
----------------------------------------
WirelessCameraConnectionSetting.resources
Assembly Version: 1.0.0.5
Win32 Version: 1.0.0.5
CodeBase: file:///C:/Users/Dale/AppData/Local/Temp/CanonOFI_TEMP/Data/en/WirelessCameraConnectionSetting.resources.DLL
----------------------------------------
System.Configuration
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.5483 (Win7SP1GDR.050727-5400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Configuration/2.0.0.0__b03f5f7f11d50a3a/System.Configuration.dll
----------------------------------------
System.Xml
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.5485 (Win7SP1GDR.050727-5400)
CodeBase: file:///C:/Windows/assembly/GAC_MSIL/System.Xml/2.0.0.0__b77a5c561934e089/System.Xml.dll
----------------------------------------
Interop.WMLSS
Assembly Version: 1.0.0.0
Win32 Version: 1.0.0.0
CodeBase: file:///C:/Users/Dale/AppData/Local/Temp/CanonOFI_TEMP/Data/Interop.WMLSS.DLL
----------------------------------------
Interop.NetFwTypeLib
Assembly Version: 1.0.0.0
Win32 Version: 1.0.0.0
CodeBase: file:///C:/Users/Dale/AppData/Local/Temp/CanonOFI_TEMP/Data/Interop.NetFwTypeLib.DLL
----------------------------------------
CustomMarshalers
Assembly Version: 2.0.0.0
Win32 Version: 2.0.50727.5483 (Win7SP1GDR.050727-5400)
CodeBase: file:///C:/Windows/assembly/GAC_32/CustomMarshalers/2.0.0.0__b03f5f7f11d50a3a/CustomMarshalers.dll
----------------------------------------

************** JIT Debugging **************
To enable just-in-time (JIT) debugging, the .config file for this
application or computer (machine.config) must have the
jitDebugging value set in the system.windows.forms section.
The application must also be compiled with debugging
enabled.

For example:

<configuration>
<system.windows.forms jitDebugging="true" />
</configuration>

When JIT debugging is enabled, any unhandled exception
will be sent to the JIT debugger registered on the computer
rather than be handled by this dialog box.


My System SpecsSystem Spec
28 Dec 2014   #8
A Guy

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium x64 SP1
 
 

I'm going to see if anyone else has any ideas...

A Guy
My System SpecsSystem Spec
28 Dec 2014   #9
gregrocker

 

Quote   Quote: Originally Posted by iknowjohnny View Post
I tried but nothing from my account was there including the app i'm having issues with. Plus i have a app that scrambles text so my passwords and user names cannot be hack, and when i turned it off it wouldn't go off so i couldn't even type to get to the app in one of my email accounts. Everything i tried to do got stopped in it's tracks by some issue due to being logged in as that admin account. So i just gave up on that.
This sounds so suspect I would expect it to give chronic problems. Can you uninstall it to see if it is blocking connection?

Is the error reporting on the camera when you try to connect to router, or on the PC itself?

Can you try to connect the camera directly to the router as I did for my Dad's and then it should show up in Devices and Printers without enabling software?

Do you have a 3rd party firewall? What does the Canon Manual for your model say about this?
My System SpecsSystem Spec
29 Dec 2014   #10
iknowjohnny

windows 7 professional
 
 

Quote   Quote: Originally Posted by gregrocker View Post
Quote   Quote: Originally Posted by iknowjohnny View Post
I tried but nothing from my account was there including the app i'm having issues with. Plus i have a app that scrambles text so my passwords and user names cannot be hack, and when i turned it off it wouldn't go off so i couldn't even type to get to the app in one of my email accounts. Everything i tried to do got stopped in it's tracks by some issue due to being logged in as that admin account. So i just gave up on that.
This sounds so suspect I would expect it to give chronic problems. Can you uninstall it to see if it is blocking connection? It's not at all problematic, it only happened when i logged in as Guy told me to with the hidden admin account.

Is the error reporting on the camera when you try to connect to router, or on the PC itself?
It has nothing to do with the camera. It's an app that gives the error and won't start and doesn't need the camera to use it, just the wifi device.

Can you try to connect the camera directly to the router as I did for my Dad's and then it should show up in Devices and Printers without enabling software? No, the router is not available to me in my current living situation. I share the bill with the person i sublet from

Do you have a 3rd party firewall? What does the Canon Manual for your model say about this? No firewall
...
My System SpecsSystem Spec
Reply

 "unhandled exception occurred in your application"




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
"A disk read error occurred" and Safe Mode Issues
So yesterday, my computer was in sleep mode, working fine. I was vacuuming my room and I blew a circuit, no biggie, happens all the time, so I turn off the vacuum and lights, went down to the fuse box, and flipped the switch back. I haven't tried to use my computer until I finished vacuuming. Once...
General Discussion
changing an ".ost"file to open with "unknown" application
I changed my outlook email .ost file to open with auto cad by mistake. Initially it was opening with an Unknown application. How can I enable it to open with an unknown application again? please help
Software
unhandled exception error has occured in your application
Hi Friends, I am new here in this forum. Hope I am welcome!:) I came here with a problem that has been nagging me since morning. I tried a lot but couldnot figure out how to solve this.I did a lot of Google search but that didn't help me at all. Now I am seeking the help of experts here in this...
Software
.NET Framework 4, 'Unhandled exception has occurred in your applicatio
Hi guys, I literally couldn't find a damn fix anywhere for this issue so I've had to make my own thread here, hopefully someone will be able to help! :D. So basically, I downloaded zoombies mod for Arma 3 alpha, and their launcher uses .NET Framework, but every time I hit launch it's been coming up...
Software
.NET Framework - Unhandled exception has occurred....
https://lh4.googleusercontent.com/-HGG6maQlIW8/UCHl2ClzpUI/AAAAAAAAAGA/872XfaDMm-o/s461/Capture2104.JPG https://lh6.googleusercontent.com/-FTQIAa9_Wn4/UCHl2PqLh0I/AAAAAAAAAF8/fd4X38CGxps/s452/Capture2105.JPG
Software
Random "Bad Pool Header" and "System Service Exception" BSODs
I have been getting these "Bad Pool Header" and "System Service Exception" BSODs for about a day now (the "Bad Pool Header" one tends to pop up more often then the other btw). I ran a registry cleaner which didn't work and ran memtest this morning and it showed that my memory was fine. The BSODs...
BSOD Help and Support


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 23:30.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App