Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows Live Messenger Crash On Opening


08 Nov 2009   #1

windows 7 professional
 
 
Windows Live Messenger Crash On Opening

Hi all,I installed the latest windows live messenger on my windows 7 (version 6.1.7600) .Everything was fine until I tried opening it today.It gave me the following message:
Windows Live Messenger has stopped working.

And on problem details:

Problem signature:
Problem Event Name: APPCRASH
Application Name: msnmsgr.exe
Application Version: 14.0.8089.726
Application Timestamp: 4a6ce533
Fault Module Name: WLDCore.dll
Fault Module Version: 14.0.8089.726
Fault Module Timestamp: 4a6ce514
Exception Code: c0000005
Exception Offset: 00002ee5
OS Version: 6.1.7600.2.0.0.256.48
Locale ID: 1033

Additional information about the problem:
LCID: 1033

Read our privacy statement online:
Windows 7 Privacy Highlights - Microsoft Windows

If the online privacy statement is not available, please read our privacy statement offline:
C:\Windows\system32\en-US\erofflps.txt

can I get some help for this??
thanks,
chris


My System SpecsSystem Spec
.

08 Nov 2009   #2

 
 

Hi Chris, and welcome to sevenforums.

In order for us to explore the nature of your problem, I'd like you to provide some additional information, such as:

- does live messenger crash every time you try to run it?
- do you experience similar crashes when trying to run other programs?
- did you try to uninstall, re-download and re-install live messenger?
- does the problem persist?
My System SpecsSystem Spec
08 Nov 2009   #3

windows 7 professional
 
 

hi!
the messenger does crash every time I try to open it,but I haven't had similar problems with other programs.Anyways I uninstalled,re-downloaded and re-installed it but the problem's still here..
My System SpecsSystem Spec
.


08 Nov 2009   #4

Win7x64
 
 

Quote   Quote: Originally Posted by the4thplayer View Post
hi!
the messenger does crash every time I try to open it,but I haven't had similar problems with other programs.Anyways I uninstalled,re-downloaded and re-installed it but the problem's still here..
"Exception Offset: 00002ee5"

Is that part always the same?
My System SpecsSystem Spec
09 Nov 2009   #5

windows 7 professional
 
 

Yes it is always the same..!
My System SpecsSystem Spec
09 Nov 2009   #6

Win7x64
 
 

Quote   Quote: Originally Posted by the4thplayer View Post
Yes it is always the same..!
Sorry, it's not practical to try to approach this as a "debugging" ex3rcise because MS doesn't share symbolic info for that DLL and even the exports are done by ordinal, not by name (to obfuscate the inner workings of the code and make it more difficult for prying eyes like mine ).

As a suggestion, test what happens if you sign in under a different Messenger identify, or even log on to Windows as a different user.

===============================================

0:000:x86> uf WLDCore!Ordinal35
WLDCore!Ordinal35:
719f2ebc 8bff mov edi,edi
719f2ebe 55 push ebp
719f2ebf 8bec mov ebp,esp
719f2ec1 51 push ecx
719f2ec2 51 push ecx
719f2ec3 833de4b49f7102 cmp dword ptr [WLDCore!Ordinal61+0x41c (719fb4e4)],2
719f2eca 56 push esi
719f2ecb 0f94c0 sete al
719f2ece 84c0 test al,al
719f2ed0 0f94c0 sete al
719f2ed3 57 push edi
719f2ed4 8bf9 mov edi,ecx
719f2ed6 50 push eax
719f2ed7 e8baf9ffff call WLDCore!Ordinal21 (719f2896)
719f2edc 50 push eax
719f2edd 8d4df8 lea ecx,[ebp-8]
719f2ee0 e876ffffff call WLDCore!Ordinal22+0x592 (719f2e5b)
719f2ee5 8b7704 mov esi,dword ptr [edi+4] // BOOM! EDI must be bad at this point.
719f2ee8 eb0d jmp WLDCore!Ordinal35+0x3b (719f2ef7)
My System SpecsSystem Spec
11 Nov 2009   #7

windows 7 professional
 
 

I tried logging on to another profile and it did work..>!!any ideas on how to make it work on my profile too...???
My System SpecsSystem Spec
11 Nov 2009   #8

7600.20510 x86
 
 

Yeah. Look in your specific user folder for any files/folders related to the software and delete. You might have to reinstall the software after, though. Maybe not.

Look in - C:\Users\{your user name}\AppData\Roaming

and also go into the Microsoft folder from there and check.

And instead of roaming, you could also look within the local folder too.
My System SpecsSystem Spec
19 Dec 2009   #9

Windows 7 Ultimate 64-bit
 
 
Had the same problem - found a solution

I had the same problem. Found out its because I linked my user account to an online ID - a Windows Live one at that!

I removed the link and now Windows Live Messenger works fine
My System SpecsSystem Spec
30 Dec 2009   #10

Windows 7
 
 
Solution

How do I "un-link" my online ID from my Windows live user account? Please help!
My System SpecsSystem Spec
Reply

 Windows Live Messenger Crash On Opening




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 05:53 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33