Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Error 1935 installing ms visual c++ x64 2008 and others

26 Jun 2015   #11
mikesndbs

Windows 7 pro 64bit SRP1
 
 

Ran 968003 as cmd file.
Sadly no effect, good idea all the same.


My System SpecsSystem Spec
.
26 Jun 2015   #12
mikesndbs

Windows 7 pro 64bit SRP1
 
 

Quote   Quote: Originally Posted by GokAy View Post
I went through the log file (I am not a programmer or anything) and as far as I can see, the problem is here:

Code:
MSI (s) (34:78) [11:31:55:561]: Executing op: SetTargetFolder(Folder=C:\Windows\winsxs\amd64_microsoft.vc90.atl_1fc8b3b9a1e18e3b_9.0.30729.6161_none_0a1fd3a3a768b895\)
MSI (s) (34:78) [11:31:55:561]: Executing op: SetSourceFolder(Folder=1\Windows\winsxs\ulATLx64\)
MSI (s) (34:78) [11:31:55:561]: Executing op: AssemblyCopy(SourceName=ax64.dll|atl90.dll,SourceCabKey=ul_atl90.dll.30729.6161.Microsoft_VC90_ATL_x64.QFE,DestName=atl90.dll,Attributes=0,FileSize=176456,PerTick=65536,,VerifyMedia=1,ElevateFlags=4,,,,ComponentId={74C57B6B-FF6E-3825-BED2-78E14E3E0E3C},,,,AssemblyMode=0,)
MSI (s) (34:78) [11:31:55:561]: Assembly Error:The system cannot find the path specified.
 
MSI (s) (34:78) [11:31:55:561]: Note: 1: 1935 2: {74C57B6B-FF6E-3825-BED2-78E14E3E0E3C} 3: 0x80070003 4: IAssemblyCache 5: CreateAssemblyCacheItem 6: Microsoft.VC90.ATL,version="9.0.30729.6161",publicKeyToken="1fc8b3b9a1e18e3b",processorArchitecture="amd64",type="win32" 
MSI (s) (34:78) [11:31:55:561]: Assembly Error (sxs): Please look into Component Based Servicing Log located at -312265544ndir\logs\cbs\cbs.log to get more diagnostic information.
MSI (s) (34:78) [11:31:57:903]: Product: Microsoft Visual C++ 2008 Redistributable - x64 9.0.30729.6161 -- Error 1935.An error occurred during the installation of assembly 'Microsoft.VC90.ATL,version="9.0.30729.6161",publicKeyToken="1fc8b3b9a1e18e3b",processorArchitecture="amd64",type="win32"'. Please refer to Help and Support for more information. HRESULT: 0x80070003. assembly interface: IAssemblyCache, function: CreateAssemblyCacheItem, component: {74C57B6B-FF6E-3825-BED2-78E14E3E0E3C}
 
Error 1935.An error occurred during the installation of assembly 'Microsoft.VC90.ATL,version="9.0.30729.6161",publicKeyToken="1fc8b3b9a1e18e3b",processorArchitecture="amd64",type="win32"'. Please refer to Help and Support for more information. HRESULT: 0x80070003. assembly interface: IAssemblyCache, function: CreateAssemblyCacheItem, component: {74C57B6B-FF6E-3825-BED2-78E14E3E0E3C}
Quote:
Assembly Error (sxs): Please look into Component Based Servicing Log located at -312265544ndir\logs\cbs\cbs.log to get more diagnostic information.
See if you can spot anything in cbs.log, and attach if size is manageable.

Maybe one of our programmers would know what this means?


That does look interesting.

CBS log is here I could not find the ref but will keep looking.
https://www.dropbox.com/s/ggwpaoo96g....6.15.log?dl=0
My System SpecsSystem Spec
26 Jun 2015   #13
mikesndbs

Windows 7 pro 64bit SRP1
 
 

Hi again, yes tried 2005 and same error. TrustedInstaller seems to have all contol.
My System SpecsSystem Spec
.

26 Jun 2015   #14
GokAy

Windows 7 Ultimate x64 SP1
 
 

Please run in elevated cmd: sfc /scannow

Also scan with Malwarebytes Anti-Malware free (if you haven't already)

Edit: Do you have any Windows Updates pending? Do they install correctly?
My System SpecsSystem Spec
26 Jun 2015   #15
mikesndbs

Windows 7 pro 64bit SRP1
 
 

Hi, sadly have done those ideas and no updates pending other than some optionals that don't apply to me.
Very grateful for your help all the same.
My System SpecsSystem Spec
27 Jun 2015   #16
mikesndbs

Windows 7 pro 64bit SRP1
 
 

Hi

After finding the error access denied winsxs/installtemp I have now set the permissions to that folder so that for the moment everyone has full control.

I re ran the installer for Visual 2008 but again it failed.
You can see here the error message and the point it seemed to fail on.
On checking the log files I don’t see access denied anymore.
What I do see in dd_vcredistMSI75E8 is this:

MSI (s) (00:3C) [09:40:39:636]: File: C:\Program Files\Common Files\Microsoft Shared\VC\msdia90.dll; To be installed; Won't patch; No existing file
MSI (s) (00:3C) [09:40:39:636]: Source for file 'FL_msdia71_dll_2_60035_amd64_ln.3643236F_FC70_11D3_A536_0090278A1BB8' is compressed
MSI (s) (00:3C) [09:40:39:683]: Executing op: SetTargetFolder(Folder=C:\Windows\winsxs\amd64_microsoft.vc90.atl_1fc8b3b9a1e18e3b_9.0.21022.8_none_ 7644f34b9721eccf\)
MSI (s) (00:3C) [09:40:39:683]: Executing op: SetSourceFolder(Folder=1\Windows\winsxs\ulATLx64\)
MSI (s) (00:3C) [09:40:39:683]: Executing op: AssemblyCopy(SourceName=ax64.dll|atl90.dll,SourceCabKey=ul_atl90.dll.21022.08.Microsoft_VC90_ATL_x64 .RTM,DestName=atl90.dll,Attributes=0,FileSize=179704,PerTick=65536,,VerifyMedia=1,ElevateFlags=4,,,, ComponentId={2A030FEB-29B5-314B-97B5-ED38673CC885},,,,AssemblyMode=0,)
MSI (s) (00:3C) [09:40:39:683]: Assembly Error:The system cannot find the path specified.

And:

Property(S): SecureCustomProperties = IE501FOUND.3643236F_FC70_11D3_A536_0090278A1BB8;INSTALLBLOCKFOUND.3643236F_FC70_11D3_A536_0090278A1B B8;JSHFOUNDVER;MMCFOUND.3643236F_FC70_11D3_A536_0090278A1BB8;NEWERPRODUCTVERSIONDETECTED;OCMFOUNDVER ;OCMFOUNDVERLANG;REDISTFOUNDVER;REDISTFOUNDVERLANG;UNINSTALLBLOCKFOUND.3643236F_FC70_11D3_A536_00902 78A1BB8
Property(S): NEWERPRODUCTVERSIONDETECTED = {9A25302D-30C0-39D9-BD6F-21E6EC160475}
Property(S): MsiLogFileLocation = C:\Users\MIKE&C~1\AppData\Local\Temp\dd_vcredistMSI75E8.txt
Property(S): PackageCode = {4058F55C-D581-49DD-8065-96BBBE4AD8D3}
Property(S): ProductState = -1
Property(S): PackagecodeChanging = 1
Property(S): USING_EXUIH = 1
Property(S): LOCPRODUCTNAME = Microsoft Visual C++ 2008 Redistributable
Property(S): CURRENTDIRECTORY = d:\197fa2011e649fd12904


So this INSTALLBLOCKFOUND I wonder what is going on?

Here is a link to the new logs and screen shot
https://www.dropbox.com/s/pb4nh23z2ej73zt/Logs.zip?dl=0
My System SpecsSystem Spec
27 Jun 2015   #17
GokAy

Windows 7 Ultimate x64 SP1
 
 

Kind of out of ideas here :P

Try cleaning with CCleaner, scan registry too (make sure to export/backup registry before cleaning).
Uninstall AV and try again.
My System SpecsSystem Spec
27 Jun 2015   #18
mikesndbs

Windows 7 pro 64bit SRP1
 
 

Well my good friend I have fixed it, and very many thanks for helping me with this.

It’s fixed!!!!

Here is how.
I ran Tweaking.com\Windows Repair (All in One)
Did the reparse repairs and then went to the main repair after backing up registry and making a restore point.
I then selected only the following repairs:
Reset Registry Permissions.
Reset file permissions (C: only)
Remove policies set by infections.
I ran this in safe mode, using msconfig as admin, boot/ minimal with network.
After this I verified I had permissions on winsxs and created the folder InstallTemp.C:\Windows\WinSxS\InstallTemp
I then installed Visual c++ 2005 first, then 2008 x86 and x64 versions.

It all worked

What I need to check now is that do I need to re set folder permissions in order to be safe from attack by viruses etc?
My System SpecsSystem Spec
27 Jun 2015   #19
GokAy

Windows 7 Ultimate x64 SP1
 
 

You should start considering a repair install or better yet a clean
install.
Repair Install

Clean Install Windows 7
or (if OEM) Clean Reinstall - Factory OEM Windows 7

You can get an installation ISO from Microsoft Software Recovery if your copy of Windows is
retail


Bah, haha. Good job! First account of fixing this issue as far as I know!
My System SpecsSystem Spec
27 Jun 2015   #20
GokAy

Windows 7 Ultimate x64 SP1
 
 

What I don't understand is you did run tweaking.com aio repair before, no? Maybe the default options were needed to be changed as you did this time?

Creating this one - C:\Windows\WinSxS\InstallTemp was a good idea
My System SpecsSystem Spec
Reply

 Error 1935 installing ms visual c++ x64 2008 and others




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Unable to install MS Visual C++2008 error 1935 etc
Hi guys I really need your help. I am trying to install VideoStudioX8_LimitedTrial_64bit and it fails at the start no matter what. I think I have traced it to MS Visual C++2008, downloaded that on its own and got the same error. I have tried all I can think of including the MS Mr Fixits. ...
Software
Error 1935, Microsoft Visual C++ 2008 Redistributable Package (x86)
I once had this before when I tried to download Age of Empires Online. I decided one game isn't worth the problem, and I'd avoid all "Games for Windows" games because of this issue. Now, I recently bought a Vita and now I can't download Content Manager Assistant because of this, so now it is...
Software
Error 1935 HRESULT: 0x80070003 when installing Microsoft Visual 2008
Hello, I was trying to install XNA 3.1 when I started receiving some VC90 errors. I uninstalled Microsoft Visual C++ 2008 32 and 64, but receive an error when reinstalling. Error 1935 HRESULT: 0x80070003. I ran SFC /SCANNOW. CBS came back OK. I ran the readiness tool. CheckSUR says I'm fine....
Performance & Maintenance
Please help! Cannot install any MS Visual C++! Error 1935
So, I'm just going to get straight to the point. I'm trying to install Microsoft Visual C++ 20xx so I can play games like Grand Theft Auto IV or BeamNG Drive, Ship Simulator Extremes, etc., but every time I try to install any of the Microsoft Visual C++ versions (anything between 2004 and 2013) it...
Software
Error installing visual c++2008 redistributable
greetings, my first post, exactly as the title says. error log: Problem Event Name: BEX64 Application Name: install.exe_Microsoft® Visual Studio® 2008 Application Version: 9.0.21022.8 Application Timestamp: 47314dc8 Fault Module Name: install.exe Fault Module...
BSOD Help and Support
Error 1935: Microsoft Visual C++ 2008 Redistributable x86 Install
I was trying to install Visual Studio 2010 and started encountering errors with the C++ distributable package during install, so I decided to install it by itself. Whenever I try and install it, it stops on Feature: FT_VC_Redist_openMP_x86 and I receive the following error message before it...
Software


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 04:14.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App