Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Do i have the wrong "Net framework" installed?

04 Oct 2015   #1
jonnyhillow

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 
Do i have the wrong "Net framework" installed?

Hello, i reinstalled Win 7 SP1 and i have a 64 bit laptop , my Kaspersky would not install unless i had (Net Framework 4.0 or higher) installed on my computer so thats the first thing i did .

Is there a newer version than the one shown in the screenshot?

Thank you




Attached Thumbnails
Do i have the wrong "Net framework" installed?-untitled.jpg  
My System SpecsSystem Spec
.
04 Oct 2015   #2
torchwood

W7 home premium 32bit/W7HP 64bit/w10 tp insider ring
 
 

That is the latest version of NF, and kapersky is installed,
I suspect that when you rebooted your comp the last time they installed in the right order, ie after you had the warning error they were both pending.

Roy
My System SpecsSystem Spec
04 Oct 2015   #3
Mellon Head

Win 7 Pro x64/Win 10 Pro x64 dual boot
 
 

The latest version of the .NET framework is 4.6. You can get it from here.

Download Microsoft .NET Framework 4.6 (Web Installer) for Windows Vista SP2, Windows 7 SP1, Windows 8, Windows 8.1, Windows Server 2008 SP2 Windows Server 2008 R2 SP1, Windows Server 2012 and Windows Server 2012 R2 from Official Microsoft Download Ce

I would also try installing version 4.0. That is required for many programs that explicitly require a specific .NET framework version. All .NET versions are supposed to be backwards compatible, but it seems (in my limited experience) that certain programs need a specific version. In any case, it's probably a good idea to install 4.0 if it will install.

Here is the download link:

https://www.microsoft.com/en-us/down....aspx?id=17851
My System SpecsSystem Spec
.

04 Oct 2015   #4
Alejandro85

Windows 7 Ultimate x64
 
 

You already have .Net 4 installed as your screenshot shows.

Version 4.5.2 (and also 4.5, 4.5.1 and 4.6) are just minor upgrade over 4.0 and completely replace it. Programs targeting 4 will actually use all those transparently.
Consider all those to be "service packs" over 4, just minor updates.
My System SpecsSystem Spec
04 Oct 2015   #5
jonnyhillow

Microsoft Windows 7 Home Premium 64-bit 7601 Multiprocessor Free Service Pack 1
 
 

Thank you very much gentlemen .
My System SpecsSystem Spec
Reply

 Do i have the wrong "Net framework" installed?




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
BSOD when browsing, error "Driver Framework"
Hello all. So I did a format a few days ago. Installed basic programs and drivers. Today I had two BSOD's out of nowhere just browsing or doing whatever, nothing heavy loading. Unfortunately I was not able to read the error, but I do know it said something about "driver framework". Obviously...
BSOD Help and Support
.NET framework "Update Manager Has Stopped Working"
I'm not sure how or where to address this issue. As of 4 days ago, I am randomly having a box pop up that says "Update Manager Has Stopped Working" I've been able to use the Realtime Data through my Avast to find that it's C:\Windows\Microsoft.NET\Framework64\v2.0.50727\dw20.exe that is...
Software
.NET Framework 4.5 "Installation failed with error code: (0x80070643)"
Hi guys. I wanna update my .net framework with an offline installer, but this error always shows up. I tried finding some fix but not even a single one worked. So I was hoping that maybe you could help me with this. :cry: Here's the log file; OS Version = 6.1.7600, SP = 0.0, Platform 2 ...
Software
Blue screen error 0x00000044; "Kernel Mode Driver Framework Runtime"
This shut down occurs ONLY when I am using 3 peripheral usb devices simultaeously and it doesn't happen right away. Sometimes it's an hour and sometimes it's several hours before it crashes. Now there is an executive program that is controlling all of the usb devices, if that makes any difference...
BSOD Help and Support
Cannot install "Security Update for Microsoft .NET Framework 3.5.1"
Hi, I have an update which refuses to install: Security Update for Microsoft .NET Framework 3.5.1 on Windows 7 and Windows Server 2008 R2 SP1 for x64-based Systems (KB2742599) Download size: 8.0 MB You may need to restart your computer for this update to take effect. Update type:...
Windows Updates & Activation
"Microsoft .NET Framework Version 2.0 is required to continue." Error
Hi, I hope I'm not asking this for the millionth time here, as I tried a search but am afraid it all just confused me more. I believe my problem is related to the Dell all-in-one printer I want to work with my Dell laptop. Recently, Windows updated and I now get this message again upon start up:...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 13:24.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App