Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: VB6 on Win 7 - problem on rebuilt system

27 Jan 2016   #1
tpriest

Windows 7 Professional 64-bit
 
 
VB6 on Win 7 - problem on rebuilt system

I've used VB6 for some very simple domestic programs for many years, it does the job. For 4 years or so my Win 7 Pro PC has run VB6 ok.

I upgraded the PC to an SSD 2 weeks and have clean installed Win 7 Pro and reinstalled all the apps.

VB6 installs and runs but...

One program has an UpDown control and when VB6 loads the project I get errors on load and a log entry saying "Class MSComCtl2.UpDown of control UpDown was not a loaded control class"

The project file for the program includes these 3 lines

Object={F9043C88-F6F2-101A-A3C9-08002B2F49FB}#1.2#0; COMDLG32.OCX
Object={831FDD16-0C5C-11D2-A9FC-0000F8754DA1}#2.1#0; MSCOMCTL.OCX
Object={86CF1D34-0C5F-11D2-A9FC-0000F8754DA1}#2.0#0; MSCOMCT2.OCX

Searching the Registry there are entries for them with those CLSIDs, and all 3 .OCX files are in SysWow64.

Despite this error the VB project loads and runs - albeit with the UpDown control.

It would seem therefore that I've not done something this time installing VB6 that I must have done earlier.

I have Ccleaner & Belarc listings from the pre-rebuild system and there's no sign of any components other than VB6 itself being installed, no MSDN, no MDAC.

Any thoughts on how to get these ActiveX controls enabled?


My System SpecsSystem Spec
.
27 Jan 2016   #2
Mellon Head

Win 7 Pro x64/Win 10 Pro x64 dual boot
 
 

Is the up/down control part of a VB6 add on package? For instance, Visual Studio often has add on extensions that offer free controls, but they have to be downloaded and installed.

Does VB6 have extensions like that? If so, it might be missing.

One other thing... Are you missing a DLL or resource file of any kind for this project?
My System SpecsSystem Spec
29 Jan 2016   #3
tpriest

Windows 7 Professional 64-bit
 
 

Thaks for that.

UpDown is one of the controls included in MSCOMCTL2.OCX.

I can only assume that somehow I've failed to properly set it up.

I've also just realised that the first error messages when loading the VB project is Object library not registered. There are 2 such messages, and will be for MSCOMCTL.OCX and MSCOMCTL2.OCX.

I've tried an elevated command prompt and run regsvr32 in the syswow64 directory; this completed successfully but has made no difference. I'm guessing that somehow they're not registered with VB6, but if that is the case I can't see how to do that.
My System SpecsSystem Spec
.

29 Jan 2016   #4
Mellon Head

Win 7 Pro x64/Win 10 Pro x64 dual boot
 
 

You might be right, and if something is not registered correctly, you might want to try a reinstall of VB6.
My System SpecsSystem Spec
29 Jan 2016   #5
tpriest

Windows 7 Professional 64-bit
 
 

I've uninstalled and reinstalled it three times already. It's so frustrating as before the rebuild it worked just fine.
My System SpecsSystem Spec
29 Jan 2016   #6
Mellon Head

Win 7 Pro x64/Win 10 Pro x64 dual boot
 
 

Just thought of something. Do you have the appropriate .NET service packs installed? Version 3.5 should do.

https://www.microsoft.com/en-ca/down...ils.aspx?id=22
My System SpecsSystem Spec
30 Jan 2016   #7
tpriest

Windows 7 Professional 64-bit
 
 
VB6 on Win 7 - problem on rebuilt system - hangs head in shame

I tried to install .NET 3.5 on my system but it just vanished into the ether. Then found https://social.msdn.microsoft.com/Forums/vstudio/en-US/d99de752-2131-4408-a693-39ee3e7d4c7c/cannot-install-net-35-on-windows-7?forum=netfxsetup which says Windows 7 ships with .NET 3.5 SP1 and refers to a verification tool, which indeed did tell me that it was already installed.

However, I uninstalled VB6 and tried again. Still no joy.

Then I found that in the IDE where the controls are shown right click brings up a dialog enabling the adding of components. Browsing the list I found a couple which referenced the 'problem' files. Added them, and now the VB6 project loads and runs error free.

Oh dear. I really should have spotted this earlier

My apologies for all this, however many thanks for the replies which made me think more and to persevere.

Have a virtual pint on me
My System SpecsSystem Spec
30 Jan 2016   #8
Mellon Head

Win 7 Pro x64/Win 10 Pro x64 dual boot
 
 

I'll have a pint, no problem.

I'm glad you got it working. If you could, please mark the thread as solved so other members know that it's no longer an outstanding issue.
My System SpecsSystem Spec
30 Jan 2016   #9
tpriest

Windows 7 Professional 64-bit
 
 

Enjoy your e-pint.

And thanks for reminding to mark the thread as solved, done.
My System SpecsSystem Spec
Reply

 VB6 on Win 7 - problem on rebuilt system




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Rebuilt PC with random BSOD occurrences
Dear forum, after a Windows and Driver update in December (the PC had not been in use for six months, switched off, not moved or tampered with), continuous BSODs ensued, the update also never fully worked. In short: Last week, I updated the BIOS for the first time and re-installed Windows...
BSOD Help and Support
XP Mode from previous build will not run on rebuilt PC.
Hi, I have an XP Mode PC running on my Windows 7 Ultimate 64bit PC all the time as it runs a small mail server and a Telnet BBS (the BBS requires an 8bit program hence the need for an XP Mode PC). Yesterday (and a few times in the past), I rebuilt my PC and installed all updates etc and...
Virtualization
Trouble re-activating rebuilt
Some History: 1. Original Desktop setup : CofA= Windows OEM XP Home Edition, with Service Pack 2 2. Upgraded to: Windows 7 Home Premium, 32-bit, using CD media purchased. Added video card with marginal performnce success. 3. Rebuilt computer : with new mother board and...
Windows Updates & Activation
BSOD On Rebuilt Laptop
I am getting intermitent BSOD since rebuilding my Packard Bell BG45-U300 with WIndows 7 Professionsal 64 bit. I have checked the attached minidump and believe it indicates an issues with lsass.exe? Not sure what to do next, so any help would be appreciated.
BSOD Help and Support
Thumbnails constantly being rebuilt
I've put up with this issue for a long time but it's really starting to aggravate me lately. I have thumbnail view enabled in folder options but every couple of days or it seems daily as of late, all my thumnails revert back to generic icons - folder icons, videos, pictures etc. God only knows how...
Customization
Rebuilt DNA : Cloned Neanderthals
Rebuilt DNA Could Lead to Cloned Neanderthals
Chillout Room


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 08:58.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App