Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Installers not starting from outside OS drive

12 Dec 2009   #1

Windows 7 Pro x64
 
 
Installers not starting from outside OS drive

I have some installers that worked fine in XP but don't install when run from outside the OS partition.

All 4 I tried should be NSIS-type installers(but it does not apply to all NSIS installers, the Imgburn one runs fine outside OS partition):
mkx.y.9.exe - Haali Media Splitter
SetupDVDDecrypter_3.5.4.0.exe
wa5_coloreditor_2_2_0.exe - Wianmp Color Editor
WaSDP_1.11.exe - Winamp Skin Dev Pack

From the event log, it seems to be some ntdll.dll fault.

But they install if I move the problem installers to the OS partition.
By the way, I'm on Windows 7 Pro x64.

My System SpecsSystem Spec
.

12 Dec 2009   #2

Windows 7 Pro & Vista Home Premium
 
 

Quote:
outside the OS partition
Could you explain that a little better?

You can use Universal Extractor to extract the contents pg these files.
My System SpecsSystem Spec
13 Dec 2009   #3

Windows 7 Pro x64
 
 

Quote   Quote: Originally Posted by reghakr View Post
Quote:
outside the OS partition
Could you explain that a little better?
I have 3 hard drives in my computer.
The Windows 7 partition is on one hard drive.
The downloaded files are in a partition on a second hard drive.
The said installers are part of the downloaded files.

I want to know why they can't run from there in Windows 7 but is able to run from there in the older XP.
My System SpecsSystem Spec
.


13 Dec 2009   #4

Windows 7 Pro & Vista Home Premium
 
 

Have you trued Running as Administrator
My System SpecsSystem Spec
13 Dec 2009   #5

Windows 7 Pro x64
 
 

Tried running it as admin.
The problem persists.

As said in the first post, the installers run fine if moved to the OS partition (e.g C:/)
But why they run fine outside the OS partition in XP?
My System SpecsSystem Spec
07 Jan 2010   #6

Windows 7 Pro x64
 
 

Ok, I finally solved this one.
Its strange but on more fiddling I found out that the said installers only refuse to run in that one folder.
They run fine in another folder on the same HDD.

Perhaps its some path corruption when I was setting the path of the Downloads user folder to that folder.

I solved it by moving the files to another folder then deleting the old folder.
My System SpecsSystem Spec
Reply

 Installers not starting from outside OS drive





Thread Tools



Similar help and support threads for2: Installers not starting from outside OS drive
Thread Forum
Optical drive clicks twice when starting video on hard drive- Music, Pictures & Video
The future of Adobe installers? News
Silent Installers Installation & Setup
Hard drive is starting to fail Hardware & Devices
Pocket Drive comes up when starting Win 7 Hardware & Devices
Installers. Why? Chillout Room
Installers use wrong drive/partition, fix? General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:26 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33