Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: ASIO4ALL and Traktor 3 / Cannot listen anything

20 Dec 2009   #1

Windows 7 Ultimate (Greek)
ASIO4ALL and Traktor 3 / Cannot listen anything

Hello all,

I am using ASIO4ALL with Traktor 3 so that I am able to get 2 channels out of my soundcard.
What I mean is that I am using one channel for the speakers and another channel for my headphones.
I need the headphones so as to listen to the "Cue" Deck.

I have connected my speaker system to my soundcard with one cable.
But I had figured out (when I used XP) that I was able to have what I want when the settings were 5.1 speaker system at realtek settings.

Now I cannot listen to anything from Traktor 3 when using ASIO4ALL.
What can I do?

Thank you for your time.

My System SpecsSystem Spec
20 Dec 2009   #2

Windows 7 Home Premium x64

This is mystery to me as well. I tried using ASIO4ALL with FL Studio 8/9 but couldn't get any sound at all...
My System SpecsSystem Spec
02 Dec 2011   #3

Windows 7 Home Premium 64bit
Problem solved


That's what I wrote to NI support:
"Support hello,

I recently consulted you after my Traktor Pro 2 crashed, while I was trying to
change the latency settings in my built-in Generic Low Latency ASIO soundcard. I followed your advice, and downloaded ASIO4ALL. Since I want to work with earphones, I plugged in my USB earphones, (it's actually regular earphones with a small PL connector, that connect to an external soundcard, that connects to the computer via USB). Then I tried to choose in Preferences>Audio Setup>Generic USB Audio device (shared mode), and the system crashed.
What should I do?"

Here is the NI support reply:

But this is exactly the reason why you have to use ASIO4ALL and NOT "Generic USB Audio device (shared mode)". Whatever device you use over a shared mode WASAPI driver may cause heavy problems, even crashes are possible.

Therefore install ASIO4ALL, then SELECT ASIO4ALL as soundcard, then use the
ASIO4ALL control panel to configure it so that it uses your "Generic USB Audio
device" as output. Maybe you should have a look into the ASIO4ALL manual, which describes this in all detail.

To use this driver, please download the latest ASIO4ALL driver from the following link:

Please follow all the instructions on this site to install and use this software

(Please note that this driver is not manufactured or supported by NATIVE
INSTRUMENTS and we cannot guarantee its performance.)

Best regards
Native Instruments Support Team"

I did as they said, installed ASIO4ALL, launched Traktor Pro 2, went to Preferences>Audio Setup>Chose "ASIO4ALL v2" as my "Audio Device">Settings>Made sure both my earphones and soundcard were highlighted>Exited "settings">went to "Output Routing">chose "Output Monitor" Left and right as "USB Audio device" (my earphones)>Chose "Output Master" Left and Right as "HD Audio output" 1 and 2 (my soundcard)>Close.

I also made sure that the earphones volume was up, and that the "cue/mix" button was on the "mix" side. It works fine now, just like virtual DJ
My System SpecsSystem Spec


 ASIO4ALL and Traktor 3 / Cannot listen anything

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Traktor Pro 2 installation problem
I run into the following issue: How do I install Traktor again, I had an older version that I deleted it but now when I want to install a new version, I have the following error:
Black Screen Crash after Ipod or Traktor S4 plugged in..
Hi folks .. I'm new here, and looking for some help! I'm usually o.k with these type of things but this is killing me! Im getting the black freeze screen after plugging in my Ipod or Traktor S4, It will not respond and needs a reboot every time. it usually takes from 30 secs to 5 mins to black...
BSOD Help and Support
How to setup asio4all in DAW software?
I'm trying to get sound output from either FL Studio, Reason, or Ableton Live to my headphones which are plugged into my Auzentech Bravura. I go into either software, click audio settings, then select ASIO4ALL as the Input/Output, click show ASIO panel. When I select Auzen X-Fi Bravura 7.1, the sub...
Sound & Audio
Sound stopped working after asio4all
I installed asio4all v2.10 so i could use my computer as an amp for my guitar but was not happy with the quality so i uninstalled it and now my sound doesnt work at all. I even tried reinstalling realtek drivers and realtek hd audio but still had the issue. When i uninstalled it i still had the...
Sound & Audio
Soundblaster Live 24 External ticking (and Traktor pro)
Hy! I have the Creative Soundblaster live 24 external audio card. So my first problem is that the sound starts ticking randomly from time to time. Primarily if 2 programs are running at the same time, e.g. , firefox with youtube playing and winamp or bsplayer etc. This stops when i close one of...
Sound & Audio
ASIO4ALL not working.
I am trying to use ASIO4ALL in order to work with my DAW Ableton Live 8.0.9. I get no sound at all with this driver. Anyone know the solution? Dean.

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:48.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App