Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: IIS7, ASP and access db's


05 Mar 2009   #1

Windows 7
 
 
IIS7, ASP and access db's

Hello, I was wondering if there were any IIS7 guru's out there?

I am developing an exsiting website that is up and running that uses access databases. I developed it on XP and have upgraded my pc to vista64 and now windows 7. I downloaded the working site to wwwroot\testsite\ followed the tutorials on the microsoft website for setting up IIS7. I had the site viewing and accessing the data in the database, but something was not quite right so. i deleted the virtual directories and website in IIS7 and started again. Now of course!, when i try and sign on to the website locally localhost/testsite the index.asp page views nicely, but the page that should display after you sign on is comming up with the folowing error:

ADODB.Command error '800a0e7a'
Provider cannot be found. It may not be properly installed.
/testsite/Helper_JS.asp, line 15

the start fo Helper_JS.asp is:
<!-- #include file="HelperGroupsRulesJS.asp" -->
<!-- #include file="Mail_JS.asp" -->
<% // ASP JavaScript
var WA_Auth_Separator = "||";
function WA_AuthenticateUser(WA_Auth_Parameter){
var UserAuthenticated = false;

var WA_Auth_loginSQL = "SELECT " + WA_Auth_Parameter.sessionColumns.join(',') + " FROM " + WA_Auth_Parameter.tableName + " WHERE ";
var WA_Auth_login_cmd;
WA_Auth_login_cmd = Server.CreateObject("ADODB.Command");
WA_Auth_login_cmd.ActiveConnection = WA_Auth_Parameter.connection;

the database connection string is:

<%
// FileName="Connection_ado_conn_string.htm"
// Type="ADO"
// DesigntimeType="ADO"
// HTTP="false"
// Catalog=""
// Schema=""
var MM_conninaura_STRING = "provider=microsoft.Jet.OLEDB.4.0;data source=G:\\inetpub\\wwwroot\\testsite\\db2\\testDB.mdb;"
%>

However i know the connection string works as you can connect to the databse in dreamweaver 8 and view the tables, but when you view the files in the browser and add records or search records you get the error. I have checked each jet engine dll files and they are all present and correct. I have also registered using regsvr32 most of the dll files. I am not sure why it worked and then stopped working! I am at a loss now, any ideas?


My System SpecsSystem Spec
.

Reply

 IIS7, ASP and access db's




Thread Tools



Similar help and support threads for2: IIS7, ASP and access db's
Thread Forum
Host a Website - IIS7.5 Tutorials
How to Setup a web site with iis7 Network & Sharing
IIS7 404.0 Error on Facebook Browsers & Mail
IIS7. Is there any possibility of mail service? Software
IIS7 Slow Problem Browsers & Mail
phpBB + MySQL + IIS7?? Network & Sharing
IIS7 Failing BSOD Help and Support

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:49 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33